在线检测未来函数

通达信箱体K线主图指标公式

来源:Internet,编辑:股旁网,2013-02-02

本指标的特点是用好了可以有利于高抛低吸和判断趋势突破。本指标最大讲究的地方是参数N的选择。参数N不是固定值,而是根据个股的特性而定。先说一个选择的方法,就是把大阳(或大阴)K线的次日作为箱体K线的起始点。

N:=13;
BC:=(H*0.382+L*0.618+O*0.382+C*0.618)/2;
LJ:=IF(INDEXC=C,BC,(BC+AMOUNT/(V*100))/2),COLORGRAY;
HT:=REF((HHV(LJ,N*0.691)+HHV(LJ,N)+HHV(LJ,N*1.309))/3,1),LINETHICK,COLORRED;
LT:=REF((LLV(LJ,N*0.691)+LLV(LJ,N)+LLV(LJ,N*1.309))/3,1),LINETHICK,COLORGREEN;
ZT:=(HT+LT)/2,LINETHICK,COLORYELLOW;
STICKLINE(ISLASTBAR=1 AND LJ<ZT,HT,LT,N*8,0),COLORBLUE;
STICKLINE(ISLASTBAR=1 AND LJ=ZT,HT,LT,N*8,0),COLORGRAY;
STICKLINE(ISLASTBAR=1 AND LJ>ZT,HT,LT,N*8,1),COLOR6600FF;
{www.gupang.com 股旁网_通达信股票指标公式}
STICKLINE(ISLASTBAR=1,ZT,ZT,N*8,0),COLORYELLOW;
STICKLINE(OPEN>=CLOSE,HIGH,LOW,0,0),COLORFFCC00;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3,0),COLORFF9F68;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.8,0),COLORFF9900;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.5,0),COLORFFAA11;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2,0),COLORFFBB11;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1,0),COLORFFCC22;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,0.4,0),COLORFFDD22;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,0.2,0),COLORFFEE33;
STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,0,0),COLORFFFF33;
STICKLINE(CLOSE>OPEN,HIGH,LOW,0,0),COLORRED;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0),COLORBROWN;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.8,0),COLOR3300CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.5,0),COLORBROWN;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0),COLOR6633CC;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.6,0),COLOR3333FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.4,0),COLOR6633FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.2,0),COLOR3366FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.1,0),COLOR6666FF;
箱顶:HT,LINETHICK,COLORRED;
箱底:LT,LINETHICK,COLORGREEN;
箱中:ZT,LINETHICK,COLORYELLOW;

通达信箱体K线主图指标公式

 

相关文章