在线检测未来函数

通达信量能抄底指标公式

来源:Internet,编辑:股旁网,2013-02-05

DIFF:=EMA(CLOSE,3)-EMA(CLOSE,8);
DEA:=EMA(DIFF,5);
MACD:=2*(DIFF-DEA);
A1:=EMA(DIFF,5)*100;
A2:=((EMA(CLOSE,3)-EMA(CLOSE,8)))*100;
A3:=IF(A2>0,A2,50),POINTDOT,COLORRED;
A4:=IF(A2<0,A2,50),POINTDOT,COLORGREEN;
动能A:=A2,COLOR00FFFF,LINETHICK2;
动能B:=A1,COLORFFFF00,LINETHICK2;
DRAWBAND(动能A,RGB(200,0,200),动能B,RGB(200,200,200));
STICKLINE(A2>0,0,A2,0.5,0),COLORRED;
STICKLINE(A2<0,0,A2,0.5,1),COLORGREEN;
VAR2:=(CLOSE-LLV(LOW,26))/(HHV(HIGH,26)-LLV(LOW,26))*100;
VAR3:=SMA(SMA(VAR2,3,1),3,1);
VAR4:=EMA(VAR3,5);
AA:=VOL>=REF(V,1)*1.91 AND C>REF(C,1)*1.01;
BB:=EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3),COLOR1010FF;
AA1:=STICKLINE(动能A<动能B,0,-3,2,0);
BB1:=STICKLINE(动能A>动能B,0,3,2,0);
持币:AA1,COLOR00FF00;
持股:BB1,COLORRED;
底部:STICKLINE(CROSS(BB,9),0,400,1.7,0),COLORWHITE;
STICKLINE(CROSS(BB,9),10,20,1.5,0),COLOR00FFFF;
STICKLINE(CROSS(BB,9),20,30,1,0),COLORRED;
DRAWTEXT(CROSS(BB,9),30,'底部'),COLOR00FFFF;
BIAS1:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
BIAS3:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
综合乖离:MA(BIAS,3),COLORFFFF00,LINETHICK0;
BIAS底A:IF(综合乖离<-18,62,0),COLORFF00FF,LINETHICK2;
BIAS底B:IF(综合乖离<-12,60,0), COLOR0000CC,LINETHICK2;
BIAS底C:IF(综合乖离<-6,68,0),COLORFFFF00,LINETHICK2;
BIAS底D:IF(综合乖离<0,88,0),COLORGREEN,LINETHICK2;
{www.gupang.com 股旁网-通达信指标公式}
AAA1:=EMA(CLOSE,7)-EMA(CLOSE,21);
BBB1:=EMA((0.668*REF(AAA1,1)+0.333*AAA1),1);
DRAWICON(AAA1>=BBB1,-400,1);
DRAWICON(AAA1<=BBB1,-400,2);
RSV:=(CLOSE - LLV(LOW,18))/(HHV(HIGH,18) - LLV(LOW,18))*100;
K:EMA(RSV,3),LINETHICK0;
D:EMA(K,3),LINETHICK0;
J:=(3*K-2*D)*1,LINETHICK1;
火山:(IF(J<=0,-J*5,0))*10,LINETHICK0;
STICKLINE(J<=0,0,火山,0.3,0),COLORYELLOW;
{M1:1 18 18}
M1:=18;
20,POINTDOT,COLOR990099;
50,POINTDOT,COLOR006666;
80,POINTDOT,COLOR009900;
量:=V/CONST(HHV(V,90))*30,LINETHICK0,VOLSTICK;
STICKLINE(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),量<0,-3,1.2,0),COLORGREEN,LINETHICK2;
DRAWTEXT(CROSS(0.9,1/VOL*1000>0.01 AND "KDJ.J"<0),量<0,'地量'),COLORYELLOW,LINETHICK1;
A111:=(2*C+H+L)/4;
A112:=LLV(L,34);
A113:=HHV(H,34);
中线持有:8*EMA((A111-A112)/(A113-A112)*100,13),COLORBLUE;
中线出货:EMA(0.667*REF(中线持有,1)+0.333*中线持有,2),COLORRED;
STICKLINE(中线持有-中线出货>0,中线持有,中线出货,10,0),COLORRED;
STICKLINE(中线持有-中线出货<0,中线持有,中线出货,10,0),COLORGREEN;
RSV333:=(((CLOSE - LLV(LOW,9)) / (HHV(HIGH,9) - LLV(LOW,9))) *100);
K333:=SMA(RSV333,3,1);
D333:=SMA(K333,3,1);
J333:=((3 * K333) - (2 * D333));
KDJ1:=REF(COUNT(J333<REF(J333,1),5)>=3,1) AND REF(J333,1)<20;
KDJ2:=J333>REF(J333,1);
反转:IF(FILTER(KDJ1 AND KDJ2,3),160,0),COLORRED,LINETHICK2;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),4,1)/SMA(ABS(CLOSE-LC),4,1)*100;
VARB:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100;
VARC:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100;
VARD:=BARSCOUNT(CLOSE);
底部雷达:(VARB< 20 AND VARC< 30 AND VARD> 20)*700,LINETHICK2,COLORYELLOW;

通达信量能抄底指标公式

 

相关文章