在线检测未来函数

通达信操盘黑马主图指标公式

来源:Internet,编辑:股旁网,2013-02-07

日均价:=(C*3+H+L+O)/6;
ZIA:=日均价;
黑马线:MA(C,5)-MA(C,13)+MA(C,8),COLORRED,LINETHICK1;
黑马攻击度:ATAN((黑马线/REF(黑马线,1)-1)*100)*57.3,NODRAW,COLORLICYAN;
SA:=EMA(日均价,5)*2-MA(日均价,5);
修正:=SMA(SMA(EMA(日均价,5)*2-MA(日均价,5),3,1),3,1);
补偿:=FLOOR(((修正-MA(修正,5))/MA(修正,5)*100));
牵牛线:SMA(SMA((EMA(SA,(5+ABS(补偿)))),2,1),2,1),COLORFF00FF,LINETHICK1;
牵牛攻击度:ATAN((牵牛线/REF(牵牛线,1)-1)*100)*57.3,NODRAW,COLORCYAN;
生命线:(MA(C,5)+MA(C,13))/2,COLORBLUE,LINETHICK1;
IF(黑马线>REF(黑马线,1),黑马线,DRAWNULL),LINETHICK2,COLOR0000FF;
IF(黑马线<REF(黑马线,1),黑马线,DRAWNULL),COLOR00FF00;
IF(牵牛线>REF(牵牛线,1),牵牛线,DRAWNULL),LINETHICK1,COLORFF00FF;
IF(牵牛线<REF(牵牛线,1),牵牛线,DRAWNULL),COLOR669933;
FL:=MA(CLOSE,13)+ABS(MA(CLOSE,13)-REF(MA(CLOSE,13),1));
FS:=MA(CLOSE,13)+MA(CLOSE,13)-REF(MA(CLOSE,13),1);
CG:=IF(MA(CLOSE,13)<FS,FS,MA(CLOSE,13));
A:=CG-(EMA(C,3)-CG);
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
CB:=EMA(X,13);
卖1:=IF(HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX),1,0);
DRAWICON(FILTER(卖1=1,1),H*1.007,2);
买1:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWICON(FILTER(买1=1,5),L*0.988,1);
{www.gupang.com 股旁网-通达信指标公式}
裁决:=(REF(ZIA,1)*0.5+REF(ZIA,2)+REF(ZIA,3)*0.5)/2;
VAR1:=IF(C<裁决 AND BETWEEN(裁决,C,O),1,0);
VAR2:=IF(C<裁决 AND REF(C,1)>裁决 AND BETWEEN(裁决,C,O)=0,1,0);
VAR3:=IF(C<裁决 AND REF(C,1)>裁决 ,1,0);
VAR4:=IF(C>=裁决 AND BETWEEN(裁决,C,O),1,0);
VAR5:=IF(C>=裁决 AND REF(C,1)>裁决,1,0);
VAR6:=IF(C>=裁决 AND BETWEEN(裁决,C,O)=0 AND REF(C,1)>裁决,1,0);
黄金柱体买:VAR4,COLORYELLOW,NODRAW;
红箭头选股:FILTER(买1=1,5),COLORLIRED,NODRAW;
STICKLINE(CLOSE> REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORRED;
STICKLINE(CLOSE< OPEN ,HIGH,LOW,0,1 ),COLORCYAN;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR000055;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR000077;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR000099;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000BB;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000DD;
STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLOR0000FF;
STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORWHITE;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR555555;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR777777;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR999999;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;
STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;
STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;
STICKLINE(CLOSE> OPEN ,HIGH,LOW,0,1 ),COLORRED;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR990000;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLORCC0000;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLORFF4400;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORFF8800;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;
STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORCYAN;
CO:=(C-O);
STICKLINE(VAR5 OR VAR6 ,OPEN,CLOSE,0.1,0 ),COLOR0000FF;
STICKLINE(VAR4,O,O+CO/3,2.7,0),COLOR335555;
STICKLINE(VAR4,O,O+CO/3,2.1,0),COLOR338888;
STICKLINE(VAR4,O,O+CO/3,1.5,0),COLOR33AAAA;
STICKLINE(VAR4,O,O+CO/3,0.9,0),COLOR33CCCC;
STICKLINE(VAR4,O,O+CO/3,0.3,0),COLOR33EEEE;
STICKLINE(VAR1,O,O+CO/3,2.7,0),COLOR550055;
STICKLINE(VAR1,O,O+CO/3,2.1,0),COLOR880088;
STICKLINE(VAR1,O,O+CO/3,1.5,0),COLORAA00AA;
STICKLINE(VAR1,O,O+CO/3,0.9,0),COLORCC00CC;
STICKLINE(VAR1,O,O+CO/3,0.3,0),COLOREE00EE;

通达信操盘黑马主图指标公式

 

相关文章