在线检测未来函数

通达信金色波段主图指标公式

来源:Internet,编辑:股旁网,2013-02-16

图中的金色与绿色波段交相辉映,金色段放心持股,绿色段安心休息。

DRAWGBK(C>=0,RGB(67,80,37),RGB(0,0,0),1,'8',1);
A1:=EMA(CLOSE,13)-EMA(CLOSE,55);
A2:=EMA((0.618*REF(A1,1)+0.382*A1),3);
STICKLINE(A1>=A2,H,L,0,0),COLOR00FFFF;
STICKLINE(A1>=A2,O,C,-1,0),COLOR0099DD;
STICKLINE(A1>=A2,O,C,2,0),COLOR00ABEE;
STICKLINE(A1>=A2,O,C,1,0),COLOR00DDFF;
STICKLINE(A1>=A2,O,C,0.1,0),COLOR00FFFF;
STICKLINE(A1<A2,H,L,0,0),COLOR00FF00;
STICKLINE(A1<A2,O,C,-1,0),COLOR009900;
STICKLINE(A1<A2,O,C,2,0),COLOR00AB00;
STICKLINE(A1<A2,O,C,1,0),COLOR00DD00;
STICKLINE(A1<A2,O,C,0.1,0),COLOR00FF00;
P1:=EMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,5);
P2:=(HHV(HIGH,55)-LLV(LOW,55))/EMA((CLOSE-LLV(LOW,55)),5);
P3:=CROSS(P2,P1);
P4:=REF(P2,2)<REF(P2,1) AND P2<REF(P2,1);
P5:=COUNT(P3,7)>0 AND P4;
P6:=3*SMA((CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100,5,1)-2*SMA((CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89))*100,5,1);
P7:= (CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
MW:= EMA(P6,5);
NU:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
NU0:=SMA(NU,3,1);
NU00:=SMA(NU0,3,1);
NU10:=3*NU0-2*NU00;
NU1:=EMA(3*NU0-2*NU00,4);
NU2:=SMA(NU1,5,1);
NW:=MA(3*SMA(P7,6,1)-2*SMA(SMA(P7,5,1),5,1),2);
HW:=CROSS(NW,0) AND MW<56;
DP:=IF(P5 AND COUNT(P5,5)=1,1,0);
{www.gupang.com 股旁网_通达信股票指标公式}
黑将军:=(HW AND DP) OR ((CROSS(IF(P6<3 AND NU2<5 AND NW<4,1,0),0.5))AND LLV(L,34)/HHV(H,144)<0.78),NODRAW;
STICKLINE(黑将军,H,L,0,0),COLOR0000FF;
STICKLINE(黑将军,O,C,-1,0),COLOR000099;
STICKLINE(黑将军,O,C,2,0),COLOR0000AB;
STICKLINE(黑将军,O,C,1,0),COLOR0000DD;
STICKLINE(黑将军,O,C,0.1,0),COLOR0000FF;
DRAWTEXT(黑将军,C*0.96,'黑将军'),COLOR00FFFF;

通达信金色波段主图指标公式

 

相关文章