在线检测未来函数

通达信北沙矩形主图指标公式

来源:Internet,编辑:股旁网,2013-02-19

说明 1、本公式适合于短线选股; 2、股价的内在力量往往通过速度和角度表现出来:时间短、角度陡、说明攻击力充足,而能长期保持大角度上升的个股更是强中之强; 3、对角线(黄线)可以看做是主趋势线; 4、45度线(绿线)可以看做是强弱分界线; 5、四条虚线分别是50、55、60、65度线、注意对角线和K线与它们的关系、越高则越强势; 6、起点(N):可根据自己的需要进行调整、例如改成60、250等等; 6、“短线只选最强势的品种操作”、很多人对此存在心理障碍; 7、建议配合北沙macd公式进行选股; 8、关于角度的探讨只是个开始;

N:=120;
TS:=BARSLAST(L=LLV(L,N));
开始信号:=FILTERX(TS=0,BARSSINCE(C));
开始天数:=BARSLAST(开始信号);
天数横线:=CONST(开始天数);
低点:DRAWLINE(L=LLV(L,N),L,ISLASTBAR,REF(L,TS),1),COLORGRAY;
高点:DRAWLINE(L=LLV(L,N),CONST(HHV(H,天数横线)),ISLASTBAR,REF(CONST(HHV(H,天数横线)),
TS),1),COLORGRAY;
STICKLINE(开始信号,L,CONST(HHV(H,天数横线)),0,0),COLORGRAY;
STICKLINE(ISLASTBAR,低点,高点,0,0),COLORGRAY;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
C2:=REF(C,1),NODRAW;
涨停:=REF(C,1)*1.1-C<0.01 AND H=C,NODRAW;
STICKLINE(涨停,OPEN,CLOSE,1,0),COLORRED;
STICKLINE(涨停,H,L,0,0),COLORRED;
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2) AND L=C,1,0),NODRAW;
STICKLINE(跌停,OPEN,CLOSE,1,0),COLORGREEN;
STICKLINE(跌停,H,L,0,1),COLORGREEN;
{www.gupang.com 股旁网_通达信股票指标公式}
差:=(高点-低点)/天数横线;
收盘差:=CONST(C)-低点;
对角差:=高点-低点;
对角角度:ATAN((对角差/(对角差*((天数横线-1)/天数横线))-1)*100)*57.3,COLORFF00FF,NODRAW;
差60度:=(高点-低点)*60/对角角度;
差45度:=(高点-低点)*45/对角角度;
差55度:=(高点-低点)*55/对角角度;
差50度:=(高点-低点)*50/对角角度;
差65度:=(高点-低点)*65/对角角度;
角度65:=IF(TS>=0 AND 低点+(差65度/天数横线)*TS<=高点,低点+(差65度/天数横线)*TS,DRAWNULL),COLORLIBLUE,DOTLINE;
角度50:IF(TS>=0 AND 低点+(差50度/天数横线)*TS<=高点,低点+(差50度/天数横线)*TS,DRAWNULL),COLORLIBLUE,DOTLINE;
角度55:IF(TS>=0 AND 低点+(差55度/天数横线)*TS<=高点,低点+(差55度/天数横线)*TS,DRAWNULL),COLORLIBLUE,DOTLINE;
对角线:IF(TS>=0 AND 低点+差*TS<=高点,低点+差*TS,DRAWNULL),COLORYELLOW,LINETHICK2;
{DRAWBAND(对角线,RGB(255,0,255),对角线,RGB(255,0,255)),LINETHICK2;}
角度60:IF(TS>=0 AND 低点+(差60度/天数横线)*TS<=高点,低点+(差60度/天数横线)*TS,DRAWNULL),COLORLIBLUE,DOTLINE;
角度45:IF(TS>=0 AND 低点+(差45度/天数横线)*TS<=高点,低点+(差45度/天数横线)*TS,DRAWNULL),COLORGREEN;
收盘角度:(收盘差*对角角度)/对角差,NODRAW;
收盘线:=IF(TS>=0 AND 低点+(收盘差/天数横线)*TS<=高点,低点+(收盘差/天数横线)*TS,DRAWNULL);
{DRAWBAND(收盘线,RGB(192,192,192),收盘线,RGB(192,192,192)),DOTLINE,COLORC0C0C0;};

通达信北沙矩形主图指标公式

 

相关文章