在线检测未来函数

通达信CCI趋势操盘线指标公式

来源:Internet,编辑:股旁网,2013-02-18

功能介绍: 看色操盘,颜色变化提示,判断个股趋势; 趋势线变红,发出买入信号,成功率很高; 趋势线变绿,变盘星号出现后,注意变盘; 具体操作看图说明希望朋友们喜欢和支持;

TYP:=(HIGH+LOW+CLOSE)/3;
CCI:(TYP-MA(TYP,13))/(0.015*AVEDEV(TYP,13)),STICK;
STICKLINE(CCI<0,0,CCI,1,0),COLORWHITE;
STICKLINE(CCI>=0,0,CCI,1,0),COLORYELLOW;
STICKLINE(CCI>REF(CCI,1) AND CCI<0 AND CCI>-100,0,CCI,1,0),COLORGREEN;
STICKLINE(CCI>REF(CCI,1) AND CCI>100,0,CCI,1,0),COLORRED;
趋势线:EXPMA(CCI,5),COLORMAGENTA,LINETHICK2;
IF(趋势线>=REF(趋势线,1),趋势线,DRAWNULL),COLORRED,LINETHICK2;
{www.gupang.com 股旁网_通达信股票指标公式}
IF(趋势线<REF(趋势线,1),趋势线,DRAWNULL),COLORGREEN,LINETHICK2;
DRAWTEXT_FIX(1,0.4,0.85,0,'★★ 绿柱:轻仓
★ 黄柱:加仓
★ 红柱:重仓
★ 白柱:持币
趋势线向上做多
趋势线向下减仓。★★'),COLOR00FFFF;
超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=L2_AMO(0,3)/10000.0;
大S:=L2_AMO(1,3)/10000.0;
中S:=L2_AMO(2,3)/10000.0;
小S:=L2_AMO(3,3)/10000.0;
TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);
大宗进:=(超B)+(大B),NODRAW;
大宗出:=(超S)+(大S),NODRAW;
非大宗进:=(中B)+(小B),NODRAW;
非大宗出:=(中S)+(小S),NODRAW;
DAZHIV:=CONST(MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出))))),NODRAW;
DRAWRECTREL(0,CONST(950-(ABS(大宗进)*250/DAZHIV))-20,30,950,IF(CONST(大宗进>0),RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(32,CONST(950-(ABS(大宗出)*250/DAZHIV))-20,62,950,IF(CONST(大宗出>0),RGB(23,125,255),RGB(255,0,0)));
DRAWRECTREL(92,CONST(950-(ABS(非大宗进)*250/DAZHIV))-20,122,950,IF(CONST(非大宗进>0),RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(124,CONST(950-(ABS(非大宗出)*250/DAZHIV))-20,154,950,IF(CONST(非大宗出>0),RGB(23,125,255),RGB(255,0,0)));
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.009,1,0,'主力进出'),COLORMAGENTA;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.1,1,0,'散户进出'),COLORCYAN;

通达信CCI趋势操盘线指标公式

 

相关文章