在线检测未来函数

通达信近期顶底主图指标公式

来源:Internet,编辑:股旁网,2013-02-20

顶底公式一般都是出现在副图的多,主图也有但不直观,这公式由顶线和底线组成,顶线为绿,底线为红,当K线触及顶线,K线就变绿,当K线触及底线,K线就变红,很好分辨。

N:=150;判断高低:=3;
高:=REF(HHV(H,N),判断高低);
近期顶:REFDATE(高,DATE),COLORGREEN,LINETHICK3;
最顶:=REFDATE(近期顶,DATE),NODRAW;
出:=最顶=H AND ((C-L)<(O-C) OR (O-L)<(C-O)),NODRAW;
STICKLINE(出,C,O,3,0),COLORGREEN;
STICKLINE(出,C,O,2,0),COLORGREEN;
低:=REF(LLV(L,N),判断高低);
近期底:REFDATE(低,DATE),COLORRED,LINETHICK3;
最底:=REFDATE(近期底,DATE),NODRAW;
进:=最底=L AND ((C+L)<(O+C) OR (O+L)<(C+O)),NODRAW;
STICKLINE(进,C,O,3,0),COLORRED;
STICKLINE(进,C,O,2,0),COLORRED;

通达信近期顶底主图指标公式

 

相关文章