在线检测未来函数

大智慧我买我卖指标公式

来源:Internet,编辑:股旁网,2013-02-20

{逐笔专家之大笔动向}
i:=MA(BARSLAST(HIGH=HHV(HIGH,16))*IF(CLOSE<OPEN,VOL,1),3);
r:=MA(BARSLAST(LOW=LLV(LOW,18))*IF(CLOSE>OPEN,VOL,1),4);
短线逃顶:IF(i,0,1),color00ff00;
DRAWICON(短线逃顶,98,8);
Var1jo:=IF(DATE<1090830 AND DATE>900101,1,0);
Var2jo:=LLV(LOW,10);
Var3jo:=HHV(HIGH,25);
警戒线:= 2.8*Var1jo;
减仓线:= 3.2*Var1jo;
动力线:=EMA((CLOSE-Var2jo)/(Var3jo-Var2jo)*4,4)*Var1jo;
DRAWICON(CROSS(动力线,警戒线),99,5);
{黑马发现的底部}{}
Vaz4:=(CLOSE-LLV(CLOSE,126))/(HHV(CLOSE,126)-LLV(CLOSE,126))*100;
Vaz24:Vaz4=0;
STICKLINE(Vaz24>0,-3,-9,1,2),colorred,linethick3 ;
Vaz25:Vaz4=100;
STICKLINE(Vaz25>0,101,105,1,2),colorgreen,linethick2;
{睡猫买入}
{n:DMA(AMOUNT/VOL/100,VOL/CAPITAL)/close;}{n日平均:ema(成本比,n);}
睡猫:if(c<MA(EMA(CLOSE,34)*0.82,5) and close/DMA(AMOUNT/VOL/100,VOL/CAPITAL)<0.64{下轴成本为0.64},30,0),linethick2,COLORffff00;
{南极}
南极:((((MA(CLOSE,5))-CLOSE)/CLOSE>3/100) AND (((MA(CLOSE,10))-(MA(CLOSE,5)))/(MA(CLOSE,5))>0.03) AND (LLV(CLOSE,30)=LLV(CLOSE,120)))*40,linethick2,colorF00FF0;
{一剑封喉}
Var9a:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),0-VOL,0)),0);
Var9b:=SUMBARS(VOL,CAPITAL);
Var9c:=IF(CLOSE>LLV(CLOSE,Var9b),1,-1);
Var9d:=IF(Var9a>LLV(Var9a,Var9b),1,-1);
Var9e:=Var9c*Var9d;
var9f:=IF(Var9e=-1,1,0);
yjfh:(var9f AND CLOSE=LLV(CLOSE,120))*48,linethick1,stick,colorred;
{等待底部买入}
买入: IF(CROSS((4*SMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5,1),3,1)),(8)),58,0),stick,color0099ff,linethick6;
drawtext(买入,45,'我买'),color66ffcc;
{导弹}
Var1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
Var1B:=SMA((SMA(Var1A,4,1)-50)*2,3,1);
Var1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
Var1D:=SMA(Var1C,4,1);
Var1E:=SMA(Var1D,3,1);
Var1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VarE:=REF(LOW,1)*0.9;
VarF:=LOW*0.9;
Var10:=(VarF*VOL+VarE*(CAPITAL-VOL))/CAPITAL;
Var11:=EMA(Var10,30);
Var12:=CLOSE-REF(CLOSE,1);
Var13:=MAX(Var12,0);
Var14:=ABS(Var12);
Var15:=SMA(Var13,7,1)/SMA(Var14,7,1)*100;
Var16:=SMA(Var13,13,1)/SMA(Var14,13,1)*100;
Var17:=BARSCOUNT(CLOSE);
Var18:=SMA(MAX(Var12,0),6,1)/SMA(ABS(Var12),6,1)*100;
Var19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
Var20:=Var18<=25 AND Var19<-95 AND Var1F>20 AND Var1B<-30 AND Var1E<30 AND Var11-CLOSE>=-0.25 AND Var15<22 AND Var16<28 AND Var17>50;
STICKLINE(Var20,0,95,5,0),LINETHICK2,COLORRED;
DRAWTEXT(CROSS(Var20,0.5) AND COUNT(Var20=1,10)=1,60,'发射导弹 '),LINETHICK7 , COLORwhite;
{我卖}{}
Vat3:=REF(CLOSE,1);
Vat4:=SMA(MAX(CLOSE-Vat3,0),6,1)/SMA(ABS(CLOSE-Vat3),6,1)*100;
我卖:(CROSS(80,Vat4))*82,stick,LINETHICK6,color9900CC ;
drawtext(我卖,80,'我卖'),colorred;
{玄黄卖出}
快逃: IF(CROSS((3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)),90),60,0),stick,linethick4,colorgreen;
drawtext(快逃,50,'快逃'),colorwhite;
{底部雷达}
Varo2:=(CLOSE-LLV(LOW,26))/(HHV(HIGH,26)-LLV(LOW,26))*100;
Varo3:=SMA(SMA(Varo2,3,1),3,1);
Varo4:=EMA(Varo3,5);
Varo5:=LLV(LOW,26);
Varo6:=HHV(HIGH,34);
Varo7:=EMA((CLOSE-Varo5)/(Varo6-Varo5)*4,4)*25;
STICKLINE(CROSS(Varo4,10) AND Varo4>10,25,0,8,0),coloryellow;
建仓区: IF((Varo7<10),80,100),linethick2 ,color00ccff;
派发区: IF((Varo7>90),20,0), linethick2 ,color6699ff;
{庄家踪迹中的买卖信号成功率为80-95 %}
Vay3:=(CLOSE-MA(CLOSE,30))/STD(CLOSE,15)*100;
VayA:=MA(CLOSE,60)-MA(CLOSE,5)/3.2;
成功率:IF(CROSS(((CLOSE-MA(CLOSE,30))/STD(CLOSE,15)*100),(EMA(Vay3,18))) AND CLOSE<VayA,50,0),STICK,COLORF0F000;
STICKLINE(CROSS(((CLOSE-MA(CLOSE,30))/STD(CLOSE,15)*100),(EMA(Vay3,18))) AND CLOSE<VayA,high+75,0,8,0),COLORF0F000;
DRAWICON(CROSS(((CLOSE-MA(CLOSE,30))/STD(CLOSE,15)*100),(EMA(Vay3,18))) AND CLOSE<VayA,high+82,1);
DRAWTEXT(CROSS(((CLOSE-MA(CLOSE,30))/STD(CLOSE,15)*100),(EMA(Vay3,18))) AND CLOSE<VayA,high+60,'成功80-95%'),coloryellow;{★←-买卖信号成功率为80-95%}
{Z马神君}
天马行空线:=ma(cost(85),5);
训马线:=ma(cost(15),5);
黑马线:=ma(cost(50),5);
天马踏地线:=ma(cost(1),7);
牵马绳:=ema(close,3);
DRAWICON(cross(牵马绳,天马踏地线) ,-5, 6);
DRAWICON(count(cross(天马行空线,牵马绳),20)=2 and 天马行空线/天马踏地线>1.6 ,95 , 10);

大智慧我买我卖指标公式

 

相关文章