在线检测未来函数

飞狐变色龙主图指标公式

来源:Internet,编辑:股旁网,2013-02-21

DRAWGBK(CLOSE>0,COLORRGB(0,100,0),COLORRGB(0,50,0),1);
上市日期年:REF(YEAR,BARSCOUNT(CLOSE)-1),LINETHICK0,colorFF00;
月:REF(MONTH,BARSCOUNT(CLOSE)-1),LINETHICK0,colorFF00FF;
日:REF(DAY,BARSCOUNT(CLOSE)-1),LINETHICK0,colorFFFF;
DRAWTEXT(SYSPARAM(2)=BARPOS,CLOSE,'证券代码:'+STKLABEL),ALIGN4,colorFF;
DRAWTEXT(BARPOS=SYSPARAM(2),HIGH,' 所属板块:'+BLKNAME),ALIGN4,colorFF00;
PARTLINE(EMA((2*CLOSE+HIGH+LOW)/4,5)>REF(EMA((2*CLOSE+HIGH+LOW)/4,5),1),EMA((2*CLOSE+HIGH+LOW)/4,5)),colorFF;
PARTLINE(EMA((2*CLOSE+HIGH+LOW)/4,5)<REF(EMA((2*CLOSE+HIGH+LOW)/4,5),1),EMA((2*CLOSE+HIGH+LOW)/4,5)),colorFF00;
PARTLINE(EMA((2*CLOSE+HIGH+LOW)/4,10)>REF(EMA((2*CLOSE+HIGH+LOW)/4,10),1),EMA((2*CLOSE+HIGH+LOW)/4,10)),LINETHICK2,colorFF;
PARTLINE(EMA((2*CLOSE+HIGH+LOW)/4,10)<REF(EMA((2*CLOSE+HIGH+LOW)/4,10),1),EMA((2*CLOSE+HIGH+LOW)/4,10)),LINETHICK2,colorFF00;
PARTLINE(EMA((LOW+CLOSE+OPEN)/3,23)>REF(EMA((LOW+CLOSE+OPEN)/3,23),1),REF(EMA((LOW+CLOSE+OPEN)/3,23),1)),LINETHICK3,colorFF;
PARTLINE(EMA((LOW+CLOSE+OPEN)/3,23)<REF(EMA((LOW+CLOSE+OPEN)/3,23),1),REF(EMA((LOW+CLOSE+OPEN)/3,23),1)),LINETHICK3,colorFF00;
STICKLINE(EMA((2*CLOSE+HIGH+LOW)/4,5)>EMA((2*CLOSE+HIGH+LOW)/4,10),EMA((2*CLOSE+HIGH+LOW)/4,10),EMA((2*CLOSE+HIGH+LOW)/4,23),0,1),colorFF00FF;
STICKLINE(EMA((2*CLOSE+HIGH+LOW)/4,5)<EMA((2*CLOSE+HIGH+LOW)/4,10),EMA((2*CLOSE+HIGH+LOW)/4,10),EMA((2*CLOSE+HIGH+LOW)/4,23),0,1),colorFFFF00;
DRAWTEXT(SYSPARAM(2)=BARPOS,CLOSE,'杨文峰编辑'),ALIGN5,colorFFFF00;
STICKLINE(CLOSE>MA(CLOSE,10),CLOSE,OPEN,8,0),colorAA;
STICKLINE(CLOSE>MA(CLOSE,10),CLOSE,OPEN,7,0),color11BB;
STICKLINE(CLOSE>MA(CLOSE,10),CLOSE,OPEN,6,0),color22CC;
STICKLINE(CLOSE>MA(CLOSE,10),CLOSE,OPEN,5,0),color33DD;
STICKLINE(CLOSE>MA(CLOSE,10),CLOSE,OPEN,4,0),color44EE;
STICKLINE(CLOSE>MA(CLOSE,10),CLOSE,OPEN,3,0),color55FF;
STICKLINE(CLOSE>MA(CLOSE,10),CLOSE,OPEN,2,0),color66FF;
STICKLINE(CLOSE>MA(CLOSE,10),CLOSE,OPEN,1,0),color77FF;
STICKLINE(CLOSE>MA(CLOSE,10),LOW,OPEN,0,1),colorFF;
STICKLINE(CLOSE>MA(CLOSE,10),HIGH,CLOSE,0,1),colorFF;
STICKLINE(CLOSE<=MA(CLOSE,10),CLOSE,OPEN,8,0),colorAA00;
STICKLINE(CLOSE<=MA(CLOSE,10),CLOSE,OPEN,7,0),colorBB11;
STICKLINE(CLOSE<=MA(CLOSE,10),CLOSE,OPEN,6,0),colorCC22;
STICKLINE(CLOSE<=MA(CLOSE,10),CLOSE,OPEN,5,0),colorDD33;
STICKLINE(CLOSE<=MA(CLOSE,10),CLOSE,OPEN,4,0),colorEE44;
STICKLINE(CLOSE<=MA(CLOSE,10),CLOSE,OPEN,3,0),colorFF55;
STICKLINE(CLOSE<=MA(CLOSE,10),CLOSE,OPEN,2,0),colorFF66;
STICKLINE(CLOSE<=MA(CLOSE,10),CLOSE,OPEN,1,0),colorFF77;
STICKLINE(CLOSE<=MA(CLOSE,10),HIGH,LOW,0,0),colorFF00;

飞狐变色龙主图指标公式

 

相关文章