在线检测未来函数

同花顺优化凤凰图主图+选股指标公式

来源:Internet,编辑:股旁网,2013-02-21

XOPEN:=(REF(O,1)+REF(C,1))/2;
XCLOSE:=CLOSE;
XHIGH:=MAX(HIGH,XOPEN);
XLOW:=MIN(LOW,XOPEN);
VOLALITY:=MA(XHIGH-XLOW,5);
凰线:MA(XCLOSE,13)+VOLALITY/2;
凤线:MA(XCLOSE,13)-VOLALITY/2;
BU:=CROSS(XCLOSE,凰线);
SEL:=CROSS(凤线,XCLOSE);
VAR1:=BARSLAST(BU);
VAR2:=BARSLAST(SEL);
DRAWICON(REF(VAR1,1)>VAR2 AND CROSS(C>凰线,0.5),XLOW*0.98,17);
DRAWTEXT(REF(VAR1,1)>VAR2 AND VAR1=0,XLOW*0.95,'买'),COLOR00FFFF;
DRAWICON(REF(VAR2,1)>VAR1 AND VAR2=0,XHIGH,6);
DRAWTEXT(REF(VAR2,1)>VAR1 AND VAR2=0,XHIGH*1.05,'卖'),COLORFFFF00;
STICKLINE(XCLOSE>XOPEN AND VAR1<VAR2,XCLOSE,XOPEN ,2.7,0 ),COLORFF00FF;
STICKLINE(XCLOSE>XOPEN AND VAR1<VAR2,XHIGH,XCLOSE ,0,0 ),COLORFF00FF;
STICKLINE(XCLOSE>XOPEN AND VAR1<VAR2,XOPEN,XLOW ,0,0 ),COLORFF00FF;
STICKLINE(XCLOSE<=XOPEN AND VAR1<VAR2,XCLOSE,XOPEN ,2.7,0 ),COLORYELLOW;
STICKLINE(XCLOSE<=XOPEN AND VAR1<VAR2,XHIGH,XOPEN ,0,0 ),COLORYELLOW;
STICKLINE(XCLOSE<=XOPEN AND VAR1<VAR2,XCLOSE,XLOW ,0,0 ),COLORYELLOW;

{
选股公式:

XOPEN:=(REF(O,1)+REF(C,1))/2;
XCLOSE:=CLOSE;
XHIGH:=MAX(HIGH,XOPEN);
XLOW:=MIN(LOW,XOPEN);
VOLALITY:=MA(XHIGH-XLOW,5);
凰线:=MA(XCLOSE,13)+VOLALITY/2;
凤线:=MA(XCLOSE,13)-VOLALITY/2;
BU:=CROSS(XCLOSE,凰线);
SEL:=CROSS(凤线,XCLOSE);
VAR1:=BARSLAST(BU);
VAR2:=BARSLAST(SEL);
REF(VAR1,1)>VAR2 AND VAR1=0;
}

同花顺优化凤凰图主图+选股指标公式

 

相关文章