在线检测未来函数

通达信波段导航指标公式

来源:Internet,编辑:股旁网,2013-02-22

B1:=(HHV(H,9)-C)/(HHV(H,9)-LLV(LOW,9))*100- 70;
B2:=SMA(B1,9,1)+100;
B3:=(C-LLV(L,9))/(HHV(H,9)- LLV(L,9))*100;
B4:=SMA(B3,3,1);
B5:=SMA(B4,9,1)+100;
导航:B5-B2;
VAR3W:=(C-LLV(L,18))/(HHV(H,18)-LLV(L,18))*100;
VAR4W:=SMA(VAR3W,9,1);
A2:=EMA(VAR4W,3),COLORBLUE;
A3:=EMA(A2,3);
A4W:=EMA(A3,3);
A5:=EMA(A4W,3);
AA:=EMA(A5,6);
压力:HHV(导航,17),COLORGREEN,DOTLINE;
支撑:LLV(导航,AA),COLOR0000FF,DOTLINE;
{短线买卖}
VA:=(2*C+H+L)/4;
VB:=LLV(L,5);
VC:=HHV(H,5);
波段红买绿卖:=EMA((VA-VB)/(VC-VB)*100,5),COLORGREEN;
短线买卖:MA(波段红买绿卖,2),COLORMAGENTA;
DRAWBAND(波段红买绿卖,RGB(255,0,255),短线买卖,RGB(17,250,180));
{中线波段}
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=VAR2/VAR1*100-70;
VAR5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR6:=(2*CLOSE+HIGH+LOW)/4;
VAR7:=SMA(VAR3/VAR1*100,3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VAR10:=IF(VAR9>100,VAR9-100,0);
VAR11:=HHV(HIGH,34);
VAR12:=EMA((VAR6-VAR8)/(VAR11-VAR8)*100,13);
VAR13:=EMA(0.667*REF(VAR12,1)+0.333*VAR12,2);
注意线:88;
STICKLINE(VAR12-VAR13>0,VAR12,VAR13,8,0), COLORRED;
STICKLINE(VAR12-VAR13<0,VAR12,VAR13,8,0), COLOR00FF0F;
生命线:EMA(VAR13,5), COLORYELLOW;
绿灯卖:IF(CROSS(VAR13,VAR12) AND VAR12<VAR13 AND VAR12>60,VAR13,88),COLORGREEN;
红灯买:IF(CROSS(VAR12,VAR13) AND VAR12>VAR13 AND VAR12<18,38,18), COLORRED;
{拉升资金}
VAR1D:=EMA(CLOSE,2)-EMA(CLOSE,89);
VAR1E:=EMA(VAR1D,30);
VAR1F:=2*(VAR1D-VAR1E);
VAR20:=POW(VAR1F,3)*0.1+POW(VAR1F,2);
VAR25:=IF(VAR1F>0.015,VAR20,0);
拉升资金: VAR25,COLORRED,LINETHICK2;
DRAWTEXT(CURRBARSCOUNT=1,拉升资金*1.5,'拉升'),COLORRED;

通达信波段导航指标公式

 

相关文章