在线检测未来函数

通达信筹码动态指标公式

来源:Internet,编辑:股旁网,2013-02-22

HH:=IF(C<REF(C,1) AND H<REF(L,1),REF(L,1),H);
LL:=IF(C>REF(C,1) AND L>REF(H,1),REF(H,1),L);
穿越筹码:=(WINNER(HH)-WINNER(LL))*100,COLORBLUE;
STICKLINE(1,穿越筹码/2,穿越筹码/2,2.5,0),COLORBLUE;
STICKLINE(1,穿越筹码/2,穿越筹码/2,3.2,0),COLOR990000;
STICKLINE(1,穿越筹码/2,-穿越筹码/2,2.5,0),COLORCC0000;
STICKLINE(1,穿越筹码/2,-穿越筹码/2,1.9,0),COLORFF4400;
STICKLINE(1,穿越筹码/2,-穿越筹码/2,1.4,0),COLORFF8800;
STICKLINE(1,穿越筹码/2,-穿越筹码/2,0.4,0),COLORFFCC00;
获利出货码:(PWINNER(1,LL)-WINNER(LL))*100,POINTDOT,COLOR000099;
套牢割肉码:(WINNER(HH)-PWINNER(1,HH))*100,POINTDOT,COLORGREEN;
STICKLINE(获利出货码>0,0,获利出货码,2.5,0),COLORRED;
STICKLINE(获利出货码>0,0,获利出货码,2.8,0)COLOR000066;
STICKLINE(获利出货码>0,0,获利出货码,2.3,0)COLOR000077;
STICKLINE(获利出货码>0,0,获利出货码,1.7,0)COLOR000099;
STICKLINE(获利出货码>0,0,获利出货码,1.2,0)COLOR0000CC;
STICKLINE(获利出货码>0,0,获利出货码,0.1,0)COLORCC66FF;
STICKLINE(套牢割肉码>0,0,-套牢割肉码,2.5,0),COLORGREEN;
STICKLINE(套牢割肉码>0,0,-套牢割肉码,3.2,0),COLOR007700;
STICKLINE(套牢割肉码>0,0,-套牢割肉码,2.8,0),COLOR009900;
STICKLINE(套牢割肉码>0,0,-套牢割肉码,2.1,0),COLOR00BB00;
STICKLINE(套牢割肉码>0,0,-套牢割肉码,1.6,0),COLOR00DD00;
STICKLINE(套牢割肉码>0,0,-套牢割肉码,0.4,0),COLOR00FF00;
A:=90+(100-90)/2;
B:=(100-90)/2;
CC:=COST(A);
DD:=COST(B);
CMJZD:=(CC-DD)/(CC+DD)*100/2;
筹码集中度:MA(CMJZD,3),COLORGRAY;
筹码集中度升:IF(筹码集中度>=REF(筹码集中度,3),筹码集中度,DRAWNULL),COLORRED,LINETHICK2;
筹码集中度降:IF(筹码集中度<REF(筹码集中度,3),筹码集中度,DRAWNULL),COLORFAABEC,LINETHICK2;
比例变化:(筹码集中度-REF(筹码集中度,1))/REF(筹码集中度,1)*100,COLORYELLOW,LINETHICK2;
拉高加仓:IF(筹码集中度>REF(筹码集中度,3) AND MA(C,20)>REF(MA(C,20),3),1,0),COLOR0095FF;
拉高加仓1:STICKLINE(拉高加仓>0,0,筹码集中度*0.33,2.7,0),COLOR0095FF;
STICKLINE(拉高加仓>0,0,筹码集中度*0.33,2.1,0),COLOR0064FF;
STICKLINE(拉高加仓>0,0,筹码集中度*0.33,1.5,0),COLOR0093FF;
STICKLINE(拉高加仓>0,0,筹码集中度*0.33,0.9,0),COLOR00C2FF;
STICKLINE(拉高加仓>0,0,筹码集中度*0.33,0.3,0),COLOR00FFFF;
下跌加仓:IF(筹码集中度>REF(筹码集中度,3) AND MA(C,20)<REF(MA(C,20),3),1,0),COLORFF0066;
下跌加仓1:STICKLINE(下跌加仓>0,0,筹码集中度*0.33,2.7,0),COLORFF0033;
STICKLINE(下跌加仓>0,0,筹码集中度*0.33,2.7,0),COLORFF0066;
STICKLINE(下跌加仓>0,0,筹码集中度*0.33,1.5,0),COLORFF0099;
STICKLINE(下跌加仓>0,0,筹码集中度*0.33,0.9,0),COLORFF00CC;
STICKLINE(下跌加仓>0,0,筹码集中度*0.33,0.3,0),COLORFF00FF;
底:0;
线1:10,COLORLIBLUE,POINTDOT;
线2:20,COLORFF00FF,POINTDOT;
VAR02:=LLV(LOW,10);
VAR03:=HHV(HIGH,25);
支撑线:EMA((CLOSE-VAR02)/(VAR03-VAR02)*4,4),COLORBLUE;
VAR01:=支撑线>REF(支撑线,1)AND 支撑线<1.5;
MA3:=MA(C,3);
VAR04:=HIGH>MA3*1.1;
买进:FILTER(CROSS(C,MA3)AND VAR01,5),STICK,LINETHICK3,COLOR0099FF;
DRAWICON(FILTER(CROSS(C,MA3)AND VAR01,5),10,35);
卖出:FILTER(VAR04 AND 支撑线>3,10),STICK,LINETHICK3,COLORFFAA66;
DRAWICON(FILTER(VAR04 AND 支撑线>3,10),1.5,36);
VARF:=TROUGHBARS(3,15,1)<4;
DRAWTEXT(FILTER(VARF=1,3),5,'庄影'),COLORYELLOW;

通达信筹码动态指标公式

 

相关文章