在线检测未来函数

通达信MACD改进加强版指标公式

来源:Internet,编辑:股旁网,2013-02-25

N:=9;M1:=3;M2:=3;
DIFF:EMA(CLOSE,12)-EMA(CLOSE,26),LINETHICK1,COLORYELLOW;
DEA:EMA(DIFF,9),LINETHICK1,COLORWHITE;
MACD:2*(DIFF-DEA), COLORSTICK,LINETHICK1;
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
F长:EMA(CLOSE,21)-EMA(CLOSE,55),COLORBLUE,LINETHICK1;
A长:EMA(F长,15),COLORRED,COLORBLUE,LINETHICK1;
MACD长:=(F长-A长)*2,LINESTICK,COLOR443434;
F中:EMA(CLOSE,12)-EMA(CLOSE,26),COLORYELLOW,LINETHICK1;
A中:EMA(F中,9),COLORYELLOW,LINETHICK1;
MACD中:=(F中-A中)*2,LINESTICK,COLORAA7755;
F短:EMA(CLOSE,6)-EMA(CLOSE,15),LINETHICK1,COLORWHITE;
A短:EMA(F短,5),LINETHICK1,COLORWHITE;
MACD短:=(F短-A短)*2,LINESTICK,COLOR44AABB;
JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);
底背:= DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK2;
A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));
顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);
顶背:= DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK1;
黑马线:=EMA(A1,5),LINETHICK2,COLORRED;
A3:=EMA(C,5);
A4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
VAR1:=REF(LOW,1);
VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),13,1)*100;
VAR3:=EMA(IF(CLOSE*1.2,VAR2*13,VAR2/13),13);
VAR4:=LLV(LOW,34);
VAR5:=HHV(VAR3,34);
VAR6:=IF(LLV(LOW,55),1,0);
VAR7:=EMA(IF(LOW<=VAR4,(VAR3+VAR5*2)/2,0),3)/618*VAR6;
XL1:=MA(LOW,2)*0.96;
XL2:=MA(LOW,26)*0.85;
XL3:=REF(XL1,1)<XL2 AND REF(XL1,1)<XL1 AND REF(XL1,1)<REF(XL1,2);
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:=SMA(RSV,M1,1);
D:=SMA(K,M2,1);
J:=3*K-2*D;
X1:=CROSS(J,1);
VAR11:=3;
VAR21:=(3)*(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1)) - (2)*(SMA(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1),3,1));
股价准备启动:=CROSS(VAR21,VAR11);
RSV1:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
K1:=SMA(RSV1,7,1);
D1:=SMA(K1,3,1);
J1:=3*K1-2*D1;
底部:=CROSS(J1,8.6);
底部1:=COUNT(X1,2)>0 AND COUNT(股价准备启动,2)>0 AND COUNT(底部,2)>0;
STICKLINE(底部1>0,0,0.2,2,0),COLORWHITE;

通达信MACD改进加强版指标公式

 

相关文章