在线检测未来函数

飞狐变异MACD指标公式

来源:Internet,编辑:股旁网,2013-02-25

nn:=35;n:=20;m:=18;
A:-( EMA(CLOSE,NN) - EMA(CLOSE,N)),linethick2;
B:EMA(A,M),linethick3;
MACD:(A-B),COLORSTICK;
A1:-(EMA(CLOSE,NN/2) - EMA(CLOSE,N/2)),COLORYELLOW;
B1:EMA(A1,M/2),linethick2;
MACD1 : 2*(A1-B1)/N/2, COLORSTICK;
A2:EMA(CLOSE,NN/3) - EMA(CLOSE,N/3);
B2:EMA(A2,M/3);
MACD2 :2*(A2-B1)/N/3, COLORSTICK;
AA:=A1<REF(A1,1)AND REF(A1,1)>REF(A1,2)AND A1>A AND A1>0.1;
DRAWTEXT(CROSS(A1,B1)AND B1<0,B1,'★'),COLORRED;
DRAWICON(CROSS(A2,B2)AND B2<-0.18,A,2);
DRAWTEXT(CROSS(A,A2)AND A<0.03,A,'进'),COLORRED;
DRAWTEXT(COUNT(A>REF(A,1),8)>=7 AND A>0.2 AND A<REF(A,1)OR AA,A,'逃'),COLORFF0000;

飞狐变异MACD指标公式

 

相关文章