在线检测未来函数

通达信成交量+主力动向指标公式

来源:Internet,编辑:股旁网,2013-02-25

量:V,VOLSTICK;
PJJ:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4),0.9);
JJ:=REF(EMA(PJJ,3),1);
QJJ:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN)))); XVL:=(IF((CLOSE > OPEN),(QJJ * (HIGH - LOW)),IF((CLOSE < OPEN),(QJJ * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2))) + IF((CLOSE > OPEN)
,(0 - (QJJ * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (QJJ * (HIGH - LOW))),(0 - (VOL / 2)))));
ZLL:=(VOL / CAPITAL);
HSL1:=IF((ZLL > 10),10,ZLL);
HSL:=((XVL / 20) / 1.15);
进攻流量:=(((HSL * 0.55) + (REF(HSL,1) * 0.33)) + (REF(HSL,2) * 0.22));
GJJ:=EMA(进攻流量,8); LLJX:=EMA(进攻流量,3);
动态天量:=CONST(IF(V=HHV(V,20),V,REF(V,BARSLAST(V=HHV(V,20))))),COLOR00FF00,POINTDOT;
STICKLINE(((HSL * 0.4) >= 0),动态天量+((HSL * 0.4) +LLJX)*20,动态天量,3,0),COLORYELLOW;
STICKLINE(((HSL * 0.4) < 0),动态天量+((HSL * 0.4) +LLJX)*20,动态天量,3,0),COLOR00FF00;
资金流入:=IF((HSL*0.4+LLJX)>0,(HSL*0.4+LLJX),DRAWNULL),COLORRED;
资金流出:=IF((HSL*0.4+LLJX)<0,(HSL*0.4+LLJX),DRAWNULL),COLOR00FF00;
资金收支:=(HSL*0.4+LLJX),LINETHICK0;
万元:=AMOUNT/10000{0000},VOLSTICK,COLORFF00FF;
资金净收支:IF((HSL*0.4+LLJX)>0,资金流入,资金流出),COLORWHITE,POINTDOT;
收支比例%:IF((HSL*0.4+LLJX)>0,资金流入/万元*100,资金流出/万元*100),COLORYELLOW;
连红天1:=BARSLASTCOUNT(资金净收支>0),,COLORA20FFD,NODRAW;
连红天2:=IF(连红天1=0,REF(连红天1,1),连红天1),,COLORA20FFD,NODRAW;
连红天3:=IF(连红天2=0,REF(连红天1,2),连红天2),,COLORA20FFD,NODRAW;
连红天4:=IF(连红天3=0,REF(连红天1,3),连红天3),,COLORA20FFD,NODRAW;
近期连红天:IF(连红天4=0,REF(连红天1,4),连红天4),,COLORYELLOW,NODRAW;
三日资金:SUM(资金收支,3),COLORWHITE,NODRAW;
五日资金:SUM(资金收支,5),COLORFF00FF,NODRAW;
十日资金:SUM(资金收支,10),COLOR0000FF,NODRAW;
资金流量:=LLJX,LINETHICK0,COLOR0000FF;
STICKLINE((资金流量 > 0),动态天量+资金流量*20,动态天量,3,0),COLOR0000FF;
STICKLINE((资金流量 < 0),动态天量+资金流量*20,动态天量,3,0),COLOR008000;

通达信成交量+主力动向指标公式

 

相关文章