在线检测未来函数

通达信斋主舍得指标公式

来源:Internet,编辑:股旁网,2013-02-25

LC:=REF(CLOSE,1);
RSI:=((SMA(MAX(CLOSE - LC,0),4.1,1))/(SMA(ABS(CLOSE - LC),4.1,1)))*(100);
蛮准:(CROSS(RSI,11))*(80),COLORRED,LINETHICK2;
A5:=MA(C,5);
A10:=MA(C,10);
STICKLINE(CROSS(A5,A10),0,48,1,0),COLORYELLOW;
DRAWTEXT(CROSS(A5,A10),52,'均线5金叉10'),COLORYELLOW;
{A5:=MA(C,5);
A10:=MA(C,10);}
STICKLINE(CROSS(A10,A5),85,100,4,0),COLORGREEN;
DRAWTEXT(CROSS(A10,A5),82,'均线10死叉5'),COLORGREEN;
DRAWTEXT(CROSS(RSI,11),82,'蛮准'),COLOR66FFCC;
买:=IF("KDJ.J"<0,10,0);
短王:CROSS(9.9,买)*36,COLORMAGENTA,LINETHICK3;
DRAWTEXT(CROSS(9.9,买),38,'短王'),,COLORMAGENTA;
VAR1Z:=(C-REF(C,1))/REF(C,1);
VAR2Z:=(INDEXC-REF(INDEXC,1))/REF(INDEXC,1);
个股:=EMA(SUM(VAR1Z,20),5);
大盘:=EMA(SUM(VAR2Z,20),5);
领涨:=(个股-大盘)>=0;
VAR3Z:=(C-LLV(L,125))/(HHV(H,125)-LLV(L,125))*100;
VAR4Z:=SMA(VAR3Z,72,1);
VAR5Z:=SMA(VAR4Z,34,1);
中线趋势:=3*VAR4Z-2*VAR5Z;
中线趋势升:=(中线趋势-REF(中线趋势,1))>=0;
均五升:=(MA(C,5)-REF(MA(C,5),1))>=0;
均十升:=(MA(C,10)-REF(MA(C,10),1))>=0;
STICKLINE(均五升 AND 均十升 AND 中线趋势升,0+0.5,0-0.5,6,1),COLORFFFF00,LINETHICK1;
强势:IF(均五升 AND 均十升 AND 中线趋势升 AND 领涨,4,0),COLORRED;
VAR6Z:=(2*C+H+L)/4;
VAR7Z:=LLV(L,27);
VAR8Z:=HHV(H,27);
操作:EMA((VAR6Z-VAR7Z)/(VAR8Z-VAR7Z)*100,13)-50,LINETHICK1,COLORYELLOW;
趋势:EMA(0.618*REF(操作,1)+0.382*操作,3),COLORGREEN,LINETHICK1;
STICKLINE(操作>趋势 AND 操作>=REF(操作,1),操作+5,趋势-1,3.5,0),COLORRED,LINETHICK2;
STICKLINE(操作>=趋势,趋势,趋势,3.5,0),COLORYELLOW,LINETHICK2;
STICKLINE(操作<趋势,趋势+0.5,趋势-0.5,3.5,0),COLORFFFF00,LINETHICK2;
STICKLINE(强势=4,操作+6,趋势-1,4,0),COLORFF99FF;
强弱界:0,COLORWHITE;
STICKLINE(操作>=趋势 AND 均五升 AND 均十升 AND 中线趋势升,趋势-3,趋势-7,4,0),COLOR64A0E6;
运动:=IF(操作>=趋势 AND 均五升 AND 均十升 AND 中线趋势升 AND 趋势<0,1,0);
买进:IF(运动=1 AND COUNT(运动=1,5)=1,28,0),COLORRED,LINETHICK3;
DRAWTEXT(买进=8,操作,'买进'),COLORYELLOW;
BIAS1:=(C-MA(C,6))/MA(C,6)*100;
BIAS2:=(C-MA(C,12))/MA(C,12)*100;
BIAS3:=(C-MA(C,24))/MA(C,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离:=MA(BIAS,3);
准备:STICKLINE(乖离<-6 AND 乖离>=-12,-6,0,6,1 ),COLOR33FFCC;
抄底一:IF(乖离<-12 AND 乖离>=-18,-12,0),
,STICK;
STICKLINE(乖离<-12 AND 乖离>=-18,-12,0,6,0) ,COLOR33CCCC;
抄底二:IF(乖离<-18,-18,0),
,STICK;
STICKLINE(乖离<-18,-18,0,6 ,0) ,COLOR3399CC;
抄底:IF(买进=8 AND COUNT(乖离<-12,10)>=1,10,0),LINETHICK0,COLORRED;
STICKLINE(抄底=10,10,0,10,1),COLORRED;
DRAWTEXT(抄底=10,10,'←抄底'),COLORYELLOW;
DRAWTEXT(CROSS(操作,趋势) AND (操作>-30),操作,'▲'),COLORRED;
DRAWTEXT(CROSS(趋势,操作) AND (操作>-20),操作,'▼' ),COLOR00FF00;
JUJ:=(HIGH+LOW+CLOSE)/3;
QUJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QUJ1:=IF(CAPITAL=0,QUJ0*(JUJ-MIN(CLOSE,OPEN)),QUJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QUJ2:=IF(CAPITAL=0,QUJ0*(MIN(OPEN,CLOSE)-LOW),QUJ0*IF(HIGH=LOW,1,(JUJ-MIN(CLOSE,OPEN))));
QUJ3:=IF(CAPITAL=0,QUJ0*(HIGH-MAX(OPEN,CLOSE)),QUJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QUJ4:=IF(CAPITAL=0,QUJ0*(MAX(CLOSE,OPEN)-JUJ),QUJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JUJ)));
QUJ5:=QUJ1+QUJ2;
QUJ6:=QUJ3+QUJ4;
DD:=(QUJ5-QUJ6)/(QUJ5+QUJ6)*100;
DDZ:=DD*17;
DDX:=((QUJ1+QUJ2)-(QUJ3+QUJ4))/IF(CAPITAL=0,1000000,10000);
DX:=MA(DDX,5)*20;
DDX1:=SMA(DX,3,1);
DDX2:=SMA(DDX1,3,1);
DDX3:=EMA(DDX2,5);
DDY:=((QUJ2+QUJ4)-(QUJ1+QUJ3))/IF(CAPITAL=0,1000000,10000);
DY:=MA(DDY,5)*22;
DDY1:=SMA(DY,3,1);
DDY2:=SMA(DDY1,3,1);
DDY3:=EMA(DDY2,5);
CC:=ABS(REF(CLOSE,1)-CLOSE)/CLOSE*100;
JJ:=CC>0 AND CC<3;
AA:=DDX1>DDX2 AND DDX2>DDX3 AND DDX1>DDX3;
BB:=DDY1>DDY2 AND DDY2>DDY3 AND DDY1>DDY3;
HH:=AA>0 AND BB>0 AND DDZ>300 AND JJ>0;
DDE均线多头:(HH>0)*36;
D:= EMA((CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,20);
J:= EMA((CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,5) ;
BIAS1W :=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
BIAS2W :=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
BIAS3W :=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
MM:=(BIAS1W+2*BIAS2W+3*BIAS3W)/6;
MN:=MA(MM,3);
VAR1:=(HHV(HIGH,24)-CLOSE)/(HHV(HIGH,24)-LLV(LOW,24))*100;
VAR2:=(CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*100;
VAR3:=(2*CLOSE+HIGH+LOW)/4;
VAR4:=LLV(LOW,26);
VAR5:=HHV(HIGH,34);
VAR6:=EMA((VAR3-VAR4)/(VAR5-VAR4)*100,16);
VAR7:=SMA((SMA(VAR2,3,1)+3),3,1),LINETHICK3;
VAR8:=EMA(VAR6,7);
VAR9:=SMA(VAR1,3,1);
VAR10:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR11:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR12:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;
VAR13:=(VAR10+VAR11+VAR12)/3;
VAR14:=IF(VAR13<=-20,10,0);
VAR15:=HHV(VAR14,10);
VAR24:=LLV(LOW,36);
VAR25:=HHV(HIGH,30);
VAR26:=EMA((CLOSE-VAR24)/(VAR25-VAR24)*4,4)*25;
K:EMA(D,3),COLOR00FF00,LINETHICK1;
M:EMA(J,7),COLORRED,LINETHICK1;
股经:J,COLORLIMAGENTA,LINETHICK2;
底观察:IF(MN<-4,10,0),COLORLIBLUE,LINETHICK2;
背离: IF((VAR26<10),90,100), COLORGREEN,LINETHICK2;
顶背离: IF((VAR26>90),5,18), COLOR808000,LINETHICK2;
AAZ:=LLV(LOW,36);
BBZ:=HHV(HIGH,30);
DDQ:=(EMA(((CLOSE-AAZ)/(BB-AAZ))*(4),4))*(25);
股海:=(((DDQ-LLV(DDQ,21))/(HHV(DDQ,21)-LLV(DDQ,21)))*(4))*(25);
跟踪:10,COLOR0000FF,LINETHICK1;
神偷出现:IF((COUNT((DDQ>REF(DDQ,1)),1)=1) AND (REF(DDQ,1)<REF(REF(DDQ,1),1)) AND (DDQ<跟踪),20,0),COLORF00FF0;
DRAWICON(CROSS(10,股经),5,1);
V1:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;
V2:=(CLOSE-LLV(LOW,43))/(HHV(HIGH,43)-LLV(LOW,43))*100;
V3:=SMA(V2,2,1);
顶:=100+(-ABS(V1)),COLORGRAY;
底:=ABS(V1),COLORGRAY;
VR1:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
VR2:=SMA(VR1,3,1);
VR3:=SMA(VR2,3,1);
VR4:=SMA(VR3,3,1);
VR5:=CROSS(VR3,VR4) AND VR3<20;
VR8:=CROSS(VR2,VR3) AND VR3>80 AND VR3>VR4;
VR9:=CROSS(VR4,VR3) AND VR3>80;
DRAWTEXT(FILTER(VR5,10)=1,21,'底'),COLORRED;
STICKLINE(FILTER(VR5,10)=1,0,20,2,0),COLORRED;
STICKLINE(FILTER(VR9,5)=1,80,100,2,0),COLORGREEN;
DRAWTEXT(FILTER(VR9,5)=1,79,'顶'),COLORGREEN;
STICKLINE(VR8,85,100,2,0),COLOR0099FF;
流通:=(AMOUNT / VOL);
资金流量:=(CLOSE-REF(CLOSE,1))*流通;
VAR111:=SMA(资金流量,10,1);
MID111:=MA(VAR111,26);
UPPER111:=MID111 + 2*STD(VAR111,26);
ZF:=(C-REF(C,1))/REF(C,1)*100;
总次数:=SUM(ZF>7,120)>=4;
多头:=MA(C,20)>=REF(MA(C,20),1);
强势Z:=VAR111>=UPPER111;
TT1:=C/REF(C,1)>=1.07;
强势买:=强势Z AND TT1 AND 多头 AND 总次数;
SS1:=O<=REF(C,1);
指数300:="399300$CLOSE";
DP:=指数300>=MA(指数300,5);
低开买:STICKLINE(CAPITAL/1000000<=8.888 AND MA(C,5)<48 AND REF(强势买,1) AND SS1 AND DP,0,56,2,0),COLORMAGENTA;
DRAWTEXT(CAPITAL/1000000<=8.888 AND MA(C,5)<48 AND REF(强势买,1) AND SS1 AND DP,60,'低开买'),COLORMAGENTA;
VOLUME:=VOL;
MAVOL1:=MA(VOLUME,5);
MAVOL2:=MA(VOLUME,10);
MAVOL3:=MA(VOLUME,135);
选股:STICKLINE(CROSS(MAVOL1,MAVOL2)AND CROSS(MAVOL1,MAVOL3),0,32,2,0),COLORWHITE;
DRAWTEXT(CROSS(MAVOL1,MAVOL2)AND CROSS(MAVOL1,MAVOL3),36,'5均量上穿10日135均量线'),COLORWHITE;

通达信斋主舍得指标公式

 

相关文章