在线检测未来函数

通达信做红弃绿指标公式

来源:Internet,编辑:股旁网,2013-02-26

VAR1:=EMA(HHV(HIGH,500),21);
VAR2:=EMA(HHV(HIGH,250),21);
VAR3:=EMA(HHV(HIGH,90),21);
VAR4:=EMA(LLV(LOW,500),21);
VAR5:=EMA(LLV(LOW,250),21);
VAR6:=EMA(LLV(LOW,90),21);
VAR7:=EMA((VAR4*0.96+VAR5*0.96+VAR6*0.96+VAR1*0.558+VAR2*0.558+VAR3*0.558)/6,21);
VAR8:=EMA((VAR4*1.25+VAR5*1.23+VAR6*1.2+VAR1*0.55+VAR2*0.55+VAR3*0.65)/6,21);
VAR9:=EMA((VAR4*1.3+VAR5*1.3+VAR6*1.3+VAR1*0.68+VAR2*0.68+VAR3*0.68)/6,21);
VAR10:=IF(DATE>=1340722,0,1);
VARA:=EMA((VAR7*3+VAR8*2+VAR9)/6*1.738,21);
VARB:=REF(LOW,1);
VARC:=SMA(ABS(LOW-VARB),3,1)/SMA(MAX(LOW-VARB,0),3,1)*100;
VARD:=EMA(IF(CLOSE*1.35<=VARA,VARC*10,VARC*VAR10/10),3);
VARE:=LLV(LOW,30)*VAR10;
VARF:=HHV(VARD,30);
VAR11:=IF(MA(CLOSE,58),1,0);
火焰山后股启航:EMA(IF(LOW<=VARE,(VARD+VARF*2)/2,0),3)/618*VAR11,COLOR00EEFF,LINETHICK2,POINTDOT;
火焰:=STICKLINE(火焰山后股启航>0 ,0 ,火焰山后股启航 ,4 ,1);
今量:=火焰山后股启航*VAR10;
STICKLINE(火焰山后股启航>0,0 ,今量*1.2,6,0 ),COLOR00EEFF;
STICKLINE(火焰山后股启航>0,0 ,今量*0.6,5,0 ),COLOR0099FF;
STICKLINE(火焰山后股启航>0,0 ,今量*0.4,3,0 ),COLOR0066FF;
STICKLINE(火焰山后股启航>0,0 ,今量*0.2,2,0 ),COLOR0000FF;
QW1:=(HIGH+LOW+CLOSE*2)/4;
QW3:=EMA(QW1,10);
QW4:=STD(QW1,10);
QW5:=(QW1-QW3)*100/QW4;
QW6:=EMA(QW5,5);
RK7:=EMA(QW6,10);
红烛看涨:EMA(QW6,10)+100/2-5,LINETHICK1,COLORRED;
绿烛看跌:IF(红烛看涨<REF(红烛看涨,1),红烛看涨,DRAWNULL),COLORGREEN,LINETHICK1;
STICKLINE(红烛看涨<REF(红烛看涨,1),红烛看涨,MA(红烛看涨,3),3,0 ),COLOR008800;
STICKLINE(红烛看涨> REF(红烛看涨,1),红烛看涨,EMA(红烛看涨,3),2,0) ,COLORRED;
VARG:= ZIG(3,18)<REF(ZIG(3,18),1) AND REF(ZIG(3,18),1)>=REF(ZIG(3,18),2);
逃顶抛股:=PEAKBARS(3,15,1)<10;
做空:=IF(逃顶抛股=1,2,0);
逃顶抛股做空:= IF(做空=2,2,0),STICK,;
□创新高减仓:IF(逃顶抛股做空>REF(逃顶抛股做空,1),2,0),STICK,COLORFF937F;
STICKLINE(PEAKBARS(3,18,1)=0 AND HIGH*0.96>LOW,221,195,2,1),COLORFF937F;
DRAWTEXT(PEAKBARS(3,18,1)=0 AND HIGH*0.96>LOW,220,'创近期新高,逢高减仓!'),COLORFF937F;
□庄撤俺撤:FILTER(VARG,1)*1,COLOR999999,POINTDOT;
STICKLINE(VARG=1,205,195,2,1),COLOR999999;
DRAWTEXT(VARG,205,'庄撤俺撤!'),COLOR999999;
X1:=(3*C+H+L+O)/6;
X2:=EMA(X1,10);
X3:=REF(X2,1);
XL11:=EMA(CLOSE,10)/100;
XL2:= MA((XL11-REF(XL11,10))/REF(XL11,10),3)*100;
XL3:= MA(XL2,3);
XL4:=SMA((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,3,1);
DRAWTEXT(IF(CROSS(3*XL4-2*SMA(XL4,3,1),8),87,0) AND X2>X3,L+50,'反弹'),COLORFF5ED8;

通达信做红弃绿指标公式

 

相关文章