在线检测未来函数

通达信线上买卖主图指标公式

来源:Internet,编辑:股旁网,2013-02-26

涨家数:INDEXADV,NODRAW, ;
跌家数:INDEXDEC,NODRAW,COLORGREEN;
C3:=REF(C,1);
涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(涨停,OPEN,CLOSE,2.5,0),COLORRED;
跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(跌停,OPEN,CLOSE,2.5,0),COLORGREEN;
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
K:=(C+H+L)/3;
D:=MA(K,4);
DRAWTEXT(REF(C,1)>D AND C<D AND D>REF(D,1),H*0.95, 'S'),COLORGREEN;
DRAWTEXT(REF(C,1)<D AND C>D AND D<REF(D,1),L*0.98 ,'B'),COLORRED;
{自动分割画线}
D1:=DRAWLINE(C=HHV(C,60),HHV(H,3),C=HHV(C,30) AND C<HHV(C,45),
HHV(HIGH,3),1);
E1:=DRAWLINE(C=LLV(C,60),LOW,C=LLV(C,30) AND C>LLV(C,45),LLV(LOW,3),1),
LINETHICK2;
E1P:DRAWLINE(C=LLV(C,30),LOW,C=LLV(C,10) AND C>LLV(C,22),LLV(LOW,3),1),
LINETHICK1,COLORBLUE;
E1PP:DRAWLINE(C=LLV(C,10),LOW,C=LLV(C,5) AND C>LLV(C,10),LLV(LOW,3),1),
LINETHICK1,COLORRED;
日:=181;昨前:=74;
高1:=REF(HHV(H,日),昨前);
低1:=REF(LLV(L,日),昨前),COLORBLUE,LINETHICK3;
H1:=高1-(高1-低1)*0.191,POINTDOT;
H2:=高1-(高1-低1)*0.382,POINTDOT;
H3:=高1-(高1-低1)*0.5,POINTDOT;
H4:=高1-(高1-低1)*0.618,POINTDOT;
H5:=高1-(高1-低1)*0.809,COLORBLUE,POINTDOT;
短线5:MA(CLOSE,5),COLORGREEN;
中线20:MA(CLOSE,20),COLORYELLOW;
DRAWLINE(CURRBARSCOUNT=TOTALBARSCOUNT,CONST(C),CURRBARSCOUNT=1,C,3)DOTLINE;

通达信线上买卖主图指标公式

 

相关文章