在线检测未来函数

通达信仿文峰K线主图指标公式

来源:Internet,编辑:股旁网,2013-02-26

DRAWRECTREL(0,530,300,998,IF(100,RGB(0,15,15),0));
超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=L2_AMO(0,3)/10000.0;
大S:=L2_AMO(1,3)/10000.0;
中S:=L2_AMO(2,3)/10000.0;
小S:=L2_AMO(3,3)/10000.0;
大宗净流入:=(超B+大B)-(超S+大S),COLORRED,NODRAW;
净流入:=(超B+大B+中B+小B)+(超S+大S+中S+小S);
大宗进:=(超B)+(大B);
大宗出:=(超S)+(大S);
非大宗进:=(中B)+(小B);
非大宗出:=(中S)+(小S);
主力买力度:=LARGEINTRDVOL*100/VOL,NODRAW;
主力卖力度:=LARGEOUTTRDVOL*100/VOL,NODRAW;
DAZHIV:=CONST(MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出))))),NODRAW;
DRAWRECTREL(0,CONST(950-(ABS(大宗进)*250/DAZHIV)),54,970,IF(CONST(大宗进>0),RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(60,CONST(950-(ABS(大宗出)*250/DAZHIV)),114,970,IF(CONST(大宗出>0),RGB(23,125,255),RGB(255,0,0)));
DRAWRECTREL(120,CONST(950-(ABS(非大宗进)*250/DAZHIV)),174,970,IF(CONST(非大宗进>0),RGB(255,0,0),RGB(23,125,255)));
DRAWRECTREL(180,CONST(950-(ABS(非大宗出)*250/DAZHIV)),234,970,IF(CONST(非大宗出>0),RGB(23,125,255),RGB(255,0,0)));
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.00,1,0,'资金驱动 主力进出 资金驱动 散户进出'),COLORWHITE;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.005,0.88,0,INTPART(大宗进)),COLORWHITE;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.068,0.88,0,INTPART(大宗出)),COLORWHITE;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.138,0.88,0,INTPART(非大宗进)),COLORWHITE;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.196,0.88,0,INTPART(非大宗出)),COLORWHITE;
主买A:=ACTINVOL,COLORRED,NODRAW;
主卖A:=ACTOUTVOL,COLORGREEN,NODRAW;
主买:主买A*100/(主买A+主卖A),NODRAW,COLORRED;
主卖:主卖A*100/(主买A+主卖A),NODRAW,COLORGREEN;
DRAWRECTREL(80,530,234,580,RGB(0,75,200));
DRAWRECTREL(80,530,234,580,RGB(0,250,50));
DRAWRECTREL(80,530,80+CONST(主买*160/100),580,RGB(175,50,250));
DRAWTEXT_FIX(1,0.00,0.54,0,STRCAT(STRCAT('主动买卖比 ',CON2STR(主买,2)),' %')),COLORYELLOW;
DRAWTEXT_FIX(1,0.18,0.54,0,STRCAT(STRCAT(' ',CON2STR(主卖,2)),' %')),COLORYELLOW;
DRAWRECTREL(80,580,234,630,RGB(0,75,200));
DRAWRECTREL(80,580,234,630,RGB(0,250,50));
DRAWRECTREL(80,580,80+CONST(主力买力度*160/100),630,RGB(200,0,50));
DRAWTEXT_FIX(1,0.00,0.59,0,STRCAT(STRCAT('主动买卖力 ',CON2STR(主力买力度,2)),'%')),COLORYELLOW;
DRAWTEXT_FIX(1,0.18,0.59,0,STRCAT(STRCAT(' ',CON2STR(主力卖力度,2)),'%')),COLORYELLOW;
DDX:=(LARGEINTRDVOL-LARGEOUTTRDVOL)*100000/FINANCE(7),NODRAW;
DDY:=IF(TRADENUM>0,(TRADEOUTNUM-TRADEINNUM)*100/TRADENUM,0);
DDZ:=IF(TRADENUM>0,(LARGETRDINNUM-LARGETRDOUTNUM)/TRADENUM*100,0);
DRAWRECTREL(234,530,300,580,IF(CONST(DDX)>0,RGB(255,0,0),RGB(0,50,0)));
DRAWRECTREL(234,580,300,630,IF(CONST(DDX)>0,RGB(255,0,0),RGB(0,50,0)));
DRAWRECTREL(234,692,300,742,IF(CONST(DDY)>0,RGB(255,0,0),RGB(0,50,0)));
DRAWRECTREL(234,742,300,792,IF(CONST(DDY)>0,RGB(255,0,0),RGB(0,50,0)));
DRAWRECTREL(234,842,300,892,IF(CONST(DDZ)>0,RGB(255,0,0),RGB(0,50,0)));
DRAWRECTREL(234,892,300,942,IF(CONST(DDZ)>0,RGB(255,0,0),RGB(0,50,0)));
DRAWTEXT_FIX(1,0.24,0.54,0,STRCAT('',CON2STR(DDX,2))),COLORYELLOW;
DRAWTEXT_FIX(1,0.24,0.70,0,STRCAT('',CON2STR(DDY,2))),COLORYELLOW;
DRAWTEXT_FIX(1,0.24,0.85,0,STRCAT('',CON2STR(DDZ,2))),COLORYELLOW;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.24,0.65,0,'大单动向'),COLORWHITE;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.24,0.80,0,'涨跌动因'),COLORWHITE;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.24,0.95,0,'大单差分'),COLORWHITE;
T1:=IF (DDX>0 AND REF(DDX,1)<0,1,0);
T2:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)<0,2,T1);
T3:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)<0,3,T2);
T4:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)<0,4,T3);
T5:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)<0,5,T4);
T6:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)<0,6,T5);
T7:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)<0,7,T6);
T8:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)<0,8,T7);
T9:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)>0 AND REF(DDX,9)<0,9,T8);
T:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)>0 AND REF(DDX,9)>0,10,T9);
TA1:=IF (DDX<0 AND REF(DDX,1)>0,1,0);
TA2:=IF (DDX<0 AND REF(DDX,1)<0 AND REF(DDX,2)>0,2,TA1);
TA3:=IF (DDX<0 AND REF(DDX,1)<0 AND REF(DDX,2)<0 AND REF(DDX,3)>0,3,TA2);
TA4:=IF (DDX<0 AND REF(DDX,1)<0 AND REF(DDX,2)<0 AND REF(DDX,3)<0 AND REF(DDX,4)>0,4,TA3);
TA5:=IF (DDX<0 AND REF(DDX,1)<0 AND REF(DDX,2)<0 AND REF(DDX,3)<0 AND REF(DDX,4)<0 AND REF(DDX,5)>0,5,TA4);
TA6:=IF (DDX<0 AND REF(DDX,1)<0 AND REF(DDX,2)<0 AND REF(DDX,3)<0 AND REF(DDX,4)<0 AND REF(DDX,5)<0 AND REF(DDX,6)>0,6,TA5);
TA7:=IF (DDX<0 AND REF(DDX,1)<0 AND REF(DDX,2)<0 AND REF(DDX,3)<0 AND REF(DDX,4)<0 AND REF(DDX,5)<0 AND REF(DDX,6)<0 AND REF(DDX,7)>0,7,TA6);
TA8:=IF (DDX<0 AND REF(DDX,1)<0 AND REF(DDX,2)<0 AND REF(DDX,3)<0 AND REF(DDX,4)<0 AND REF(DDX,5)<0 AND REF(DDX,6)<0 AND REF(DDX,7)<0 AND REF(DDX,8)>0,8,TA7);
TA9:=IF (DDX<0 AND REF(DDX,1)<0 AND REF(DDX,2)<0 AND REF(DDX,3)<0 AND REF(DDX,4)<0 AND REF(DDX,5)<0 AND REF(DDX,6)<0 AND REF(DDX,7)<0 AND REF(DDX,8)<0 AND REF(DDX,9)>0,9,TA8);
TA:=IF (DDX<0 AND REF(DDX,1)<0 AND REF(DDX,2)<0 AND REF(DDX,3)<0 AND REF(DDX,4)<0 AND REF(DDX,5)<0 AND REF(DDX,6)<0 AND REF(DDX,7)<0 AND REF(DDX,8)<0 AND REF(DDX,9)<0,10,TA9);
TAA:=IF (DDX<0,TA,T);
DRAWTEXT_FIX(1,0.24,0.59,0,STRCAT(STRCAT(' ',CON2STR(TAA,0)),' [天] ')),COLORYELLOW;
T11:=IF (DDY>0 AND REF(DDY,1)<0,1,0);
T21:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)<0,2,T11);
T31:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)<0,3,T21);
T41:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)<0,4,T31);
T51:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)<0,5,T41);
T61:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)<0,6,T51);
T71:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)<0,7,T61);
T81:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)<0,8,T71);
T91:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)>0 AND REF(DDY,9)<0,9,T81);
TY:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)>0 AND REF(DDY,9)>0,10,T91);
TB11:=IF (DDY<0 AND REF(DDY,1)>0,1,0);
TB21:=IF (DDY<0 AND REF(DDY,1)<0 AND REF(DDY,2)>0,2,TB11);
TB31:=IF (DDY<0 AND REF(DDY,1)<0 AND REF(DDY,2)<0 AND REF(DDY,3)>0,3,TB21);
TB41:=IF (DDY<0 AND REF(DDY,1)<0 AND REF(DDY,2)<0 AND REF(DDY,3)<0 AND REF(DDY,4)>0,4,TB31);
TB51:=IF (DDY<0 AND REF(DDY,1)<0 AND REF(DDY,2)<0 AND REF(DDY,3)<0 AND REF(DDY,4)<0 AND REF(DDY,5)>0,5,TB41);
TB61:=IF (DDY<0 AND REF(DDY,1)<0 AND REF(DDY,2)<0 AND REF(DDY,3)<0 AND REF(DDY,4)<0 AND REF(DDY,5)<0 AND REF(DDY,6)>0,6,TB51);
TB71:=IF (DDY<0 AND REF(DDY,1)<0 AND REF(DDY,2)<0 AND REF(DDY,3)<0 AND REF(DDY,4)<0 AND REF(DDY,5)<0 AND REF(DDY,6)<0 AND REF(DDY,7)>0,7,TB61);
TB81:=IF (DDY<0 AND REF(DDY,1)<0 AND REF(DDY,2)<0 AND REF(DDY,3)<0 AND REF(DDY,4)<0 AND REF(DDY,5)<0 AND REF(DDY,6)<0 AND REF(DDY,7)<0 AND REF(DDY,8)>0,8,TB71);
TB91:=IF (DDY<0 AND REF(DDY,1)<0 AND REF(DDY,2)<0 AND REF(DDY,3)<0 AND REF(DDY,4)<0 AND REF(DDY,5)<0 AND REF(DDY,6)<0 AND REF(DDY,7)<0 AND REF(DDY,8)<0 AND REF(DDY,9)>0,9,TB81);
TBY:=IF (DDY<0 AND REF(DDY,1)<0 AND REF(DDY,2)<0 AND REF(DDY,3)<0 AND REF(DDY,4)<0 AND REF(DDY,5)<0 AND REF(DDY,6)<0 AND REF(DDY,7)<0 AND REF(DDY,8)<0 AND REF(DDY,9)<0,10,TB91);
TBB:=IF (DDY<0,TBY,TY);
DRAWTEXT_FIX(1,0.24,0.75,0,STRCAT(STRCAT(' ',CON2STR(TBB,0)),' [天] ')),COLORYELLOW;
T1Z:=IF (DDZ>0 AND REF(DDZ,1)<0,1,0);
T2Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)<0,2,T1Z);
T3Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)<0,3,T2Z);
T4Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)<0,4,T3Z);
T5Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)<0,5,T4Z);
T6Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)<0,6,T5Z);
T7Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)<0,7,T6Z);
T8Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)<0,8,T7Z);
T9Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)>0 AND REF(DDZ,9)<0,9,T8Z);
TZ:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)>0 AND REF(DDZ,9)>0,10,T9Z);
TC1Z:=IF (DDZ<0 AND REF(DDZ,1)>0,1,0);
TC2Z:=IF (DDZ<0 AND REF(DDZ,1)<0 AND REF(DDZ,2)>0,2,TC1Z);
TC3Z:=IF (DDZ<0 AND REF(DDZ,1)<0 AND REF(DDZ,2)<0 AND REF(DDZ,3)>0,3,TC2Z);
TC4Z:=IF (DDZ<0 AND REF(DDZ,1)<0 AND REF(DDZ,2)<0 AND REF(DDZ,3)<0 AND REF(DDZ,4)>0,4,TC3Z);
TC5Z:=IF (DDZ<0 AND REF(DDZ,1)<0 AND REF(DDZ,2)<0 AND REF(DDZ,3)<0 AND REF(DDZ,4)<0 AND REF(DDZ,5)>0,5,TC4Z);
TC6Z:=IF (DDZ<0 AND REF(DDZ,1)<0 AND REF(DDZ,2)<0 AND REF(DDZ,3)<0 AND REF(DDZ,4)<0 AND REF(DDZ,5)<0 AND REF(DDZ,6)>0,6,TC5Z);
TC7Z:=IF (DDZ<0 AND REF(DDZ,1)<0 AND REF(DDZ,2)<0 AND REF(DDZ,3)<0 AND REF(DDZ,4)<0 AND REF(DDZ,5)<0 AND REF(DDZ,6)<0 AND REF(DDZ,7)>0,7,TC6Z);
TC8Z:=IF (DDZ<0 AND REF(DDZ,1)<0 AND REF(DDZ,2)<0 AND REF(DDZ,3)<0 AND REF(DDZ,4)<0 AND REF(DDZ,5)<0 AND REF(DDZ,6)<0 AND REF(DDZ,7)<0 AND REF(DDZ,8)>0,8,TC7Z);
TC9Z:=IF (DDZ<0 AND REF(DDZ,1)<0 AND REF(DDZ,2)<0 AND REF(DDZ,3)<0 AND REF(DDZ,4)<0 AND REF(DDZ,5)<0 AND REF(DDZ,6)<0 AND REF(DDZ,7)<0 AND REF(DDZ,8)<0 AND REF(DDZ,9)>0,9,TC8Z);
TCZ:=IF (DDZ<0 AND REF(DDZ,1)<0 AND REF(DDZ,2)<0 AND REF(DDZ,3)<0 AND REF(DDZ,4)<0 AND REF(DDZ,5)<0 AND REF(DDZ,6)<0 AND REF(DDZ,7)<0 AND REF(DDZ,8)<0 AND REF(DDZ,9)<0,10,TC9Z);
TCC:=IF (DDZ<0,TCZ,TZ);
DRAWTEXT_FIX(1,0.24,0.90,0,STRCAT(STRCAT(' ',CON2STR(TCC,0)),' [天] ')),COLORYELLOW;

通达信仿文峰K线主图指标公式

 

相关文章