在线检测未来函数

通达信风字部主图指标公式

来源:Internet,编辑:股旁网,2013-02-27

买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
STICKLINE(买线>=卖线,CLOSE,OPEN,3,0), COLOR7070FF{B0B0FF};
STICKLINE(买线>=卖线,LOW,HIGH,0,0), COLORYELLOW;
STICKLINE(买线<卖线,CLOSE,OPEN,3,0), COLORFF6600;
STICKLINE(买线<卖线,LOW,HIGH,0,0), {COLORCYAN;}COLORFFCC66;
合力线:FORCAST(C,10),COLOR00FF00,LINETHICK2;
保守线:HHV(FORCAST(C,10),18),COLORRED,LINETHICK2;
顶线:HHV(H,20),COLORCCFFFF,LINETHICK1;
底线:LLV(L,20),COLORYELLOW,LINETHICK1;
V1:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9);
HY1:=REF(EMA(V1,3),1);
DRAWTEXT(CROSS(CLOSE,HY1),LOW,'Ⅲ'),COLORWHITE;
SHORT:=12;
LONG:=26;
M:=9;
DIFF:=EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:=EMA(DIFF,M);
MACD:=2*(DIFF-DEA);
低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;
DRAWTEXT(低位金叉,L*0.92,'低位金叉'),COLORF00FF0;
A1:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));
二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(A1=2,21)=1;
DRAWTEXT(二次金叉,L*0.90,'二次金叉');
DRAWTEXT(CROSS(MA(CLOSE,9),MA(CLOSE,20)),LOW,'牛抬头'),COLORRED;
DRAWICON(CROSS(CCI,-200),CLOSE,4);

通达信风字部主图指标公式

 

相关文章