在线检测未来函数

通达信进出线主图指标公式

来源:Internet,编辑:股旁网,2013-02-27

bc:=((H*0.5+L*0.5)*0.382+(O*0.382+C*0.618)*0.618);
Mc:=(EMA(c,5*2)+EMA(c,12)+EMA(c,7*2))/3;
Mh:=(EMA(h,5*2)+EMA(h,12)+EMA(h,7*2))/3;
Ml:=(EMA(l,5*2)+EMA(l,12)+EMA(l,7*2))/3;
Mo:=(EMA(O,5*2)+EMA(O,12)+EMA(O,7*2))/3;
MAF:=((Mc*0.618+MO*0.382)*0.618+(MH*0.5+ML*0.5)*0.382);
MAc:=(EMA(c,6*2)+EMA(c,13)+EMA(c,7*2))/3;
MAh:=(EMA(h,6*2)+EMA(h,13)+EMA(h,7*2))/3;
MAl:=(EMA(l,6*2)+EMA(l,13)+EMA(l,7*2))/3;
MAo:=(EMA(O,6*2)+EMA(O,13)+EMA(O,7*2))/3;
MA1:=((MAc*0.618+MAO*0.382)*0.618+(MAH*0.5+MAL*0.5)*0.382);
MA2c:=(EMA(c,(7*2))+EMA(c,15)+EMA(c,(8*2)))/3;
MA2h:=(EMA(h,(7*2))+EMA(h,15)+EMA(h,(8*2)))/3;
MA2l:=(EMA(l,(7*2))+EMA(l,15)+EMA(l,(8*2)))/3;
MA2o:=(EMA(O,(7*2))+EMA(O,15)+EMA(O,(8*2)))/3;
MA2:=((MA2c*0.618+MA2O*0.382)*0.618+(MA2H*0.5+MA2L*0.5)*0.382);
多空线:=(MA1+ma2+maF)/3;
MA3c:=(EMA(c,(3*8))+EMA(c,26)+EMA(c,(4*7)))/3;
MA3h:=(EMA(h,(3*8))+EMA(h,26)+EMA(h,(4*7)))/3;
MA3l:=(EMA(l,(3*8))+EMA(l,26)+EMA(l,(4*7)))/3;
MA3o:=(EMA(O,(3*8))+EMA(O,26)+EMA(O,(4*7)))/3;
进出:=(((MA3c*0.618+MA3O*0.382)*0.618+(MA3H*0.5+MA3L*0.5)*0.382));
进出线:进出+STD((多空线-进出),20),COLOR6600FF,LINETHICK;
SQ:=进出线>REF(进出线,1);
XQ:=进出线<REF(进出线,1);
SQS:=BACKSET(BARSLAST(NOT(SQ))>=5,BARSLAST(NOT(SQ))),LINETHICK;
XQS:=BACKSET(BARSLAST(NOT(XQ))>=5,BARSLAST(NOT(XQ))),LINETHICK;
DRAWTEXT(NOT(XQS),进出线,'*'),COLORRED,LINETHICK1;
DRAWTEXT(NOT(SQS),进出线,'*'),COLORAAAA00,LINETHICK1;

通达信进出线主图指标公式

 

相关文章