在线检测未来函数

通达信圆满启动指标公式

来源:Internet,编辑:股旁网,2013-02-27

{秘密筹码}
VAR22:=REF(LOW,1);
VAR23:=((SMA(ABS((LOW - VAR22)),3,1) / SMA(MAX((LOW - VAR22),0),3,1)) * 100);
VAR24:=EMA(IF((CLOSE * 1.2),(VAR23 * 10),(VAR23 / 10)),3);
VAR25:=LLV(LOW,38);
VAR26:=HHV(VAR24,38);
VAR27:=IF(LLV(LOW,90),1,0);
VAR28:=((EMA(IF((LOW <= VAR25),((VAR24 + (VAR26 * 2)) / 2),0),3) / 618) * VAR27);
主力秘密筹码:STICKLINE(VAR28,-50,VAR28/3-50,6,1),COLORRED;
{浮动筹码}
VAR111:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
VAR112:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR113:=(SMA(VAR112,3,1)-18)*1.55;
VAR114:=SMA(VAR113,3,1);
VAR115:=(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100))*100;
VAR116:=SMA(VAR115,10,1);
VAR117:=(EMA(SMA(VAR116,8,1),34)-25)*2.6;
VAR118:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);
VAR119:=POW(MA(LOW,5),2)+MA(LOW,5);
VAR11A:=POW(MA(HIGH,5),2)+MA(HIGH,5);
VAR11B:=((VAR118-LLV(VAR119,64))/(HHV(VAR11A,64)-LLV(VAR119,64))*150+65-10)/2;
VAR11C:=SMA(VAR11B,3,1)*1.5-46;
VAR11D:=SMA(VAR11C,3,1);
VAR11E:=3*VAR11C-2*VAR11D;
VAR11F:=(VAR111+VAR112+VAR115)/3;
VAR1110:=((VAR113+VAR113+VAR116+VAR11C)/4-15)*1.67;
VAR1111:=((VAR114+VAR114+VAR117+VAR11D)/4-15)*1.67;
VAR1112:=((VAR111+VAR115*2+VAR11F+VAR1110+VAR1111+VAR11B+VAR11C+VAR11D+VAR11E)/10-15)*1.67;
VAR1113:=(HHV(HIGH,5)-CLOSE)/(HHV(HIGH,5)-LLV(LOW,5))*(-1)+0.9;
VAR1114:=(HHV(HIGH,10)-CLOSE)/(HHV(HIGH,10)-LLV(LOW,10))*(-1)+0.92;
VAR1115:=(HHV(HIGH,15)-CLOSE)/(HHV(HIGH,15)-LLV(LOW,15))*(-1)+0.93;
VAR1116:=(HHV(HIGH,55)-CLOSE)/(HHV(HIGH,55)-LLV(LOW,55))*(-1)+0.94;
VAR1117:=(HHV(HIGH,89)-CLOSE)/(HHV(HIGH,89)-LLV(LOW,89))*(-1)+0.95;
VAR1118:=(HHV(HIGH,120)-CLOSE)/(HHV(HIGH,120)-LLV(LOW,120))*(-1)+0.91;
VAR1119:=(HHV(HIGH,180)-CLOSE)/(HHV(HIGH,180)-LLV(LOW,180))*(-1)+0.96;
VAR111A:=((VAR1113*8+VAR1114*8+VAR1115*8+VAR1116+VAR1117+VAR1118+VAR1119)/28-0.1)*185;
VAR111B:=SMA(VAR111A,3,1);
VAR111C:=(SMA(VAR111B,8,1)-8)*1.18;
浮动筹码: (VAR1110+VAR1111+VAR1112+VAR11C+VAR11D+VAR11E+VAR111C+VAR117)/13,COLORWHITE,POINTDOT;
浮动筹码1: (VAR1110+VAR1111+VAR1112+VAR11C+VAR11D+VAR11E+VAR111C+VAR117)/21,COLORWHITE,POINTDOT;
浮动筹码2: (VAR1110+VAR1111+VAR1112+VAR11C+VAR11D+VAR11E+VAR111C+VAR117)/34,COLORWHITE,POINTDOT;
{主要部分}
VAR1AA:5,COLORGREEN;
止损:=CLOSE/(1.04);
逃命:=CLOSE/1.06;
趋势: 3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),LINETHICK2,COLORWHITE;
买警1: IF(趋势<=30,-30,0),LINETHICK1,COLORGREEN;
买警2: IF(趋势<=25,-25,0),LINETHICK1,COLORYELLOW;
买警3: IF(趋势<=15,-15,0),LINETHICK1,COLORMAGENTA;
买警4: IF(趋势<=10,-10,0),LINETHICK3,COLORRED;
卖5: IF(趋势>=105,96,105),LINETHICK2,COLORBLUE;
卖4: IF(趋势>=95,86,95),LINETHICK2,COLORRED;
卖3: IF(趋势>=88,79,88),LINETHICK2,COLORYELLOW;
卖2: IF(趋势>=81,66,81),LINETHICK2,COLORMAGENTA;
卖1: IF(趋势>=74,57,74),LINETHICK2,COLORBLUE;
准备启爆点:IF(CROSS(趋势,VAR1AA),0,-50),COLORMAGENTA,LINETHICK2;
神秘私募买点:IF((趋势<=3),-40,-50),COLORGREEN,LINETHICK2;
机构建增补仓:IF((趋势<5),-30,-50),COLORYELLOW,LINETHICK2;
{中长趋势}
RSV1:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
K1:=SMA(RSV1,6,1);
D1:=SMA(K1,6,1);
STICKLINE(EMA(D1,3)>REF(EMA(D1,3),1) ,EMA(D1,3) ,REF(EMA(D1,3),1) ,3 ,0),COLORRED;
STICKLINE(EMA(D1,3)<REF(EMA(D1,3),1) ,EMA(D1,3) ,REF(EMA(D1,3),1) ,3 ,0 ),COLORYELLOW;
VAR55:=EMA(0.382*REF(D1,1)+0.618*D1,2);
生命线:EMA(D1,10), COLORFFAA00,LINETHICK2;
IF(生命线<REF(生命线,1),生命线,DRAWNULL),COLORFFAA00,LINETHICK2;
IF(生命线>REF(生命线,1),生命线,DRAWNULL),COLORRED,LINETHICK2;
RSV2:=(CLOSE-LLV(LOW,120))/(HHV(HIGH,120)-LLV(LOW,120))*100;
K2:=SMA(RSV2,12,1);
D2:=SMA(K2,12,1);
STICKLINE(EMA(D2,6)>REF(EMA(D2,6),1) ,EMA(D2,6) ,REF(EMA(D2,6),1) ,3 ,0),COLORMAGENTA;
STICKLINE(EMA(D2,6)<REF(EMA(D2,6),1) ,EMA(D2,6) ,REF(EMA(D2,6),1) ,3 ,0 ),COLORGREEN;
{筹码}
VAR1:=1;
VAR2:=1/WINNER(CLOSE);
VAR3:=MA(CLOSE,13);
VAR4:=100-ABS((CLOSE-VAR3)/VAR3*100);
VAR5:=LLV(LOW,75);
VAR6:=HHV(HIGH,75);
VAR7:=(VAR6-VAR5)/100;
VAR8:=SMA((CLOSE-VAR5)/VAR7,20,1);
VAR9:=SMA((OPEN-VAR5)/VAR7,20,1);
VARA:=3*VAR8-2*SMA(VAR8,15,1);
VARB:=3*VAR9-2*SMA(VAR9,15,1);
VARC:=100-VARB;
主力:= (100-VARA)*VAR1;
散户:=MA(WINNER(CLOSE*0.95)*100,3)*VAR1;
新庄:=(100-IF(VAR2>5,IF(VAR2<100,VAR2,VAR4-10),0))*VAR1;
VARD:=散户>VAR4;
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*VOL+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=CLOSE-REF(CLOSE,1);
VAR13:=MAX(VAR12,0);
VAR14:=ABS(VAR12);
VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;
VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;
VAR17:=BARSCOUNT(CLOSE);
VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;
VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;
STICKLINE(VARD,VAR4,散户,5,0),COLORWHITE;
STICKLINE(VAR20,0,80,5,0),COLORRED,LINETHICK3;
VAR1Z:=3;
股价启动在即:IF(CROSS(趋势,VAR1Z),50,0),COLORYELLOW;
AAAAAA:-50,LINETHICK2,COLORRED;

通达信圆满启动指标公式

 

相关文章