在线检测未来函数

通达信顶底涨跌定主图指标公式

来源:Internet,编辑:股旁网,2013-02-27

多空线:(MA(C,8)+MA(C,17)+MA(C,26)+MA(C,35)+MA(C,44)+MA(C,53)+MA(C,62)+MA(C,71)+MA(C,80)+MA(C,91)+MA(C,102)+MA(C,113)+MA(C,124)+MA(C,135)+MA(C,146)+MA(C,157)+MA(C,168))/17,COLORWHITE;
做多:多空线+STD(C,80),COLORRED;
做空:多空线-STD(C,80),COLORGREEN;
买线:=EMA(C,4);
卖线:=EMA(SLOPE(C,20)*10+C,35);
DRAWTEXT(CROSS(买线,卖线),LOW*1.00,'←买'),COLORRED,LINETHICK2;
DRAWTEXT(CROSS(卖线,买线),HIGH*1.01,'←卖'),COLORGREEN;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
DRAWTEXT(CROSS(90,RSI) , HIGH*1.01,'←逢高出局!'),COLOR00FF00 ;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;
主力成本:EMA(X,13),COLORFF00FF,LINETHICK0;
ZZ:=(O+H+L)/3;
YC:=(H+L)/2;
YCHJX:=(EMA(ZZ,4))+(YC-REF(ZZ,3))/4;
今日买点:EMA(ZZ,3),COLORYELLOW,LINETHICK0;
明日买点:YCHJX,LINETHICK0;
昨测今日买点:REF(YCHJX,1),LINETHICK0;
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
DRAWTEXT(CROSS(MA15,FF),(HIGH * 1.02),'←拐点卖'),COLOR00FF00;
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),'←拐点买'),COLOR00FFFF;
VAR1:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);
VAR2:=CROSS(VAR1,0.9);
VAR3:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);
VAR4:=CROSS(VAR3,0.9);
压力: REF(HIGH,BARSLAST(VAR2)), POINTDOT,COLOREA91B5;
STICKLINE(CLOSE,REF(HIGH,BARSLAST(VAR2)),REF(HIGH,BARSLAST(VAR2)),5,0),COLOREA91B5;
支撑: REF(LOW,BARSLAST(VAR4)), POINTDOT,COLOR3791B5;
STICKLINE(CLOSE,REF(LOW,BARSLAST(VAR4)),REF(LOW,BARSLAST(VAR4)),5,0),COLOR3791B5;
DRAWTEXT(VAR2,HIGH*1.01,'跌定'),COLOR00E40E;
VAR5:=IF(VAR2,HIGH,IF(VAR4,LOW,0));
VAR6:=BACKSET(REF(HIGH,2)=HHV(HIGH,5) AND LOW<REF(LOW,1) AND HIGH<REF(HIGH,1),3);
VAR7:=BACKSET(REF(HIGH,2)=HHV(HIGH,5) AND LOW>REF(LOW,1) AND HIGH>REF(HIGH,1),3);
VAR8:=BACKSET(REF(HIGH,2)=HHV(HIGH,5) AND HIGH<REF(HIGH,1) AND LOW>REF(LOW,1)
AND REF(LOW,1)>REF(LOW,2) AND REF(HIGH,1)<REF(HIGH,2),3);
VAR9:=BACKSET(REF(LOW,2)=LLV(LOW,5) AND LOW>REF(LOW,1) AND HIGH>REF(HIGH,1),3);
VARA:=BACKSET(REF(LOW,2)=LLV(LOW,5) AND LOW<REF(LOW,1) AND HIGH<REF(HIGH,1),3);
VARB:=BACKSET(REF(LOW,2)=LLV(LOW,5) AND HIGH<REF(HIGH,1) AND LOW>REF(LOW,1)
AND REF(LOW,1)>REF(LOW,2) AND REF(HIGH,1)<REF(HIGH,2),3);
DRAWTEXT(CROSS(VAR9,0.9),LOW*0.99,'涨定'),COLOR0000FF;
DRAWTEXT(CROSS(VARA,0.9),HIGH*1.01,'犹豫'),COLOR00E5E9;
现价:CLOSE,POINTDOT,COLORRED;
N:=150;判断高低:=3;
高:=REF(HHV(H,N),判断高低);
近期顶:REFDATE(高,DATE),COLORGREEN,LINETHICK3;
最顶:=REFDATE(近期顶,DATE),NODRAW;
出:=最顶=H AND ((C-L)<(O-C) OR (O-L)<(C-O)),NODRAW;
STICKLINE(出,C,O,3,0),COLORGREEN;
STICKLINE(出,C,O,2,0),COLORGREEN;
低:=REF(LLV(L,N),判断高低);
近期底:REFDATE(低,DATE),COLORRED,LINETHICK3;
最底:=REFDATE(近期底,DATE),NODRAW;
进:=最底=L AND ((C+L)<(O+C) OR (O+L)<(C+O)),NODRAW;
STICKLINE(进,C,O,3,0),COLORRED;
STICKLINE(进,C,O,2,0),COLORRED;
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
牛线:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15*REF(MID,5)+14*REF
(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10*REF(MID,10)+9*REF(MID,11)+8*REF
(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF
(MID,18)+REF(MID,20))/210,COLORRED;
马线:MA(牛线,8),COLORGREEN;
DRAWICON( FILTER(CROSS(牛线,马线),20),马线+0.02 ,1);
DRAWTEXT(CROSS(牛线,马线),LOW*0.98,'买'),COLORRED,LINETHICK2;
庄家:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+
16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+
13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+
10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+
7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+
4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORRED;

通达信顶底涨跌定主图指标公式

 

相关文章