在线检测未来函数

通达信MACD+KD+RSI+WR指标公式

来源:Internet,编辑:股旁网,2013-02-28

STICKLINE(1,0,20,10,0)COLOR003300,LINETHICK2;
STICKLINE(1,80,100,10,0)COLOR000033,LINETHICK2;
STICKLINE(1,80,20,10,0)COLOR333333,LINETHICK2;
DIFF:=(EMA(C,12)-EMA(C,26))/EMA(C,26)*1000,NODRAW;
DEA:=EMA(DIFF,9),COLOR000000;
DRAWBAND(DIFF+50,RGB(155,50,50),EMA(DIFF+50,9),RGB(0,50,150));
IF(C,EMA(DIFF+50,9),DRAWNULL),COLORFFFFFF,LINETHICK1;
IF(C,DIFF+50,DRAWNULL),COLORRED,LINETHICK1;
IF(DIFF<=REF(DIFF,1),DIFF+50,DRAWNULL),COLORFFF000;
MACD:2*(DIFF-DEA)+50,NODRAW;
STICKLINE(MACD<REF(MACD,1)AND MACD>50,50,MACD,2,1),COLORCYAN;
STICKLINE(MACD<REF(MACD,1)AND MACD<50,50,MACD,2,1),COLORCYAN;
STICKLINE(MACD>REF(MACD,1)AND MACD<50,50,MACD,2,1),COLORLIMAGENTA;
STICKLINE(MACD>REF(MACD,1)AND MACD>50,50,MACD,2,1),COLORLIMAGENTA;
50,DOTLINE,COLORWHITE;20,COLORGREEN;80,COLORBLUE;
N1:=9;
LC:=REF(CLOSE,1);
RSI短:SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,COLORRED,LINETHICK2;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,3,1),COLORWHITE;
D:SMA(K,3,1),COLORYELLOW;
DRAWNUMBER(ISLASTBAR,CONST(RSI短),RSI短),COLORRED;
WR:100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14)),COLORGREEN,LINETHICK2;
DRAWICON(CROSS(RSI短,WR),WR,1);
DRAWICON(CROSS(WR,RSI短),RSI短,2);

通达信MACD+KD+RSI+WR指标公式

 

相关文章