在线检测未来函数

通达信战斗英雄主图指标公式

来源:Internet,编辑:股旁网,2013-03-01

N:=5;
GET:ZIG(3,N),COLORYELLOW;
EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
PL10:=ZIG(3,10);
EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
PL20:=ZIG(3,20);
EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
VV0:=BARSLAST(PL10<REF(PL10,1));
VV1:=BARSLAST(PL10>REF(PL10,1));
VV2:=BARSLAST(PL20<REF(PL20,1));
ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,VV0),0);
ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,VV0),0);
DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,VV1),0);
ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,VV2),0);
ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,VV2),0);
DRAWTEXT(EN2 AND ZTJZ5=1,L*0.94,'发现目标'),COLORRED;
DRAWTEXT(EN3 AND ZTJZ10=1,L*0.94,'发现目标'),COLORRED;
DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2) AND EX2,H*1.06,'结束战斗'),COLORGREEN

通达信战斗英雄主图指标公式

 

相关文章