在线检测未来函数

大智慧江恩最准指标公式

来源:Internet,编辑:股旁网,2013-03-01

INPUT: N(3,1,300),M(3,1,300);
捞:CROSS(ZIG(3,8),REF(ZIG(3,8),1)),COLORCYAN,PRECIS0;
布下轨:CROSS("BOLL.LOWER"(26,2),L),COLORRED,linethick0,PRECIS0;
MID:=MA(CLOSE,26);
布中轨:CROSS("BOLL.MID",L),COLORYELLOW,linethick0,PRECIS0;
STICKLINE(CROSS("BOLL.MID",L),0,0.3,10,0),COLORYELLOW;
STICKLINE(CROSS("BOLL.LOWER"(26,2),L),0,0.5,8,0),COLORRED;
{"出现布林线中下轨迹,5天内出现捞钱手,且K<28有效"};
DRAWTEXT(布下轨=1,0.8,'下轨' ),COLORRED,linethick2;
DRAWTEXT(布中轨=1,0.6,'中轨' ),COLORYELLOW,linethick2;
X12:=1;
X13:=REF(HIGH,1)*1.1;
X14:=HIGH*1.1;
X15:=(X14*VOL+X13*(CAPITAL-VOL))/CAPITAL;
X16:=REF(LOW,1)*0.9;
X17:=LOW*0.9;
X18:=(X17*VOL+X16*(CAPITAL-VOL))/CAPITAL;
X19:=EMA(X18,30);
VARA:=EMA(X15,30);
VARB:=VARA-2;
VARC:=IF(CLOSE<=X19,VARB,VARA);
神獒买入:=(FILTER(VARC-VARB=0 AND CROSS((EMA(EMA(EMA(CLOSE,N),N),N)-REF(EMA(EMA(EMA(CLOSE,N),N),N),1))/REF(EMA(EMA(EMA(CLOSE,N),N),N),1)*100,MA((EMA(EMA(EMA(CLOSE,N),N),N)-REF(EMA(EMA(EMA(CLOSE,N),N),N),1))/REF(EMA(EMA(EMA(CLOSE,N),N),N),1)*100,M)),4));
神獒:CROSS(神獒买入,0.5),COLOR00FF00,linethick0,PRECIS0;
{MN 3 1 300 1;}
STICKLINE(神獒,0,0.7,6,0),COLOR00FF00;
DRAWTEXT(神獒=1,1,'神獒' ),COLOR00FF00,linethick2;
AA05:=MA(C,5);
五日乖离率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3);
AA10:=MA(C,10);
AA20:=MA(C,20);
BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
VAR1:=(AA20-AA30)>REF((AA20-AA30),1) AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);
VAR2:=(AA30-AA20)<REF((AA30-AA20),1) AND AA20<REF(AA20,1) AND AA30<REF(AA30,1);
BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;
强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1) AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>AA30 OR O>AA30) AND AA05<REF(AA05,1) AND 三拾日乖离率<REF(三拾日乖离率,1) AND AA10<REF(AA10,1),10);
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
买入:=FILTER(MR,10);
乖离率买入:CROSS(买入,0.5),COLORBLUE,linethick0,PRECIS0;
STICKLINE(乖离率买入,0,0.9,4,0),COLORBLUE;
DRAWTEXT(乖离率买入=1,1,'乖离' ),COLORBLUE,linethick2;
{超准完美买卖选股1短进}
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
X:=LLV(J,2)=LLV(J,8);
短进:CROSS(J,REF(J+0.01,1)) AND X AND J<20,COLORWHITE,linethick0,PRECIS0;
STICKLINE(短进,0,-0.3,10,0),COLORWHITE;
DRAWTEXT(短进=1,-0.4,'短进' ),COLORWHITE,linethick2;
{超准完美买卖选股2见底}
主力:=EMA( (CLOSE-MA(CLOSE,3))/MA(CLOSE,3),2);
散户:=EMA( (CLOSE-MA(CLOSE,20))/MA(CLOSE,20),7);
超准2:=LLV(LOW,10);
超准3:=HHV(HIGH,25);
动能趋势线:=100*EMA((CLOSE-超准2)/(超准3-超准2),4);
见底:CROSS(主力,散户) AND 主力<0 AND 散户<0,COLOR000080,linethick0,PRECIS0;
STICKLINE(见底,0,-0.5,8,0),COLOR000080;
DRAWTEXT(见底=1,-0.6,'见底' ),COLOR000080,linethick2;
{X1: 0;}
r1:=MA(CLOSE,5);
r2:=MA(CLOSE,10);
r3:=MA(CLOSE,20);
r4:=MA(CLOSE,30);
r5:=(r1+r2+r3+r4)/4;
r6:=(r5-REF(r5,5))/REF(r5,5)*1500;
r7:=(r5-REF(r5,5))/REF(r5,5)*1500;
r8:=EMA(r6,8);
R9:=TROUGHBARS(3,15,1)<10;
R10:=PEAKBARS(3,15,1)<10;
R11:=IF(R9=1,50,0);
R12:=IF(R10=1,50,0);
底部部:= IF(R11=50,50,0);
头部部:= IF(R12=50,100,0);
江恩买:底部部>ref(底部部,1),COLORFF00FF,linethick0,PRECIS0;
头1:=头部部>ref(头部部,1);
STICKLINE(江恩买,0,-0.7,6,0),COLORFF00FF;
卖:-CROSS(头1,0),PRECIS0;
DRAWTEXT(江恩买=1,-0.7,'江恩买' ),COLORFF00FF,linethick2;
DRAWTEXT(头1=1,-0.5,'卖'),COLORffffff,linethick2;

大智慧江恩最准指标公式

 

相关文章