在线检测未来函数

飞狐量价MACD指标公式

来源:Internet,编辑:股旁网,2013-03-02

本指标根据macd的原理,把量加了进去,看起来更平滑,但也有其缺陷,大家可以比较。能直观看出量的变化。

VC:=(REF(C,4)*REF(V,4)+REF(C,3)*REF(V,3)+REF(C,2)*REF(V,2)+REF(C,1)*REF(V,1)+C*V)/(V+REF (V,1)+REF(V,2)+REF(V,3)+REF(V,4));
SQX:=(VC-MA(VC,14))*100;
DIF:MA(SQX,4),COLORWHITE;
DEA:EMA(DIF,5),COLORYELLOW;
MACD:(DIF-DEA)*2,linethick0;
STICKLINE(macd>0 and macd>ref(macd,1),0,macd,8,0),COLORred;
STICKLINE(macd>0 and macd<ref(macd,1),0,macd,8,1),COLORred;
STICKLINE(macd<0 and macd<ref(macd,1),0,macd,8,0),COLORgreen;
STICKLINE(macd<0 and macd>ref(macd,1),0,macd,8,1),COLORgreen;
VAR1:=HHV(DEA,53);
VAR2:=LLV(DEA,55);
VAR3:=DEA-(DIF-DEA);
DEA高点延长线:IF(DIF>VAR1 AND DEA=VAR1,MAX(LLV (VAR1,10),VAR3),VAR1),LINEDOT,ColorEA91B5,LINETHICK1;
DEA低点延长线:IF(DIF<VAR2 AND DEA=VAR2,MIN(HHV (VAR2,10),VAR3),VAR2),COLOR00FFFF,LINEDOT,LINETHICK1;

飞狐量价MACD指标公式

 

相关文章