在线检测未来函数

通达信剑客必赢主图指标公式

来源:Internet,编辑:股旁网,2013-03-03

MA5:MA(CLOSE,5),pointdot,color000000,linethick1;
MA21:=EMA(CLOSE,21);
MID:MA(CLOSE,21),color000000,linethick0;
风险线: MA(CLOSE,13),linethick3,COLORGREEN;
止损线: MA(CLOSE,27),linethick0,Coloree00ee;
UPPER:MID + 2*STD(C,20),LINETHICK0,COLORFFFFFF;
LOWER:MID - 2*STD(C,20),LINETHICK0,COLORFFFFFF;
H1:=EMA(SLOPE(CLOSE,34)*20+CLOSE,75);
H2:=EMA(CLOSE,8);
Var1d:=H2-H1;
a:=(3*c+l+o+h)/6;
b:=(20*a+19*ref(a,1)+18*ref(a,2)+17*ref(a,3)+16*ref(a,4)+15*ref(a,5)+14*ref(a,6)+13*ref(a,7)+12*ref(a,8)+11*ref(a,9)+10*ref(a,10)+9*ref(a,11)+8*ref(a,12)+7*ref(a,13)+6*ref(a,14)+5*ref(a,15)+4*ref(a,16)+3*ref(a,17)+2*ref(a,18)+ref(a,20))/210;
d:=ma(b,10);
STICKLINE((MA21 > REF(MA21,1)),MA21,MA21,5,6),LINETHICK2,Color00FFFF;
STICKLINE(C>=MID AND C>=O,C,O,5,0),COLORRED;
STICKLINE(C>=MID AND C>=O,H,L,0,0),COLORRED;
STICKLINE(C>=MID AND C<O,C,O,5,1),COLORRED;
STICKLINE(C>=MID AND C<O,O,H,0,0),COLORRED;
STICKLINE(C>=MID AND C<O,C,L,0,0),COLORRED;
STICKLINE(C<MID AND C>O,C,O,5,1),COLORffff00;
STICKLINE(C<MID AND C<=O,C,O,5,1),COLORffff00;
STICKLINE(C<MID AND C<=O,H,L,0,1),COLORffff00;
STICKLINE(C<MID AND C>O,C,H,0,1),COLORffff00;
STICKLINE(C<MID AND C>O,O,L,0,1),COLORffff00;
TY:=C;
A1:=REF(TY,10)=HHV(TY,2*10+1);
B11:=FILTER(A1,10);
C1:=BACKSET(B11,10+1);
HD:=FILTER(C1,10);
A2:=REF(TY,10)=LLV(TY,2*10+1);
B22:=FILTER(A2,10);
C2:=BACKSET(B22,10+1);
LD:=FILTER(C2,10);
LY:=REF(C,BARSLAST(HD));
LG:=REF(C,BARSLAST(LD));
t1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD) ;
t2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);
波峰:IF(t1,LY,LY),ColorFF80FF,POINTDOT,LINETHICK1;
波谷:IF(t2,LG,LG),Color00FF00,POINTDOT,LINETHICK1;
牛熊线:EMA(C,250),CIRCLEDOT,color999999;
界:MA(CLOSE,21),,pointdot,color000000,linethick0;
VAR1:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR2:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
DRAWICON(CROSS(VAR2,MA(VAR3,6)),(LOW * 0.95),4),linethick3;
DRAWICON(CROSS(MA(VAR3,6),VAR1),(HIGH * 1.05),5),linethick3;
DRAWTEXT(CROSS(VAR2,MA(VAR3,6)),(LOW * 0.988),'B'),coloryellow,linethick3;
DRAWTEXT(CROSS(MA(VAR3,6),VAR1),(HIGH * 1.02),'S'),colorFFFF34,linethick3;
STICKLINE(C>=界 AND C>=O,C,O,5,0),COLORRED;
STICKLINE(C>=界 AND C>=O,H,L,0,0),COLORRED;
STICKLINE(C>=界 AND C<O,C,O,5,1),COLORRED;
STICKLINE(C>=界 AND C<O,O,H,0,0),COLORRED;
STICKLINE(C>=界 AND C<O,C,L,0,0),COLORRED;
STICKLINE(C<界 AND C>O,C,O,5,1),COLORffff00;
STICKLINE(C<界 AND C<=O,C,O,5,1),COLORffff00;
STICKLINE(C<界 AND C<=O,H,L,0,1),COLORffff00;
STICKLINE(C<界 AND C>O,C,H,0,1),COLORffff00;
STICKLINE(C<界 AND C>O,O,L,0,1),COLORffff00;
DRAWTEXT(CROSS(MA5,界),(LOW * 0.90),'◇底背离'),COLORWHITE;
VAR11:=(ZIG(3,10) < REF(ZIG(3,10),1)) AND (REF(ZIG(3,10),1) > REF(ZIG(3,10),2));
VAR22:=(ZIG(3,10) > REF(ZIG(3,10),1)) AND (REF(ZIG(3,10),1) < REF(ZIG(3,10),2));
DRAWTEXT(VAR11,HIGH*1.05,'秋收'),COLORYELLOW;
DRAWTEXT(VAR22 AND (DATE < 1070804),LOW*0.97,'春播'),COLORFF00FF;
STICKLINE(VAR11 AND (DATE < 1070804),CLOSE,OPEN,5,0),COLORYELLOW;
STICKLINE(VAR11 AND (DATE < 1070804),HIGH,LOW,0.5,0),COLORYELLOW;
STICKLINE(VAR22 AND (DATE < 1070804),CLOSE,OPEN,5,0),COLORFF00FF;
STICKLINE(VAR22 AND (DATE < 1070804),HIGH,LOW,0.5,0),COLORFF00FF;

通达信剑客必赢主图指标公式

 

相关文章