在线检测未来函数

通达信成交量叠加净流入指标公式

来源:Internet,编辑:股旁网,2013-03-03

涨家:INDEXADV,NODRAW,COLORLIRED;
跌家:INDEXDEC,NODRAW,COLORLIBLUE;
套盘:=(1-WINNER(C))*100,COLORGREEN,NODRAW;
TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,240,1)))));
MTIME:=MOD(FROMOPEN,TOTAL);
CTIME:=IF(MTIME<0.5,TOTAL,MTIME);
VVOL:=IF(CURRBARSCOUNT=1,VOL*TOTAL/CTIME,DRAWNULL),NODRAW;
虚拟换:IF(CURRBARSCOUNT=1,VOL*TOTAL/CTIME/CAPITAL*100,DRAWNULL),COLORGREEN,NODRAW;
换手:VOL/CAPITAL*100,POINTDOT,NODRAW,COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=1 && (SETCODE=0 || SETCODE=1),VVOL,0,-1,-1),COLOR00C0C0;
超B:=L2_AMO(0,2)/10000.0;
大B:=L2_AMO(1,2)/10000.0;
中B:=L2_AMO(2,2)/10000.0;
小B:=L2_AMO(3,2)/10000.0;
超S:=L2_AMO(0,3)/10000.0;
大S:=L2_AMO(1,3)/10000.0;
中S:=L2_AMO(2,3)/10000.0;
小S:=L2_AMO(3,3)/10000.0;
净流入:(超B+大B+中B+小B)-(超S+大S+中S+小S),NODRAW;
N:=30;
ZJD:=HHV(净流入,N);
ZJX:=LLV(净流入,N);
CJ:=HHV(V,N);
BEIS:=CJ/(ZJD-ZJX);
值:=CONST(CJ+ABS(ZJX)*BEIS);
STICKLINE(净流入>0 ,值,值+净流入*BEIS,2,0),COLOR0000AA;
STICKLINE(净流入<=0 ,值,值+净流入*BEIS,2,0),COLOR00AA00;
DRAWTEXT(ISLASTBAR=1 AND 净流入<=0,值*1.12,' 净流入'),COLORGREEN;
DRAWTEXT(ISLASTBAR=1 AND 净流入>0,值*0.88,' 净流入'),COLORRED;
VOLUME:VOL,VOLSTICK;
V1:=MA(VOLUME,5);
V2:=MA(VOLUME,10);
V3:=MA(VOLUME,30);
{空中加油}
STICKLINE(C<O AND C>REF(C,1),0,V,2,0),COLORMAGENTA;
量1:V1,COLORWHITE;
量2:=V2,COLORYELLOW;
量3:=V3,COLORGREEN;
主买A:=ACTINVOL,COLORRED,NODRAW;
主卖A:=ACTOUTVOL,COLORGREEN,NODRAW;
主买:主买A*100/(主买A+主卖A),NODRAW,COLORRED;
主卖:主卖A*100/(主买A+主卖A),NODRAW,COLORGREEN;
XX:=CONST(主买*500/(主买+主卖)+50),NODRAW;
DRAWRECTREL(50,0,CONST(主买*500/(主买+主卖)+50),120,RGB(230,65,0));
DRAWRECTREL(50,150,CONST(主卖*500/(主买+主卖)+50),270,RGB(0,104,0));
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.005,0,0,'主买'),COLORLIRED;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.005,0.170,0,'主卖'),COLORGREEN;
DRAWNUMBER_FIX(CURRBARSCOUNT=1,CONST(主买*500/(主买+主卖)+55)/1000,0.001,0,ROUND(主买));
DRAWNUMBER_FIX(CURRBARSCOUNT=1,CONST(主卖*500/(主买+主卖)+55)/1000,0.170,0,ROUND(主卖));

通达信成交量叠加净流入指标公式

 

相关文章