在线检测未来函数

通达信黄金白银令指标公式

来源:Internet,编辑:股旁网,2013-03-04

var11:=(2*c+o+h+l)/5;
var12:=vol;
m8:=sum(var11*var12,8)/sum(var12,8);
m13:=sum(var11*var12,13)/sum(var12,13);
m21:=sum(var11*var12,21)/sum(var12,21);
r1:=c;
r2:=llv(low,45);
r3:=hhv(high,45);
y1:=c;
y2:=llv(low,144);
y3:=hhv(high,144);
RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV1,3,1),linethick1,colorff00ff;
D:=SMA(K,3,1),linethick2,coloryellow;
RSVr:=((r1-r2)/(r3-r2))*100;
Kr:=SMA(RSVr,3,1),colorred;
Dr:=SMA(Kr,3,1),coloryellow;
RSVy:=((y1-y2)/(y3-y2))*100;
Ky:=SMA(RSVy,3,1),colorccee33;
Dy:=SMA(Ky,3,1),coloryellow;
X1:=m8;
X2:=m13;
X3:=m21;
XX:=C>X2 AND C>X2 ,;
LC := REF(CLOSE,1);
RSI1:=SMA(MAX(CLOSE-LC,0),8,1)/SMA(ABS(CLOSE-LC),8,1)*100;
RSI2:=SMA(MAX(CLOSE-LC,0),21,1)/SMA(ABS(CLOSE-LC),21,1)*100,;
DIFF:= EMA(CLOSE,8) - EMA(CLOSE,21);
DEA:= EMA(DIFF,8);
MACD:= 2*(DIFF-DEA);
J13:=m8-m21,;
K13:=SMA(J13,3,1), ;
D13:=SMA(K13,3,1), ;
MACD13:=4*(k13-D13);
js:= MACD>0 AND K>D AND RSI1>50 AND DR<60 AND dy<60 AND XX>0 and macd13>0 and macd13>ref(macd13,1);
XG:= js>0 and cross(k,d) and cross(macd,0)and ma(v,5)>ma(v,40);
短:=d,color00FF00,LINETHICK1;
短1:=ref(d,1),colorred,LINETHICK1;
中:=dr,coloryellow,LINETHICK1;
中1:=ref(dr,1),colorf0f000;
长:=dy,colorFF00FF,LINETHICK1;
长1:=ref(dy,1),colorFF00FF,LINETHICK1;
aaa:=cross(d,ref(d,2))and 短1<50 and dr>ref(dr,1)and dy>ref(dy,1)
and d<30 and dr<20 and dy <20 ;
黄金令:STICKLINE(aaa>0,0,50,6,0),,coloryellow;
白银令:STICKLINE(xg>0,0,50,6,0),colorwhite;
短期主力:d,color00FF00,LINETHICK1;
中期主力:dr,color0099ff,LINETHICK1;
长期主力:dy,colorFF00FF,LINETHICK1;
{底部低吸}
var2:=REF(LOW,1);
var3:=SMA(ABS(LOW-var2),3,1)/SMA(MAX(LOW-var2,0),3,1)*100;
var4:=EMA(IF(CLOSE*1.2,var3*10,var3/10),3);
var5:=LLV(LOW,30);
var6:=HHV(var4,30);
var7:=IF(LLV(LOW,58),1,0);
var8:=EMA(IF(LOW<=var5,(var4+var6*2)/2,0),3)/618*var7;
var9:=IF(var8>100,100,var8);
var5x:=llv(low,75);
var6x:=hhv(high,75);
var7x:=(var6x-var5x)/100;
var8x:=sma((close-var5x)/var7x,20,1);
vara:=3*var8x-2*sma(var8x,15,1);
var26:=(close-llv(low,27))/(hhv(high,27)-llv(low,27))*100;
var28:=sma(var26,3,1);
波段王:=sma(var28,3,1);
STICKLINE(var9>-150,0,var9,3,0),colorff00ff;
底部吸筹指标: (CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100,color00ff00;
STICKLINE(var8,0,var8,6,1),COLORred;
底部吸筹:if(var8,var8,1),COLORred;
乖离线: (CLOSE-MA(CLOSE,40))/MA(CLOSE,40)*100,COLORffff00;
STICKLINE(CROSS(16.5,底部吸筹指标),40,0,4,0),colorf00ff0;
STICKLINE(CROSS(40,底部吸筹指标),40,0,4,0),colorf00ff0;
STICKLINE(CROSS(20,底部吸筹指标),40,0,4,0),colorf00ff0;
STICKLINE(CROSS(底部吸筹指标,-5.4) and (8+底部吸筹指标)*10>=29 and (100-vara)>49 and (vara>sum(vara,20)/20 or 波段王>25),(8+底部吸筹指标)*(100-vara)/5,0,4,0),colorffffff;
先知: (CLOSE-LLV(LOW,40))/LLV(LOW,40)*100,COLORYELLOW;
主力线: (CLOSE-MA(LLV(LOW,40),40))/MA(LLV(LOW,40),40)*100,COLOR00ff00;
放量拉升: IF(CROSS(底部吸筹指标,-5.4),(8+底部吸筹指标)*10,0),colorffffff;
drawtext(CROSS(底部吸筹指标,-5.4) and (8+底部吸筹指标)*10>=29,15,'拉升'),color00eeaa;
drawtext(CROSS(16.5,底部吸筹指标),10,'注意'),colorred;
drawtext(CROSS(40,底部吸筹指标),15,'注意'),colorred;
drawtext(CROSS(20,底部吸筹指标),20,'注意'),colorred;

通达信黄金白银令指标公式

 

相关文章