在线检测未来函数

大智慧战略资金指标公式

来源:Internet,编辑:股旁网,2013-03-04

N:=5;
VAR1:=AMOUNT/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
买:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),AMOUNT/2))/10000;
卖:=IF(CLOSE>OPEN,VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,VAR1*(HIGH-LOW),AMOUNT/2))/10000;
bz:=SUM(买,1);
sz:=SUM(卖,1);
az:=bz+sz;
cz:=bz-sz;
总金额:az,linethick0;
买入:bz,linethick0;
卖出:sz,linethick0;
净入:cz,linethick0;
N总净入:SUM(净入,n),ColorFF00FF,linethick2;
打压1:=HHV(H,1);
打压2:=HHV(H,3);
打压3:=HHV(H,6);
打压4:=HHV(H,10);
打压5:=HHV(H,15);
打压6:=HHV(H,20);
拉升1:=LLV(L,1);
拉升2:=LLV(L,3);
拉升3:=LLV(L,6);
拉升4:=LLV(L,10);
拉升5:=LLV(L,15);
拉升6:=LLV(L,20);
拉升1买量:=IF(拉升1>REF(拉升1,1),VAR1*(HIGH-LOW),IF(REF(打压1,1)>打压1,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),AMOUNT/2))/10000;
打压1卖量:=IF(拉升1>REF(拉升1,1),VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(拉升1>REF(拉升1,1),VAR1*(HIGH-LOW),AMOUNT/2))/10000;
拉升1总:=SUM(拉升1买量,n);
打压1总:=SUM(打压1卖量,n);
打拉1:拉升1总-打压1总,Color00FFFF;
拉升2买量:=IF(拉升2>REF(拉升2,1),VAR1*(HIGH-LOW),IF(REF(打压2,1)>打压2,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),AMOUNT/2))/10000;
打压2卖量:=IF(拉升2>REF(拉升2,1),VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(拉升2>REF(拉升2,1),VAR1*(HIGH-LOW),AMOUNT/2))/10000;
拉升2总:=SUM(拉升2买量,n);
打压2总:=SUM(打压2卖量,n);
打拉2:拉升2总-打压2总,ColorFFFFFF;
拉升3买量:=IF(拉升3>REF(拉升3,1),VAR1*(HIGH-LOW),IF(REF(打压3,1)>打压3,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),AMOUNT/2))/10000;
打压3卖量:=IF(拉升3>REF(拉升3,1),VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(拉升3>REF(拉升3,1),VAR1*(HIGH-LOW),AMOUNT/2))/10000;
拉升3总:=SUM(拉升3买量,n);
打压3总:=SUM(打压3卖量,n);
打拉3:拉升3总-打压3总,ColorFF0082;
拉升4买量:=IF(拉升4>REF(拉升4,1),VAR1*(HIGH-LOW),IF(REF(打压4,1)>打压4,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),AMOUNT/2))/10000;
打压4卖量:=IF(拉升4>REF(拉升4,1),VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(拉升4>REF(拉升4,1),VAR1*(HIGH-LOW),AMOUNT/2))/10000;
拉升4总:=SUM(拉升4买量,n);
打压4总:=SUM(打压4卖量,n);
打拉4:拉升4总-打压4总,Color00FF00,linethick2,LAYER2;
拉升5买量:=IF(拉升5>REF(拉升5,1),VAR1*(HIGH-LOW),IF(REF(打压5,1)>打压5,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),AMOUNT/2))/10000;
打压5卖量:=IF(拉升5>REF(拉升5,1),VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(拉升5>REF(拉升5,1),VAR1*(HIGH-LOW),AMOUNT/2))/10000;
拉升5总:=SUM(拉升5买量,n);
打压5总:=SUM(打压5卖量,n);
打拉5:拉升5总-打压5总,ColorFF0000,linethick2;
拉升6买量:=IF(拉升6>REF(拉升6,1),VAR1*(HIGH-LOW),IF(REF(打压6,1)>打压6,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),AMOUNT/2))/10000;
打压6卖量:=IF(拉升6>REF(拉升6,1),VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(拉升6>REF(拉升6,1),VAR1*(HIGH-LOW),AMOUNT/2))/10000;
拉升6总:=SUM(拉升6买量,n);
打压6总:=SUM(打压6卖量,n);
打拉6:拉升6总-打压6总,Color0000FF,linethick2;
DRAWTEXTREL(12,10,'■'+NUMTOSTRN (n,0)+'天总净入:'+NUMTOSTRN (N总净入,2)),ColorFF00FF,LAYER1;
DRAWTEXTREL(12,150,'■一拉升打压资金:'+NUMTOSTRN (打拉1,2)),Color00FFFF,LAYER1;
DRAWTEXTREL(12,290,'■二拉升打压资金:'+NUMTOSTRN (打拉2,2)),ColorFFFFFF,LAYER1;
DRAWTEXTREL(12,430,'■三拉升打压资金:'+NUMTOSTRN (打拉3,2)),ColorFF0082,LAYER1;
DRAWTEXTREL(12,570,'■短■拉升打压资金:'+NUMTOSTRN (打拉4,2)),Color00FF00,LAYER1;
DRAWTEXTREL(12,710,'■中■拉升打压资金:'+NUMTOSTRN (打拉5,2)),ColorFF0000,LAYER1;
DRAWTEXTREL(12,850,'■长■拉升打压资金:'+NUMTOSTRN (打拉6,2)),Color0000FF,LAYER1;
0,DOTLINE,LAYER1;

大智慧战略资金指标公式

 

相关文章