在线检测未来函数

飞狐突破封锁线指标公式

来源:Internet,编辑:股旁网,2013-03-05

DRAWGBK(C>0,COLORRGB(176,250,176),168,1);
Aa1:=SUMBARS(VOL,CAPITAL);
换手成本:=IF(CAPITAL>0,SUM(AMOUNT,Aa1)/SUM(VOL,Aa1)/100,EMA(CLOSE,120)),pointdot,COLORGRAY,LINETHICK2;
换手成本20:HHV((llV(换手成本,1)+HHV(换手成本,2))/2,20),COLORyellow,LINETHICK2;
换手成本120:HHV((llV(换手成本,1)+HHV(换手成本,2))/2,120),COLORred,LINETHICK2;
PARTLINE(换手成本120=换手成本20,换手成本120),COLORRED, LINETHICK4;
PARTLINE(换手成本120>换手成本20, 换手成本120),COLORGREEN,LINETHICK4;
PARTLINE(换手成本120<换手成本20, 换手成本120),COLORGREEN,LINETHICK4;
{强牛主图}
var100:=dma(amount/v/100,v/capital);
筹码线:var100*1.1,colorwhite,linethick2;{1.1}
牛熊线:COST(75),colorblue,linethick2;
持仓线:MA(CLOSE,20) ,coloryellow,linethick0;
STICKLINE(c>0,o,c,8,0), colorblue;
STICKLINE(c>0,h,l,0.8,0) ,colorblue;
a:=close>筹码线 and CLOSE>牛熊线 and CLOSE>持仓线;
b:=close>筹码线 and CLOSE<牛熊线 and CLOSE>持仓线;
STICKLINE(a>0,o,c,8,0) ,coloryellow;
STICKLINE(a>0,h,l,0.8,0), coloryellow;
STICKLINE(b>0,h,l,0.8,0), COLORMAGENTA;
STICKLINE(b>0,o,c,8,0), COLORMAGENTA;a1:=(c-ma(c,5))/ma(c,34)*100;
a2:=(c-ma(c,10))/ma(c,89)*100;
Ax:=REF(LLV(a2,34),BARSLAST(CROSS(a2,ema(a2,13))));
Ay:=REF(HHV(a2,34),BARSLAST(CROSS(ema(a2,13),a2)));
Az:=(1+SQRT(5))/2-1;
侦察英雄:a1;
大部队:a2;
AAx:=REF(LLV(a1,34),BARSLAST(CROSS(a1,ema(a1,13))));
AAy:=REF(HHV(a1,34),BARSLAST(CROSS(ema(a1,13),a1)));
AAz:=(1+SQRT(5))/2-1;
封锁线:(AAy-AAx)*AAz+AAx,COLORyellow,LINETHICK2;
电网:(Ay-Ax)*Az+Ax,LINETHICK2, CrossDOT;
分界线:ay;
底部:(a1<0 and a2<0 and 封锁线<0 and 电网<0)*-10;
大本营:(l=llv(l,0))*-40;
指挥所:(a1<-30)*-30,colorff00ff;

飞狐突破封锁线指标公式

 

相关文章