在线检测未来函数

通达信三平底买点主图+选股指标公式

来源:Internet,编辑:股旁网,2013-03-06

KOH:=LOW>REF(HIGH,1);
KOL:=HIGH<REF(LOW,1);
HIF:=LOW>REF(HIGH,BARSLAST(KOH)+1);
NHIF:=LOW<=REF(HIGH,BARSLAST(KOH)+1);
LIF:=HIGH<REF(LOW,BARSLAST(KOL)+1);
NLIF:=HIGH>=REF(LOW,BARSLAST(KOL)+1);
DRAWICON(HIF AND BARSLAST(KOH)<BARSLAST(NHIF) AND BARSLAST(HIF)<BARSLAST(NHIF),REF(HIGH,BARSLAST(KOH)+1),1);
DRAWICON(LIF AND BARSLAST(KOL)<BARSLAST(NLIF) AND BARSLAST(LIF)<BARSLAST(NLIF),REF(LOW,BARSLAST(KOL)+1),2);
标示缺口线:IF(HIF AND BARSLAST(KOH)<BARSLAST(NHIF) AND BARSLAST(HIF)<BARSLAST(NHIF),REF(HIGH,BARSLAST(KOH)+1),DRAWNULL),COLORYELLOW,LINETHICK3;
DA1:=IF(168>TOTALBARSCOUNT,TOTALBARSCOUNT,168);
DA:=IF(CURRBARSCOUNT>DA1,0,DA1);
HI:=REFDATE(HHV(H,DA),DATE);
LO:=REFDATE(LLV(L,DA),DATE);
C1:=IF(CURRBARSCOUNT<=DA,C,DRAWNULL);
GZ:=EXP(LN(HI/LO)/10);
LH1:=SUM(IF(C1>=(HI/GZ),V,0),DA);
LH2:=SUM(IF(C1>=(HI/POW(GZ,2)) AND C1<(HI/GZ),V,0),DA);
LH3:=SUM(IF(C1>=(HI/POW(GZ,3)) AND C1<(HI/POW(GZ,2)),V,0),DA);
LH4:=SUM(IF(C1>=(HI/POW(GZ,4)) AND C1<(HI/POW(GZ,3)),V,0),DA);
LH5:=SUM(IF(C1>=(HI/POW(GZ,5)) AND C1<(HI/POW(GZ,4)),V,0),DA);
LH6:=SUM(IF(C1>=(HI/POW(GZ,6)) AND C1<(HI/POW(GZ,5)),V,0),DA);
LH7:=SUM(IF(C1>=(HI/POW(GZ,7)) AND C1<(HI/POW(GZ,6)),V,0),DA);
LH8:=SUM(IF(C1>=(HI/POW(GZ,8)) AND C1<(HI/POW(GZ,7)),V,0),DA);
LH9:=SUM(IF(C1>=(LO*GZ) AND C1<LO*POW(GZ,2),V,0),DA);
LH10:=SUM(IF(C1>=LO AND C1<LO*GZ,V,0),DA);
L1:=REFDATE(HHV(LH1,DA),DATE),LINETHICK0;
L2:=REFDATE(HHV(LH2,DA),DATE),LINETHICK0;
L3:=REFDATE(HHV(LH3,DA),DATE),LINETHICK0;
L4:=REFDATE(HHV(LH4,DA),DATE);
L5:=REFDATE(HHV(LH5,DA),DATE);
L6:=REFDATE(HHV(LH6,DA),DATE);
L7:=REFDATE(HHV(LH7,DA),DATE);
L8:=REFDATE(HHV(LH8,DA),DATE);
L9:=REFDATE(HHV(LH9,DA),DATE);
L10:=REFDATE(HHV(LH10,DA),DATE);
SSS:=(L1+L2+L3+L4+L5+L6+L7+L8+L9+L10);
STICKLINE(CEILING(DA*L1/SSS)*3>=CURRBARSCOUNT,HI*99/100,HI/GZ,9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L2/SSS)*3>=CURRBARSCOUNT,HI/POW(GZ,1)*99/100,HI/POW(GZ,2),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L3/SSS)*3>=CURRBARSCOUNT,HI/POW(GZ,2)*99/100,HI/POW(GZ,3),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L4/SSS)*3>=CURRBARSCOUNT,HI/POW(GZ,3)*99/100,HI/POW(GZ,4),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L5/SSS)*3>=CURRBARSCOUNT,HI/POW(GZ,4)*99/100,HI/POW(GZ,5),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L6/SSS)*3>=CURRBARSCOUNT,HI/POW(GZ,5)*99/100,HI/POW(GZ,6),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L7/SSS)*3>=CURRBARSCOUNT,HI/POW(GZ,6)*99/100,HI/POW(GZ,7),9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L8/SSS)*3>=CURRBARSCOUNT,LO*POW(GZ,2),LO*POW(GZ,3)*99/100,9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L9/SSS)*3>=CURRBARSCOUNT,LO*POW(GZ,1),LO*POW(GZ,2)*99/100,9,0)COLOR3C3C3A,LINETHICK3;
STICKLINE(CEILING(DA*L10/SSS)*3>=CURRBARSCOUNT,LO,LO*POW(GZ,1)*99/100,9,0)COLOR3C3C3A,LINETHICK3;
DRAWKLINE(H,O,L,C);
日均价:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
JF1:=SMA(SMA(EMA(日均价,5)*2-MA(日均价,5),3,1),3,1),COLOR999900;
补偿:=FLOOR(((JF1-MA(JF1,5))/MA(JF1,5)*100));
操作线:=SMA(SMA((EMA(日均价,(5+ABS(补偿)))),2,1),2,1),COLORWHITE LINETHICK4;
上轨:=操作线+2*STD(日均价,10),COLORA08888;
下轨:=操作线-2*STD(日均价,10);
DRAWBAND(上轨,RGB(100,300,150),操作线,RGB(100,300,130));
DRAWBAND(下轨,RGB(50,50,50),操作线,RGB(100,100,300));
B1:=REF(C,1);B2:=REF(C,2);
SS:=IF(C>REF(C,1) AND REF(C,1)>=REF(C,2),1,IF(C<REF(C,1) AND REF(C,1)<=REF(C,2),-1,IF(C>REF(C,2) AND REF(C,2)>REF(C,1),2,IF(C<REF(C,2) AND REF(C,2)<REF(C,1),-2,0))));
SM:=IF(REF(SS,1)!=0,REF(SS,1),IF(REF(SS,2)!=0,REF(SS,2),IF(REF(SS,3)!=0,REF(SS,3),IF(REF(SS,5)!=0,REF(SS,5),IF(REF(SS,6)!=0,REF(SS,6),IF(REF(SS,7)!=0,REF(SS,7),0))))));
{STICKLINE(SS=1 OR SM>=1 AND SS=0,B1,C,2.8,0),COLORBLUE;
STICKLINE(SS=-1 OR SM<=-1 AND SS=0,B1,C,2.8,0),COLORYELLOW;
STICKLINE(SS=2,B2,C,2.8,0),COLORBLUE;
STICKLINE(SS=-2,B2,C,2.8,0),COLORYELLOW;}
STICKLINE((SS=-1 OR SS=-2) AND SM>0,B2,B1,2.8,0),COLORGREEN;
STICKLINE((SS=1 OR SS=2) AND SM<0,B2,B1,2.8,0),COLORYELLOW;
AA:=CLOSE>REF(CLOSE,1) AND REF(CLOSE,1)>REF(CLOSE,2) AND REF(CLOSE,1)<REF(CLOSE,3) AND IF(REF(CLOSE,3)<REF(CLOSE,4),1,IF(REF(CLOSE,4)<REF(CLOSE,5),REF(CLOSE,1)<REF(CLOSE,4) OR (REF(CLOSE,2)<REF(CLOSE,4) AND REF(CLOSE,3)>=REF(CLOSE,5)),IF(REF(CLOSE,5)<REF(CLOSE,6),1,REF(CLOSE,6)<REF(CLOSE,7))));
BB:=CLOSE<REF(CLOSE,1) AND REF(CLOSE,1)<REF(CLOSE,2) AND REF(CLOSE,1)>REF(CLOSE,3) AND IF(REF(CLOSE,3)>REF(CLOSE,4),1,IF(REF(CLOSE,4)>REF(CLOSE,5),REF(CLOSE,1)>REF(CLOSE,4) OR (REF(CLOSE,2)>REF(CLOSE,4) AND REF(CLOSE,3)<=REF(CLOSE,5)),IF(REF(CLOSE,5)>REF(CLOSE,6),1,REF(CLOSE,6)>REF(CLOSE,7))));
DRAWTEXT(AA AND CLOSE>REF(OPEN,2),LOW*0.99,'三平底'),COLORWHITE;
DRAWTEXT(BB AND CLOSE<REF(CLOSE,2),HIGH*1.01,'三平顶'),COLORCYAN;
MA60:MA(CLOSE,60) COLORGREEN;
D_D:=MA(IF(L<=LLV(L,13),1,0),3); C_D1:=(3*C+2*O+L+H)/7;
WMA5:(5*C_D1+4*REF(C_D1 ,1 )+3*REF(C_D1 ,2 )+2*REF(C_D1 ,3 )+REF(C_D1 ,4 ))/15 COLORYELLOW;
C_D2:REVERSE(C_D1)+2*WMA5 COLORGREEN;
DRAWBAND(WMA5,RGB(205,92,92),C_D2,RGB(28,134,238));
DRAWICON(CROSS(C_D2,WMA5*0.997),H*1.005,2);
DRAWICON(CROSS(WMA5,C_D2*0.997),L*0.995,1);
F:=C/O;
STICKLINE(F>=1,C,O,2.8,1),COLORRED;
STICKLINE(F>=1,C,H,0.00001,0),COLORRED;
STICKLINE(F>=1,L,O,0.00001,0),COLORRED;
STICKLINE(F<1,C,O,2.8,0),COLORCYAN;
STICKLINE(F<1,O,H,0.00001,0),COLORCYAN;
STICKLINE(F<1,L,C,0.00001,0),COLORCYAN;

{
选股公式:

C_D1:=(3*C+2*O+L+H)/7;
WMA5:=(5*C_D1+4*REF(C_D1 ,1 )+3*REF(C_D1 ,2 )+2*REF(C_D1 ,3 )+REF(C_D1 ,4 ))/15;
C_D2:=REVERSE(C_D1)+2*WMA5;
红箭头:CROSS(WMA5,C_D2*0.997);
}

通达信三平底买点主图+选股指标公式

 

相关文章