在线检测未来函数

通达信KJ顶底指标公式

来源:Internet,编辑:股旁网,2013-03-09

此KJ顶底指标对判断短线顶底很有帮助,无论在牛市和熊市都有很好的表现,并加入了自己通过实践验证的几种买入指标提示。

10,COLOR00FFFF,LINETHICK3,POINTDOT;
40,COLORCBCBC0,LINETHICK3,POINTDOT;
50,COLORRED,LINETHICK2;
60,COLOR00FFFF,LINETHICK3,POINTDOT;
80, COLORRED,LINETHICK3,POINTDOT;
{大底中顶大顶}
X:=MA(AMOUNT,5)/MA(V,5)/100;
VAR3:=(X-MA(AMOUNT,125)/MA(V,125)/100)/X;
VAR4:=MA((LLV(L,45)-C)/(HHV(H,45)-LLV(L,45))*100,3);
VAR5:=C/MA(C,60)-1;
大底:IF(CROSS(-5,VAR4) AND VAR3<-0.4,20,0),COLORFF7F00,LINETHICK2;
DRAWTEXT(大底>0,20,'大底'),COLORFF7F00,LINETHICK1;
中顶:IF(CROSS(VAR4,-95) AND VAR5<0.35 AND VAR5>=0.2,80,100),COLORMAGENTA,LINETHICK2;
大顶:IF(CROSS(VAR4,-95) AND VAR5>=0.35,80,100),COLORFF7F00,LINETHICK2;
{共振}
RV:=(CLOSE-LLV(LOW,33))/(HHV(HIGH,33)-LLV(LOW,33))*100;
RG:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
VAR44:=SMA(RV,3,1);
VAR55:=SMA(VAR44,3,1);
KK:=EMA(SMA(RG,3,1),2);
JJ:=SMA(KK,3,1);
共振点:=(CROSS(VAR44,VAR55) AND CROSS(KK,JJ));
STICKLINE(共振点>0,0,50,1.2,0),COLOR008888;
STICKLINE(共振点>0,0,50,0.8,0),COLOR00AAAA;
STICKLINE(共振点>0,0,50,0.4,0),COLOR00CCCC;
STICKLINE(共振点>0,0,50,0,0),COLOR00FFFF;
DRAWTEXT(共振点>0,48,'升'),COLOR00FFFF;
{MACD背离买}
DIF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIF,9),COLORFFFF00;
A3:=BARSLAST(REF(CROSS(DIF,DEA),1));
底背离:=REF(CLOSE,A3+1)>CLOSE AND DIF> REF(DIF,A3+1) AND CROSS(DIF,DEA);
STICKLINE(底背离,0,35,1.2,0),COLOR880088;
STICKLINE(底背离,0,35,0.8,0),COLORAA00AA;
STICKLINE(底背离,0,35,0.4,0),COLORCC00CC;
STICKLINE(底背离,0,35,0,0),COLORFF00FF;
DRAWTEXT(底背离,33,'底背离'),COLORFF00FF,LINETHICK1;
{买}
A5:=C-REF(C,1);
A6:=100*EMA(EMA(A5,6),6)/EMA(EMA(ABS(A5),6),6);
RMA1:=EMA(CLOSE,7);
NMA1:=EMA(CLOSE,19);
UP1:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(NMA1,RMA1))+1),LLV(L,BARSLAST(CROSS(NMA1,RMA1))+1),H
=HHV(H,BARSLAST(CROSS(RMA1,NMA1))+1),HHV(H,BARSLAST(CROSS(RMA1,NMA1))+1),0);
DOWN1:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(RMA1,NMA1))+1),HHV(H,BARSLAST(CROSS(RMA1,NMA1))+1),L
=LLV(L,BARSLAST(CROSS(NMA1,RMA1))+1),LLV(L,BARSLAST(CROSS(NMA1,RMA1))+1),0);
买入:=(LLV(A6,2)=LLV(A6,7) AND COUNT(A6<0,2) AND CROSS(A6,MA(A6,2))) AND
REF(DOWN1,1)<REF(DOWN1,2) AND UP1>REF(DOWN1,1);
IF(买入,0,35),COLORCYAN,LINETHICK2;
0,COLORMAGENTA,LINETHICK2;
{KDJ}
RSV:=(CLOSE-LLV(LOW,33))/(HHV(HIGH,33)-LLV(LOW,33))*100;
K:SMA(RSV,3,1),COLORWHITE,LINETHICK2;
D:=SMA(K,3,1),COLOR00FFFF,LINETHICK2;
{J线没未来}
J:3*K-2*D,COLOR00FFFF,LINETHICK2;
IF(J<REF(J,1),J,DRAWNULL),COLORGREEN,LINETHICK2;
IF(J>REF(J,1),J,DRAWNULL),COLORRED,LINETHICK2;
{KDJ红绿相交}
DRAWICON(CROSS(J,D) AND CROSS(J,K),0,25);
DRAWICON(CROSS(D,J) AND CROSS(K,J),100,27);

通达信KJ顶底指标公式

 

相关文章