在线检测未来函数

飞狐飞龙顶底线主图指标公式

来源:Internet,编辑:股旁网,2013-03-07

DRAWGBK(CLOSE>0, COLORRGB(100,0,120), COLORRGB(50,0,60),1);{收平变品红}
DRAWGBK(C>O,COLORRGB(110,11,0),COLORRGB(60,11,0),1); {收阳变红}
DRAWGBK(C<O,COLORRGB(80,130,130),COLORRGB(30,30,60),1);{收阴变绿}
VERTLINE(HHV(HIGH,5)>=REF(HHV(HIGH,5),1)),POINTDOT,color808080;
Nn1:=SYSPARAM(3);
Nn:=((Nn1 - SYSPARAM(2)) + 1);
HH:=HHV(HIGH,Nn);
LL:=LLV(LOW,Nn);
最高:=HH[Nn1];
最低:=LL[Nn1];
{K线}
STICKLINE((CLOSE > OPEN),OPEN,LOW,1,0),color726CA;
STICKLINE((CLOSE > OPEN),OPEN,LOW,0.5,0),color62D3;
STICKLINE((CLOSE > OPEN),CLOSE,HIGH,1,0),color726CA;
STICKLINE((CLOSE > OPEN),CLOSE,HIGH,0.5,0),color62D3;
STICKLINE((OPEN > CLOSE),OPEN,HIGH,1,0),color6300;
STICKLINE((OPEN > CLOSE),CLOSE,LOW,1,0),colorDE9100;
STICKLINE((OPEN > CLOSE),OPEN,HIGH,1,0),colorDE9100;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,9,0),colorFF5B00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,8,0),colorFF6C00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,7,5),colorFF6500;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,7,3),color8B00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,7,0),colorFF7B00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,6.8,0),colorFF8500;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,6.5,0),colorFF8C00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,6.3,0),colorFF9700;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,6,0),colorFF9C00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,5.7,0),colorFF9C00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,5.5,0),colorFFB400;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,5.3,0),colorFFA900;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,5,0),colorFFBE00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,4.5,0),colorFFC500;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,3.5,0),colorFFCC00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,3,0),colorFFD300;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,2.5,0),colorFFDD00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,1.5,0),colorFFFF00;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,8,0),color70084;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,7.8,0),colorA3;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,7.5,0),colorA9;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,7.3,0),colorB2;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,7,0),colorB7;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,6.8,0),colorB9;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,6.5,0),colorBC;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,6.3,0),colorC5;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,6,0),colorCD;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,5.7,0),colorD6;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,5.5,0),colorDB;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,5.3,0),colorE2;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,5,0),colorE9;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,4.5,0),color3EE9;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,3.5,0),color43E9;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,3,0),color754E9;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,2.5,0),color762E9;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1.5,0),color76EF3;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1,0),color77BF3;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,0.7,0),color78CFD;

飞狐飞龙顶底线主图指标公式

 

相关文章