在线检测未来函数

通达信侠女十三妹主图指标公式

来源:Internet,编辑:股旁网,2013-03-07

M1:=5;M2:=10;M3:=20;M4:=30;
DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.98,9) ;
DRAWICON((ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.01,4);
VAR3:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR5:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;
VAR6:=(VAR3+VAR4+VAR5)/3;
VAR7:=EMA(VAR6,5);
ZB:=EMA(EMA(VAR3,5),5)*3, COLORSTICK;
VAR8:=IF(VAR6<=-20,10,0);
VAR9:=HHV(VAR8,10);
VARA:=IF(VAR9 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0);
K:=EMA(VAR7,5)*2, , COLORFF00FF;
D:=EMA(K,5), , COLORWHITE;
J:=K*3-D*2, ,COLORYELLOW;
VARB:=BETWEEN(CLOSE,MA(CLOSE,3),MA(CLOSE,5)) AND J>10;
HS:=VOL/CAPITAL*100, , COLORGREEN;
DRAWTEXT(VAR8=10 AND FILTER(VAR8=10,5),LOW*1.00,'准备') COLORMAGENTA;
DRAWTEXT(VARA=20,LOW*1.00,'一定要买') COLORRED;
DRAWICON(VARA=20,LOW*1.00,1);
VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR11:=VARF<REF(VAR10,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,LOW*0.95,'庄家异动'),LINETHICK1,COLORFF00FF;
VAR12:=(HIGH+LOW+CLOSE)/3;
VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));
VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));
VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0);
VAR16:=IF(VAR13<=-150 AND VAR13>-200 AND VAR14<=-150 AND VAR14>-200,-10,VAR15);
VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR18:=100-ABS(VAR17);
VAR19:=IF(VAR18<90,VAR18,100);
VAR1A:=IF(VARE>0,VARE,0);
VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;
VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;
DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,LOW*1.00,'大动作') COLORYELLOW;
VAR20:=PEAKBARS(3,15,1)<10;
VAR21:=IF(VAR20=1,2,0);
VAR22:=IF(VAR21=2,2,0);
VAR23:=IF(VAR22>REF(VAR22,1),35,0)LINETHICK2;
DRAWTEXT(VAR23=35,HIGH*1.00,'一定要逃')COLORGREEN;
DRAWICON(VAR23=35,HIGH*1.00,2);
三妹:MA(CLOSE,3);
四姨:EXPMA(CLOSE,40);
十三妹:MA(C,13),COLOR00FFFF,LINETHICK2;
涨:IF(MA(CLOSE,13)>REF(MA(CLOSE,13),1),MA(CLOSE,13),DRAWNULL),COLORRED,LINETHICK2;
平:IF(MA(CLOSE,13)=REF(MA(CLOSE,13),1),MA(CLOSE,13),DRAWNULL),COLOR00FFFF,LINETHICK3;
跌:IF(MA(CLOSE,13)<REF(MA(CLOSE,13),1),MA(CLOSE,13),DRAWNULL),COLORGREEN,LINETHICK2;
HH:=LLV(L,7)*1.13-0.03;
STICKLINE(H>=HH,H,H*1.005,1,0),COLOR00FFFF;
TT2:=DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9);
TT1:=REF(EMA(TT2,3),1);
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K8:=SMA(RSV,3,1);
D8:=SMA(K8,3,1);
J8:=3*K8-2*D8;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
AA1:=AMOUNT/VOL;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=VOL<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
F:=100*(C-REF(C,1))/REF(C,1);
P1:=IF(C<REF(O,1) AND F<0,1,0);
P2:=IF(C<REF(O,2) AND F<0,1,0);
TT3:=P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1 ;
TT4:=P1=1 AND REF(P1,1)=0 AND P2=1 AND REF(P2,1)=0 ;
STICKLINE(TT3,OPEN,CLOSE,3,0),COLORFF00FF;
日跌:L*0.989,NODRAW,COLORFF00FF;
今小昨:=IF(C<REF(O,1) AND F<0,1,0);
P11:=今小昨;
今小前:=IF(C<REF(O,2) AND F<0,1,0);
P22:=今小前;
DL:=P11=1 AND REF(P11,1)=0 AND P22=1 AND REF(P22,1)=0;
STICKLINE(DL,O,C,0.1,0),COLORAAAAAA;
BB :=MAX(C,O)-(REF(MAX(C,O),2)-MAX(C,O))/2;
买点:=(H-(REF(H,2)-H)/2);
AA:MAX(BB,买点),NODRAW,COLORFF00FF;
STICKLINE(C<O AND F<-3 AND F>-5,C+(O-C)/3,C+(O-C)/3,2.5,0),COLORRED;
STICKLINE(C<O AND F<-3 AND F>-5,C+2*(O-C)/3,C+2*(O-C)/3,2.5,0),COLORRED;
STICKLINE(C<O AND F<=-5 AND F>-7,C+(O-C)/2,C+(O-C)/2,2.5,0),COLORYELLOW;
STICKLINE(C<O AND F<=-7 AND F>-10,C+2*(O-C)/3,C+(O-C)/3,2.5,1),COLORYELLOW;
STICKLINE(C<O AND F<=-9.9,O,C,2.5,0),COLOR00FF00;
STICKLINE(C>O AND F>2.9 AND F<5,O+(C-O)/3,O+(C-O)/3,2.5,0),COLORYELLOW;
STICKLINE(C>O AND F>2.9 AND F<5,O+2*(C-O)/3,O+2*(C-O)/3,2.5,0),COLORYELLOW;
STICKLINE(C>O AND F>=5 AND F<7,O+(C-O)/2,O+(C-O)/2,2.5,0),COLORYELLOW;
STICKLINE(C>O AND F>=7 ,O+2*(C-O)/3,O+(C-O)/3,2.5,1),COLORYELLOW;

通达信侠女十三妹主图指标公式

 

相关文章