在线检测未来函数

通达信泣血抄底指标公式

来源:Internet,编辑:股旁网,2013-03-07

AA4:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
AA5:=SMA(AA4,13,8);
走势:CEILING(SMA(AA5,13,8)),COLORRED,LINETHICK1;
N1:=7;
VAR1:=REF(C,1);
VAR2:=SMA(MAX(C-VAR1,0),N1,1)/SMA(ABS(C-VAR1),N1,1)*1000;
VAR3:=DRAWLINE(VAR2>=HHV(VAR2,N1),VAR2,VAR2<=LLV(VAR2,N1),VAR2,1);
VAR4:=VAR2=VAR3;
VAR5:=VAR2<REF(VAR2,1);
PD1:=VAR4 AND VAR5;
Q_3:=CROSS(EMA(C,19),EMA(C,7));
Q_4:=CROSS(EMA(C,7),EMA(C,19));
Z1:=L=LLV(L,BARSLAST(Q_3)+1);
Z2:=LLV(L,BARSLAST(Q_3)+1);
Z3:=H=HHV(H,BARSLAST(Q_4)+1);
Z4:=HHV(H,BARSLAST(Q_4)+1);
Q_A:=DRAWLINE(Z1,Z2,Z3,Z4,0);
Y1:=H=HHV(H,BARSLAST(Q_4)+1);
Y2:=HHV(H,BARSLAST(Q_4)+1);
Y3:=L=LLV(L,BARSLAST(Q_3)+1);
Y4:=LLV(L,BARSLAST(Q_3)+1);
Q_B:=DRAWLINE(Y1,Y2,Y3,Y4,0);
TJ:=IF(Q_B<REF(Q_B,1) AND Q_B=Q_A,1,0);
JDMD:=REF(TJ,1)=0 AND TJ>=1;
PD11:=PD1 AND JDMD;
PD7:=IF(PD1,SUM(JDMD,3),0);
PD8:=IF(PD7>0,0,1);
PD9:=PD1 AND PD8;
PD3:=IF(JDMD,SUM(PD1,3),0);
PD4:=IF(PD3>0,0,1);
PD5:=JDMD AND PD4;
PD6:=FILTER(IF(PD11,1,PD9 OR PD5),2);
底现抄底:PD6,NODRAW,COLOR7777FF;
STICKLINE(PD6,走势,走势+45,3.15,0),COLOR1111FF;
STICKLINE(PD6,走势,走势+45,2.45,0),COLOR3333FF;
STICKLINE(PD6,走势,走势+45,1.75,0),COLOR5555FF;
STICKLINE(PD6,走势,走势+45,1.05,0),COLOR7777FF;
STICKLINE(PD6,走势,走势+45,0.35,0),COLOR9999FF;
PD2:=IF(REF(PD6,1)=1 AND C>=REF(L,1),1,0);
PD10:=FILTER(PD2,2);
底成买进:PD2,NODRAW,COLOR00CC00;
STICKLINE(PD2,走势,走势+45,3.2,0),COLOR004400;
STICKLINE(PD2,走势,走势+45,2.7,0),COLOR006600;
STICKLINE(PD2,走势,走势+45,2.1,0),COLOR008800;
STICKLINE(PD2,走势,走势+45,1.5,0),COLOR00AA00;
STICKLINE(PD2,走势,走势+45,0.9,0),COLOR00CC00;
STICKLINE(PD2,走势,走势+45,0.3,0),COLOR00EE00;
大底:IF(JDMD=1,1,DRAWNULL),COLORYELLOW;
小底:IF(JDMD=0 AND (PD9 OR PD5),1,DRAWNULL),COLORBLUE;
STICKLINE(JDMD,走势,走势+45,0,0),COLORYELLOW;
STICKLINE(JDMD=0 AND (PD9 OR PD5),走势,走势+45,0,0),COLORBLUE;
上升趋势更有效:DRAWNULL,COLORYELLOW;
下跌趋势要小心:DRAWNULL,COLORWHITE;

通达信泣血抄底指标公式

 

相关文章