在线检测未来函数

通达信必羊上升主图指标公式

来源:Internet,编辑:股旁网,2013-03-12

STICKLINE(CLOSE>OPEN or CLOSE=OPEN and CLOSE>REF(CLOSE,1),LOW,HIGH,0.1,0),colorred;
STICKLINE(CLOSE>OPEN or CLOSE=OPEN and CLOSE>REF(CLOSE,1),OPEN,CLOSE,7,0),colorred;
STICKLINE(CLOSE<OPEN or CLOSE=OPEN and CLOSE<=REF(CLOSE,1),LOW,HIGH,0.1,0),colorcyan;
STICKLINE(CLOSE<OPEN or CLOSE=OPEN and CLOSE<=REF(CLOSE,1),OPEN,CLOSE,7,0),colorcyan;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,0,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,8,0 ),COLOR008800;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLOR009900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLOR00AA00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLOR00BB00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLOR00CC00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLOR00DD00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLOR00EE00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLOR00FF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0,0) ,COLORFFBBFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0) ,COLORFF00FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLORFF22FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLORFF44FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLORFF66FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLORFF88FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLORFF99FF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLORFFAAFF;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLORFFBBFF;
a1:(EMA(AMOUNT/VOL/100,3)+EMA(AMOUNT/VOL/100,6)+EMA( AMOUNT/VOL/100,9))/3,ColorFF80FF,linethick1;
a2:(EMA(AMOUNT/VOL/100,5)+EMA(AMOUNT/VOL/100,10)+EMA( AMOUNT/VOL/100,20))/3,ColorFF80FF;
a3:(EMA(AMOUNT/VOL/100,7)+EMA(AMOUNT/VOL/100,14)+EMA( AMOUNT/VOL/100,28))/3,ColorFF80FF;
a4:(EMA(AMOUNT/VOL/100,9)+EMA(AMOUNT/VOL/100,18)+EMA( AMOUNT/VOL/100,36))/3,ColorFF80FF;
a5:(EMA(AMOUNT/VOL/100,11)+EMA(AMOUNT/VOL/100,22)+EMA( AMOUNT/VOL/100,44))/3,ColorFF80FF;
a6:(EMA(AMOUNT/VOL/100,13)+EMA(AMOUNT/VOL/100,26)+EMA( AMOUNT/VOL/100,52))/3,ColorFF80FF;
A:(EMA(AMOUNT/VOL/100,21)+EMA(AMOUNT/VOL/100,34)+EMA(AMOUNT/VOL/100,55))/3,LINETHICK2;
a7:a-(a1-a),coloryellow,linethick1;
a8:a-(a2-a),coloryellow;
a9:a-(a3-a),coloryellow;
a10:a-(a4-a),coloryellow;
a11:a-(a5-a),coloryellow;
a12:a-(a6-a),coloryellow;
stickline(c>=ref(c,1),o,c,5,0),colorred;
stickline(c<ref(c,1),o,c,5,0),colorcyan;
stickline(c>=ref(c,1),h,l,1,0),colorred;
stickline(c<ref(c,1),h,l,1,0),colorcyan;M21:MA(C,21),COLORWHITE;
M55:MA(C,55),COLORYELLOW;
MA72:MA(CLOSE,72),ColorFFFfff,linethick1;
MA98:MA(CLOSE,98),Color00Ffff,linethicK1;
MA250:MA(CLOSE,250),Color00ff00,linethick1;
x1:=(C+L+H)/3;
x2:=EMA(x1,6);
x3:=EMA(x2,5);
stickline(x2>x3 and c>ema(x1,13),low,high,0.1,1),colorred;
stickline(x2>x3 and c>ema(x1,13),close,open,5,1),colorred;
stickline(x2<x3 and c<ema(x1,13),low,high,0.1,1),colorffff54;
stickline(x2<x3 and c<ema(x1,13),close,open,5,0),colorffff54;
gr1:=BARSLAST(BETWEEN("bias.bias2"(6,13,24),0,5));
gr2:=ema(x1,13)>ema(x1,21) and ema(x1,21)>ema(x1,34)
and ema(x1,13)>ref(ema(x1,13),1);
gr3:=count("bias.bias2"(6,13,24)>10 and h=hhv(h,gr1),gr1);
gr4:=h=hhv(h,gr1);
gr5:="macd.macd"(12,26,9)<ref("macd.macd"(12,26,9),1);
gr6:=gr2 and gr3 and gr4;
gr7:=gr2 and gr3 and gr4 and gr5;
gr8:=gr6 and gr7;
LC := REF(CLOSE,1);
RSI6:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
BIAS5:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
换手:=100*v/capital;
bb13:=atan(ema(x1,13)-ref(ema(x1,13),1))*3.1416*10;
ema8:=ema(c,8);
DRAWTEXT(filter(bb13>1 and ema(x1,13)>ref(ema(x1,8),1),10),
ema8,'∠45必羊上升'),colorwhite;

通达信必羊上升主图指标公式

 

相关文章