在线检测未来函数

通达信天风地火主图指标公式

来源:Internet,编辑:股旁网,2013-03-12

N:=3;M:=30;
Var0:=(3*CLOSE+LOW+OPEN+HIGH)/6;
多头线: (20*Var0+19*REF(Var0,1)+18*REF(Var0,2)+17*REF(Var0,3)+16*REF(Var0,4)+15*REF(Var0,5)+14*REF(Var0,6)+13*REF(Var0,7)+12*REF(Var0,8)+11*REF(Var0,9)+10*REF(Var0,10)+9*REF(Var0,11)+8*REF(Var0,12)+7*REF(Var0,13)+6*REF(Var0,14)+5*REF(Var0,15)+4*REF(Var0,16)+3*REF(Var0,17)+2*REF(Var0,18)+REF(Var0,20))/210, CIRCLEDOT,COLORRED,linethick2;
空头线: MA(多头线,10), CIRCLEDOT,COLORGREEN,linethick2;
STICKLINE(多头线>空头线,多头线,空头线,10,10),,COLORRED;
STICKLINE(多头线<空头线,多头线,空头线,10,10), ,COLORGREEN;
STICKLINE(C>O,O,C,7,0),COLORRED;
STICKLINE(C>O,O,C,4,0),COLORB0B0FF;
STICKLINE(C>O,O,C,2,0),COLORYELLOW;
STICKLINE(C>O,L,H,0.1,0),COLORYELLOW;
STICKLINE(C< O,O,C,7,0),COLORFF2020;
STICKLINE(C< O,O,C,4,0),COLORFF6600;
STICKLINE(C< O,O,C,2,0),COLORffcc66;
STICKLINE(C< O,L,H,0.1,0),COLORffcc66;
STICKLINE(C=O AND C>=REF(C,1),O,C,7,0),COLORRED;
STICKLINE(C=O AND C>=REF(C,1),O,C,4,0),COLORB0B0FF;
STICKLINE(C=O AND C>=REF(C,1),O,C,2,0),COLORYELLOW;
STICKLINE(C=O AND C>=REF(C,1),L,H,0.1,0),COLORYELLOW;
STICKLINE(C=O AND C< REF(C,1),O,C,7,0),COLORFF2020;
STICKLINE(C=O AND C< REF(C,1),O,C,4,0),COLORFF6600;
STICKLINE(C=O AND C< REF(C,1),O,C,2,0),COLORffcc66;
STICKLINE(C=O AND C< REF(C,1),L,H,0.1,0),COLORffcc66;
var1:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,5);
A1:=CLOSE/MA(CLOSE,40);
A2:=(CLOSE-OPEN)/OPEN*100>4;
A3:=LOW*1.051<HIGH;
A4:=A3 AND COUNT(A3,5)>1;
B1:=INDEXC;
B2:=MA(B1,5);
B3:=MA(B1,20);
B4:=B1*1.03<B2 AND B1*1.13<B3;
买入1:=(var1<6 AND A1<0.85 AND A2)*90;
买入2:=(var1<6 AND A1<0.76 AND A4)*70;
买入3:=(var1<6 AND B4)*60;
DRAWICON(var1<6 AND A1<0.85 AND A2,l*0.9,1);
DRAWTEXT(var1<6 AND A1<0.85 AND A2,l*0.85,'--->买入1'),colorred;
DRAWICON(var1<6 AND A1<0.76 AND A4,l*0.9,1);
DRAWTEXT(var1<6 AND A1<0.76 AND A4,l*0.85,'--->买入2'),colorred;
DRAWICON(var1<6 AND B4,l*0.9,1);
DRAWTEXT(var1<6 AND B4,l*0.85,'--->买入3'),colorred;
Var2:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));
Var3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);
MV:=(Var2+Var3)/AMOUNT*VOL*100*50;
DRAWICON(MV>5,l*0.95,1);
DRAWTEXT(MV>5,l*0.95,'--->异动'),coloryellow;
Var4:=EMA((EMA(CLOSE,95)-EMA(CLOSE,120)),35);
Var5:=((EMA(CLOSE,95)-EMA(CLOSE,120))-Var4)*2;
DRAWICON(Var5>0.3,h*1.05,2);
DRAWTEXT(Var5>0.3,h*1.05,'--->顶'),colorred;

通达信天风地火主图指标公式

 

相关文章