在线检测未来函数

通达信玉帝渡观音主图指标公式

来源:Internet,编辑:股旁网,2013-03-13

CYC2:MA((CLOSE+OPEN)/2,VOL/(SMA(VOL,13,1)*13));
CYC3:MA((CLOSE+OPEN)/2,VOL/(SMA(VOL,34,1)*34));
CYC4:MA((CLOSE+OPEN)/2,VOL/(SMA(VOL,89,1)*89)),linethick2;
Var1a:=(HIGH+LOW+CLOSE)/3;
Var2a:=(Var1a-MA(Var1a,14))/(0.015*AVEDEV(Var1a,14));
Var3:=MA(VOL,5);
Var4:=MA(VOL,10);
Var5:=MA(VOL,60);
Var6:=MA(CLOSE,5);
Var7:=MA(CLOSE,8);
Var8:=MA(CLOSE,25);
Var9:=MA(CLOSE,60);
DRAWTEXT(CROSS(Var2a,EMA(Var2a,2)) AND Var2a>80 AND VOL>Var3 AND VOL>Var4 AND VOL>Var5 AND Var6>Var9 AND Var7>Var9 AND Var8>Var9 AND OPEN<Var6 AND CLOSE>Var6,LOW,'拉升'),coloryellow;
Var1:=EMA(AMOUNT/VOL/100,3);
成本: EMA(Var1,88),CROSSDOT;
伏击: EMA(Var1,88)*0.85,CROSSDOT;
年线:MA(CLOSE,250),POINTDOT,colorffcc66;
cb:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
玉帝出逃:cb+cb*10/100, COLORBLUE;
Var9a:=REF(CLOSE,1);
VarA:=SMA(MAX(CLOSE-Var9a,0),6,1)/SMA(ABS(CLOSE-Var9a),6,1)*100;
DRAWTEXT(CROSS(84,VarA),HIGH,'→逃顶 '),color00ff00;
Var1g:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14,1);
Var2g:=HIGH-REF(HIGH,1);
Var3g:=REF(LOW,1)-LOW;
Var4g:=SMA(IF(Var2g>0 AND Var2g>Var3g,Var2g,0),12,1);
Var5g:=SMA(IF(Var3g>0 AND Var3g>Var2g,Var3g,0),12,1);
Var6g:=Var4g*100/Var1;
Var7g:=Var5g*100/Var1;
Var8g:=SMA(ABS(Var7g-Var6g)/(Var7g+Var6g)*100,12,1);
Var9g:=(Var8g+REF(Var8g,5))/2;
VarAg:=SUM(HIGH-OPEN,12)/SUM(OPEN-LOW,12)*100;
VarB:=SUM(MAX(0,HIGH-REF(CLOSE,1)),12)/SUM(MAX(0,REF(CLOSE,1)-LOW),12)*100;
VarC:=AMOUNT/VOL/100;
VarD:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VarE:=SUM(AMOUNT,5)/VarC/100;
VarF:=SUM(AMOUNT,13)/VarC/100;
Var10:=SUM(AMOUNT,34)/VarC/100;
Var11:=SUM(AMOUNT,209)/VarC/100;
Var12:=REF(VOL,1)+REF(VOL,2)+REF(VOL,3)+REF(VOL,4);
Var13:=Var12/CAPITAL;
Var14:=VOL/CAPITAL*VarD+Var13*REF(VarC,1);
Var15:=DMA(VarD,VOL/VarE);
Var16:=DMA(VarD,VOL/VarF);
Var17:=DMA(VarD,VOL/Var10);
Var18:=DMA(VarD,VOL/CAPITAL);
Var19:=MA(HHV(HIGH,488),18);
Var1Ag:=MA(HHV(HIGH,220),18);
Var1B:=MA(HHV(HIGH,98),18);
Var1C:=MA(LLV(LOW,488),18);
Var1D:=MA(LLV(LOW,220),18);
Var1E:=MA(LLV(LOW,98),18);
Var1F:=MA((Var1C*0.96+Var1D*0.96+Var1E*0.96+Var19*0.558+Var1Ag*0.558+Var1B*0.558)/6,18);
Var20:=MA((Var1C*1.25+Var1D*1.23+Var1E*1.2+Var19*0.55+Var1Ag*0.55+Var1B*0.65)/6,18);
Var21:=MA((Var1C*1.3+Var1D*1.3+Var1E*1.3+Var19*0.68+Var1Ag*0.68+Var1B*0.68)/6,18);
Var22:=MA((Var1F*3+Var20*2+Var21)/6*1.738,18);
Var24:=LOW;
Var25:=REF(LOW,1);
Var26:=SMA(ABS(Var24-Var25),3,1)/SMA(MAX(Var24-Var25,0),3,1)*100;
Var27:=MA(IF(CLOSE*1.35<=Var22,Var26*10,Var26/10),3);
Var28:=LLV(LOW,30);
Var29:=HHV(Var27,30);
Var2Ag:=IF(LOW<=Var28,(Var27+Var29*2)/2,0);
DRAWTEXT(MA(Var2Ag AND CLOSE<COST(1),3) AND (CLOSE-Var16)/Var16*100<-16,LOW,'盯'),colorff00ff;
DRAWTEXT(MA(Var2Ag AND CLOSE<COST(1),3) AND (CLOSE-Var16)/Var16*100<-19,LOW,'杀进'),COLORYELLOW ;
Var1z:=(CLOSE-OPEN)/OPEN*100;
Var2z:=REF(CLOSE,1);
Var3z:=SMA(MAX(CLOSE-Var2z,0),6,1)/SMA(ABS(CLOSE-Var2z),6,1)*100;
Var4z:=COUNT(Var3z<20,20)>=1;
DRAWTEXT(Var1z>9 AND Var4z,LOW,'观音'),coloryellow;
Var18a:=(HIGH+LOW+CLOSE)/3;
Var19a:=(Var18a-MA(Var18a,14))/(0.015*AVEDEV(Var18a,14));
Var1Aa:=(Var18a-MA(Var18a,70))/(0.015*AVEDEV(Var18a,70));
Var1Ba:=IF(Var19a>=150 AND Var19a<200 AND Var1Aa>=150 AND Var1Aa<200,-10,0);
Var1Ca:=IF(Var19a<=-150 AND Var19a>-200 AND Var1Aa<=-150 AND Var1Aa>-200,10,0);
Var1Da:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
Var1Ea:=100-ABS(Var1Da);
出击A:=(IF(BARSCOUNT(CLOSE)<13,-100,0-IF(Var1Ea<92 AND Var1Da<0,20,100))+100)*1,STICK,COLORFF00FF;
出击:DRAWICON(IF(出击A=80,30,0),LLV(LOW,5),4);
卖出A:=(IF(BARSCOUNT(CLOSE)<70,120,IF(Var1Aa>=200 AND Var19a>=150,-15,Var1B)))*(-1),STICK,colorccff66;
DRAWICON(卖出A<=15 AND 卖出A>5 ,HHV(HIGH,5),5);

通达信玉帝渡观音主图指标公式

 

相关文章