在线检测未来函数

通达信未来不是梦指标公式

来源:Internet,编辑:股旁网,2013-03-13

MA1:MA(CLOSE,5),COLORFFFFFF,LINETHICK3;
MA2:MA(CLOSE,10),COLORFFFFFF,LINETHICK3;
MA3:MA(CLOSE,20),COLORE66878,LINETHICK3;
MA4:MA(CLOSE,30),COLOR00FFFF,LINETHICK3;
MA5:MA(CLOSE,10),COLOR0000FF,LINETHICK3;
涨停:=IF(REF(C,1)*1.1-C<0.2 ,1,0);
STICKLINE(OPEN>=CLOSE ,O,C,3,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE ,O,C,1.75,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE ,O,C,0.5,0 ),COLOR00FF00;
STICKLINE(CLOSE>OPEN,O,C,3,0 ),COLORRED;
STICKLINE(CLOSE>OPEN,O,C,1.75 ,0 ),COLORRED;
STICKLINE(CLOSE>OPEN,O,C,0.5,0 ),COLORRED;
STICKLINE(CLOSE>OPEN,OPEN,LOW,0,0),COLORRED;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0,0 ),COLORRED;
STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0,0),COLOR00FF00;
VAR1:=SAR(10,2,20);
IF(VAR1<=C,VAR1,DRAWNULL),COLORRED,CIRCLEDOT,LINETHICK8;
IF(VAR1>C,VAR1,DRAWNULL),COLORGREEN,CIRCLEDOT,LINETHICK8;
B1:=REF(C,1);B2:=REF(C,2);
SS:=IF(C>REF(C,1) AND REF(C,1)>=REF(C,2),1,IF(C<REF(C,1) AND REF(C,1)<=REF(C,2),-1,IF(C>REF(C,2) AND REF(C,2)>REF(C,1),2,IF(C<REF(C,2) AND REF(C,2)<REF(C,1),-2,0))));
SM:=IF(REF(SS,1)>0 OR REF(SS,1)<0,REF(SS,1),IF(REF(SS,2)>0 OR REF(SS,2)<0,REF(SS,2),IF(REF(SS,3)>0 OR REF(SS,3)<0,REF(SS,3),IF(REF(SS,4)>0 OR REF(SS,4)<0,REF(SS,4),IF(REF(SS,5)>0 OR REF(SS,5)<0,REF(SS,5),IF(REF(SS,6)>0 OR REF(SS,6)<0,REF(SS,6),IF(REF(SS,7)>0 OR REF(SS,7)<0,REF(SS,7),0)))))));ZYXF:=TROUGHBARS(3,15,1)<4;
STICKLINE(FILTER(ZYXF=1,5),50,0,6,0),COLORRED;
DRAWICON(FILTER(ZYXF=1,3),80,1);
DRAWTEXT(FILTER(ZYXF=1,3),60,'漂流底'),COLORYELLOW;
买吗:= IF(TROUGHBARS(3,15,1)=0 AND HIGH>LOW+0.01,21,-0),COLORYELLOW ,LINETHICK2;
卖吧: IF(PEAKBARS(3,15,1)=1,51,80),COLORGREEN,LINETHICK2;
DRAWTEXT(卖吧=51,55,'卖吧');
VAR1AAA:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>REF(ZIG(3,10),2);{ZIG 有未来}
VAR2AAA:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<REF(ZIG(3,10),2);
试探买入:IF(VAR2AAA AND COUNT(VAR2AAA,3)=1,15,0),STICK,LINETHICK1,COLORFF00FF;
STICKLINE(VAR2AAA,0,25,4,0),COLORFF00FF;
DRAWTEXT(试探买入=15,25,'买一点');
0,LINETHICK2,COLORYELLOW;

通达信未来不是梦指标公式

 

相关文章