在线检测未来函数

通达信控仙丹指标公式

来源:Internet,编辑:股旁网,2013-03-13

VOLUME:VOL,VOLSTICK;
MAVOL1:=MA(VOLUME,5);
MAVOL2:=MA(VOLUME,10);
VVOL:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5 ,VVOL,V,2,-1);
主力启动线:MA(VOLUME,5),COLORRED,LINETHICK1;
主力洗盘线:MA(VOLUME,35),COLORYELLOW,LINETHICK1;
资金异动线:MA(VOLUME,135),COLORBLUE,LINETHICK1;
{出击:}STICKLINE(CROSS(主力启动线,资金异动线) OR ((主力洗盘线 > 资金异动线) AND CROSS(主力启动线,主力洗盘线)),V*0.75,VOL,2.5,0),COLORYELLOW;
DRAWICON(CROSS(主力启动线,资金异动线) OR ((主力洗盘线 > 资金异动线) AND CROSS(主力启动线,主力洗盘线)),主力洗盘线*2.5,15);
{启动:}STICKLINE(主力启动线>REF(主力启动线,1) AND (CROSS(VOL,主力启动线) AND (REF(VOL,1)<REF(资金异动线,1) AND REF(VOL,2)<REF(资金异动线,2))),V*0.75,V*0.5,2.5,0),COLORBLUE;
DRAWICON(主力启动线>REF(主力启动线,1) AND (CROSS(VOL,主力启动线) AND (REF(VOL,1)<REF(资金异动线,1) AND REF(VOL,2)<REF(资金异动线,2))),资金异动线*1.5,19);
V1:=CLOSE/LLV(C,4){REF(CLOSE,2)}>=1.095;
V2:=BACKSET(V1,2);
V3:=REF(CLOSE,3)*1.1;
V4:=CROSS(C,V3);
{OK:}STICKLINE((V2 AND COUNT(V2,2)=1),0.2*V,V*0.5,2.5,0),COLORRED;
OKOK:=(V2 AND COUNT(V2,2)=1);
COND:=(CROSS(主力启动线,资金异动线) OR ((主力洗盘线 > 资金异动线) AND CROSS(主力启动线,主力洗盘线)))
OR (主力启动线>REF(主力启动线,1) AND (CROSS(VOL,主力启动线) AND (REF(VOL,1)<REF(资金异动线,1) OR REF(VOL,2)<REF(资金异动线,2))))
OR (V2 AND COUNT(V2,2)=1),LINETHICK02,COLORRED;
牛股:=(CROSS(主力启动线,资金异动线) {OR (V2 AND COUNT(V2,2)=1)} OR ((主力洗盘线 > 资金异动线) AND CROSS(主力启动线,主力洗盘线))) AND (主力启动线>REF(主力启动线,1) AND (CROSS(VOL,主力启动线) AND (REF(VOL,1)<REF(资金异动线,1) OR REF(VOL,2)<REF(资金异动线,2)))) ;
{主力控盘}
VAR11:=EMA(EMA(CLOSE,9),9);
控盘:=(VAR11-REF(VAR11,1))/REF(VAR11,1)*1000;
A10:=CROSS(控盘,0);
{开始控盘:=IF(A10,5,0),LINETHICK2,COLORYELLOW;}
STICKLINE(控盘>REF(控盘,1) AND 控盘>0,0,VOL*0.2,2.5,0),COLORLIRED;
有庄控盘:=IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0),COLORRED,NODRAW;
有控盘:=有庄控盘;
VAR2:=100*WINNER(CLOSE*0.95);
STICKLINE(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,0,VOL*0.2,2.5,0),COLORFF00FF;
高度控盘:=IF(VAR2>50 AND COST(85)<CLOSE AND 控盘>0,控盘,0);
高控盘:=高度控盘;
STICKLINE(控盘<REF(控盘,1) AND 控盘>0,V*0.87,VOL*0.97,2.5,0),COLOR00FF00;
选股公式:=EXIST(牛股,3) AND ( 有控盘 OR 高控盘 );
换手:=VOL/CAPITAL*100;
十日换手:=SUM(换手,10);
二十日换手:SUM(换手,20),NODRAW;
欣喜:=MEMA(XMA((((C-O)*2)+O),30),13);
若狂:=MEMA(MEMA((((C-O)*2)+O),5),13);
DRAWICON(LONGCROSS(欣喜,若狂,1),{V*0.6}主力启动线,7),COLORRED;
DRAWICON(LONGCROSS(若狂,欣喜,1),{V*0.6}主力启动线,8),COLORGREEN;
DRAWTEXT(LONGCROSS(欣喜,若狂,1),{V*0.6}主力启动线,'买入'),COLORRED;
机构资金趋势:=MA(MA(C,2),1),COLORWHITE,LINETHICK2;
机构持仓:=STICKLINE(MA(C,20)>=REF(MA(C,20),1),REF(MA(C,20),4),MA(C,20),5,0),COLORLIRED;
丹:=CROSS(欣喜,机构资金趋势) AND ( COUNT(CROSS(若狂,欣喜),15)>=1 OR (MA(C,20)<=REF(MA(C,20),1)));
DRAWICON(丹,资金异动线*2.3,6);
{斜率1:=(机构资金趋势-REF(机构资金趋势,1))/REF(机构资金趋势,1);
斜率2:=(REF(机构资金趋势,1)-REF(机构资金趋势,2))/REF(机构资金趋势,2);
斜率增大:=斜率1<=斜率2;}
金丹:=((LONGCROSS(机构资金趋势,欣喜,1) OR LONGCROSS(机构资金趋势,若狂,1) ) AND 机构资金趋势>REF(机构资金趋势,1) ) AND (欣喜 >若狂) AND (欣喜>REF(欣喜,1)) {AND 若狂>=REF(若狂,1)} AND (EMA(C,20)>=REF(EMA(C,20),1)) AND 机构资金趋势>若狂 ;
DRAWICON(金丹,主力启动线*3.5,17);
金丹2:=((LONGCROSS(机构资金趋势,欣喜,1) {OR CROSS(机构资金趋势,若狂)} OR LONGCROSS(机构资金趋势,若狂,1) OR (十日换手>40 AND 二十日换手>80 )) AND 机构资金趋势>REF(机构资金趋势,1) ) AND ((COUNT(CROSS(欣喜,若狂),15)>=1 ) AND 欣喜>REF(欣喜,1)) {AND 若狂>=REF(若狂,1)} AND (EMA(C,20)>=REF(EMA(C,20),1)) AND 机构资金趋势>若狂 ;
DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),资金异动线*5,'短卖'),COLORLIGREEN;
DRAWICON(金丹2,资金异动线,23);
满仓:=(ZIG(3,35)>REF(ZIG(3,35),1) AND REF(ZIG(3,35),1)<REF(ZIG(3,35),2));{DRAWICON((ZIG(3,35)>REF(ZIG(3,35),1) AND REF(ZIG(3,35),1)<REF(ZIG(3,35),2)),资金异动线*4,25);}
DRAWTEXT(满仓,资金异动线*4,'满仓'),COLORRED;
空仓:=(ZIG(3,35)<REF(ZIG(3,35),1) AND REF(ZIG(3,35),1)>REF(ZIG(3,35),2));{DRAWICON((ZIG(3,35)<REF(ZIG(3,35),1) AND REF(ZIG(3,35),1)>REF(ZIG(3,35),2)),资金异动线*3.8,27);}
DRAWTEXT(空仓,资金异动线*3.8,' 空仓'),COLORGREEN;
JL01:=MA(C,3);
LJL07:=(3*C+L+O+H)/6;
牛线:=(20*LJL07+19*REF(LJL07,1)+18*REF(LJL07,2)+17*REF(LJL07,3)+16*REF(LJL07,4)+15*REF(LJL07,5)+14*REF(LJL07,6)+13*REF(LJL07,7)+12*REF(LJL07,8)+11*REF(LJL07,9)+10*REF(LJL07,10)+9*REF(LJL07,11)+8*REF(LJL07,12)+7*REF(LJL07,13)+6*REF(LJL07,14)+5*REF(LJL07,15)+4*REF(LJL07,16)+3*REF(LJL07,17)+2*REF(LJL07,18)+REF(LJL07,20))/210;
马线:=MA(牛线,5);
VAR1L:=(C>REF(C,1) AND C>REF(C,2));
VAR2L:=(REF(VAR1L,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR3L:=(REF(VAR2L,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR4L:=(REF(VAR3L,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR5L:=(REF(VAR4L,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR6L:=(REF(VAR5L,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR7L:=(REF(VAR6L,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR8L:=(REF(VAR7L,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR9L:=(REF(VAR8L,1) AND C>=REF(C,1) AND C<=REF(C,2));
VARAL:=(REF(VAR9L,1) AND C<=REF(C,1) AND C>=REF(C,2));
VARBL:=(REF(VARAL,1) AND C>=REF(C,1) AND C<=REF(C,2));
VARCL:=(REF(VARBL,1) AND C<=REF(C,1) AND C>=REF(C,2));
机构持仓区域:=MA(C,20)>=REF(MA(C,20),1),NODRAW,COLORLIRED;
持股:=IF(VAR1L OR VAR2L OR VAR3L OR VAR4L OR VAR5L OR VAR6L OR VAR7L OR VAR8L OR VAR9L OR VARAL OR VARBL OR VARCL,牛线,DRAWNULL),COLORMAGENTA,LINETHICK2;
VARDL:=(C<REF(C,1) AND C<REF(C,2));
VAREL:=(REF(VARDL,1) AND C>=REF(C,1) AND C<=REF(C,2));
VARFL:=(REF(VAREL,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR1L0:=(REF(VARFL,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR1L1:=(REF(VAR1L0,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR1L2:=(REF(VAR1L1,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR1L3:=(REF(VAR1L2,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR1L4:=(REF(VAR1L3,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR1L5:=(REF(VAR1L4,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR1L6:=(REF(VAR1L5,1) AND C>=REF(C,1) AND C<=REF(C,2));
VAR1L7:=(REF(VAR1L6,1) AND C<=REF(C,1) AND C>=REF(C,2));
VAR1L8:=(REF(VAR1L7,1) AND C>=REF(C,1) AND C<=REF(C,2));
持币:=IF(VARDL OR VAREL OR VARFL OR VAR1L0 OR VAR1L1 OR VAR1L2 OR VAR1L3 OR VAR1L4 OR VAR1L5 OR VAR1L6 OR VAR1L7 OR VAR1L8,牛线,DRAWNULL),COLORGREEN,LINETHICK2;
DRAWTEXT(OKOK AND MA(C,20)>=REF(MA(C,20),1) AND 持股,资金异动线*5,'OK');
DRAWTEXT(EXIST(牛股,1) AND ( 有控盘 OR 高控盘 ) AND MA(C,20)>=REF(MA(C,20),1) AND 持股,主力启动线*5.5,'牛控'),COLORRED;

通达信控仙丹指标公式

 

相关文章