在线检测未来函数

通达信形态量指标公式

来源:Internet,编辑:股旁网,2013-03-14

STICKLINE(CLOSE>=OPEN,0,vol,4,1),colorred;
STICKLINE(CLOSE<OPEN,0,vol,4,1),coloryellow;
量增:STICKLINE(vol>=REF(vol,1)*1.2 and vol<REF(vol,1)*1.4,0,vol,4,0),colorred;
巨量:STICKLINE(vol>=REF(vol,1)*1.4,0,vol,4,0),coloryellow;
量减:STICKLINE(vol<=REF(vol,1)*0.8 and vol>REF(vol,1)*0.6,0,vol,4,0),color66ff00;
低量:STICKLINE(vol<=REF(vol,1)*0.6,0,vol,4,0),color66ff00;
底部量:STICKLINE(vol<=ma(vol,12)*0.13,0,vol,4,0),COLOR66ff00;
危险量:STICKLINE(vol>=FINANCE(7)*0.1*100,0,vol,4,0),colorred;
AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买盘:IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE<OPEN,AA*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLORred, LINETHICK0;
主动卖盘:IF(CLOSE>OPEN,0-AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-AA*(HIGH-LOW),0-VOL/2)),color66ff00, LINETHICK0;
STICKLINE(主动买盘>0,主动买盘,VOL,4,0),colorffff00;
ch1:(ma(VOL,5)+ma(VOL,10)+ma(VOL,25))/3;
ch2:(ma(VOL,5)+ma(VOL,10)+ma(VOL,20)+ma(VOL,60)+ma(VOL,120))/5;
ch3:(ma(VOL,20)+ma(VOL,60)+ma(VOL,120))/3,COLORGREEN,linethick1;
量已经出现:DRAWTEXT(ch1>ch2 and ch2>ch3 and ch1>ch3,v,'●'),COLORred;
量不够或减少:DRAWTEXT(ch2>ch1 and ch3>ch2 and ch3>ch1,v,'●'),color66ff00;
持续放量:STICKLINE(count(VOL>REF(VOL,1),3)=3 ,vol*1.2+800 ,vol*1.12,5 ,0),colorred,pointdot;
卖出价预测:=(CLOSE*2.5/100+CLOSE);
买入价预测:=C-CLOSE*2.5/100;

通达信形态量指标公式

 

相关文章