在线检测未来函数

飞狐彩龙K线主图指标公式

来源:Internet,编辑:股旁网,2013-03-14

Var2:=REF(CLOSE-OPEN,2);
Var3:=REF(CLOSE,1);
Var4:=REF(CLOSE,2);
Var5:=REF(CLOSE,3);
Var6:=REF(CLOSE,4);
Var7:=MAX(MAX(MAX(CLOSE,Var3),Var4),Var5);
Var8:=MIN(MIN(MIN(CLOSE,Var3),Var4),Var5);
红色持股: STICKLINE(CLOSE=Var7 AND (Var3>=Var4 OR Var3>=Var5) OR Var3=Var7 AND (Var4=Var8 OR Var5=Var8) AND CLOSE>=Var4 OR Var4=Var7 AND Var5=Var8 AND CLOSE>=Var3 OR Var5=Var7 AND CLOSE>=Var3 AND CLOSE>=Var4,Var3,CLOSE,5,1), COLORRED;
品红变盘: STICKLINE(CLOSE=Var7 AND Var3=Var8,Var4,CLOSE,5,1),COLORMAGENTA;
黄色下跌: STICKLINE(CLOSE=Var8 AND (Var3<Var4 OR Var3<Var5) OR Var3=Var8 AND (Var4=Var7 OR Var5=Var7) AND CLOSE<Var4 OR Var4=Var8 AND Var5=Var7 AND CLOSE<Var3 OR Var5=Var8 AND CLOSE<Var3 AND CLOSE<Var4,Var3,CLOSE,5,0),COLORYELLOW;
绿色买: STICKLINE(Var3=Var7 AND CLOSE=Var8,Var4,CLOSE,5,0), COLORGREEN;
STICKLINE(Var3=Var8 AND CLOSE>=Var4 OR (Var4=Var8 AND Var3<=Var5 OR Var5=Var8 AND Var3<=Var4) AND Var4<Var6 AND CLOSE>=Var3,Var3,Var4,5,0), COLORGREEN;
兰色抛售: STICKLINE(Var3=Var7 AND CLOSE<Var4 OR (Var4=Var7 AND Var3>Var5 OR Var5=Var7 AND Var3>Var4) AND Var4>=Var6 AND CLOSE<Var3,Var3,Var4,5,1), COLORBLUE;
Var9:=SAR(5,1,5);
VarA:=EMA(CLOSE,30);
VarB:=IF(CLOSE>450,8,IF(CLOSE>=20 AND CLOSE<150,0.2,IF(CLOSE<20 AND CLOSE>=10,0.07,IF(CLOSE<10,0.03,0.07))));
变色龙: STICKLINE(CLOSE>Var9,VarA,VarA+VarB,6,0), COLORMAGENTA;
STICKLINE(CLOSE<Var9,VarA,VarA-VarB,6,0),COLORCYAN;
STICKLINE(CROSS(CLOSE,Var9),VarA,VarA-VarB,6,0);
STICKLINE(CROSS(Var9,CLOSE),VarA,VarA+VarB,6,0), COLORCYAN;
STICKLINE(RANGE(DAY,6,9) OR RANGE(DAY,27,30),VarA+0.01,VarA-0.01,6,0), COLORYELLOW;
生命线: FORCAST(CLOSE,30), CIRCLEDOT;
支撑: MA(CLOSE,13)*0.955;

飞狐彩龙K线主图指标公式

 

相关文章