在线检测未来函数

通达信庄家特快列车指标公式

来源:Internet,编辑:股旁网,2013-03-16

A5:=MA(C,5);
A20:=MA(C,20);
A30:=MA(C,30);
M5:=ATAN((A5/REF(A5,1)-1)*100)*180/3.14159;
M20:=ATAN((A20/REF(A20,1)-1)*100)*180/3.14159;
M30:=ATAN((A30/REF(A30,1)-1)*100)*180/3.14159;
QSXS:=M30>0;
A50:=IF(M5<0,-25,0);
A51:=IF(BETWEEN(M5,0,45),25,A50);
A52:=IF(BETWEEN(M5,45,75),50,A51);
MA5:IF(M5>75,75,A52)*QSXS,COLOR00FFFF;
A200:=IF(M20<0,-25,0);
A201:=IF(BETWEEN(M20,0,45),25,A200);
A202:=IF(BETWEEN(M20,45,75),50,A201);
MA20:IF(M20>75,75,A202)*QSXS,COLORFF00FF;
A300:=IF(M30<0,-25,0);
A301:=IF(BETWEEN(M30,0,45),25,A300);
A302:=IF(BETWEEN(M30,45,75),50,A301);
MA30:IF(M30>75,75,A302)*QSXS,COLOR00FF00;
SGSJ:=BARSLAST(CROSS(MA5,REF(MA5+1,1)));
XGSJ:=BARSLAST(CROSS(REF(MA5-1,1),MA5));
列车:IF(MA5>=50 AND MA20>=25 AND MA30>=25 AND SGSJ<XGSJ,50,25),COLOR00FFFF;
启动:IF(CROSS(列车,45),50,25),COLORFF00FF;
站台:IF(MA5<=0 AND COUNT(MA20>=25,10)>=9 AND MA30>=25,-25,25),COLORFFFF00;
买票:IF(站台=-25 AND COUNT(站台=-25,3)>=2 AND C>=REF(C,4),25,-10),COLORFF8800;
上车:IF(CROSS(MA5,0) AND COUNT(MA20>=25,10)>=9 AND MA30>=25,50,25),COLORFFFFFF;
{以下设置副图显示方式}
STICKLINE(MA5>0,25,33,4,1),COLOR00FFFF;
STICKLINE(MA20>0,33,41,4,1),COLORFF00FF;
STICKLINE(MA30>0,41,50,4,1),COLOR00FF00;
{追求简洁者,以上三行可删除}
DRAWTEXT(列车=50,25, '○'),COLOR88FFFF;
DRAWTEXT(启动=50,25, '●'),COLORFF00FF;
DRAWTEXT(上车=50,25, '△'),COLORFFFFFF;
STICKLINE(站台=-25,-10,-25,4,0),COLORFFFF00;

通达信庄家特快列车指标公式

 

相关文章