在线检测未来函数

通达信彩虹指标公式

来源:Internet,编辑:股旁网,2013-03-16

RV:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;
RG:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100;
J0:=(HIGH+LOW)/2;QJ:=EMA(J0,3);
J1:=IF(CLOSE>QJ,VOL,0);
J2:=IF(CLOSE<QJ,VOL,0);
量能:IF(CAPITAL<1,MA(VOL,74),MA(SUM(J1-J2,22),3)),COLOR00DDDD,NODRAW;
趋势:IF(CAPITAL<1,EMA(量能,360),EMA(量能,21)),COLOR008800,NODRAW;
VAR3:=(量能-趋势);
VAR44:=SMA(RV,3,1);
VAR55:=SMA(VAR44,3,1);
STICKLINE(VAR3>0,20,10,5,1),COLOR0000FF;
STICKLINE(VAR3<0,100,90,10,1),COLOR00FF00;
DRAWICON(CROSS(VAR44,VAR55) AND VAR55<30,2,1);
DRAWICON(CROSS(VAR55,VAR44) AND VAR55>30,97,2);
DRAWBAND(VAR55,RGB(0,22,224),VAR44,RGB(255,50,50));
遵:IF(VAR55>=VAR44,VAR55,DRAWNULL),COLORRED;
守:IF(VAR44>=VAR55,VAR44,DRAWNULL),COLORFF9900;
纪:IF(VAR55>=VAR44,VAR44,DRAWNULL),COLOR00FFFF;
律:IF(VAR44>=VAR55,VAR55,DRAWNULL),COLOR00FF00;
KK:=EMA(SMA(RG,3,1),2),LINETHICK0;
DD:=SMA(KK,3,1),LINETHICK0;
{DRAWBAND(KK,RGB(155,50,50),DD,RGB(0,100,50));
持:IF(KK>=DD,KK,DRAWNULL),COLORRED;
观:IF(DD>=KK,DD,DRAWNULL),COLORFF9900;
股:IF(KK>=DD,DD,DRAWNULL),COLOR00FFFF;
望:IF(DD>=KK,KK,DRAWNULL),COLOR00FF00; }
DRAWICON(CROSS(KK,DD),KK,23);
DRAWTEXT(CROSS(VAR44,VAR55) AND CROSS(KK,DD),10,'共振'),COLOR00FFFF;
共振点:=(CROSS(VAR44,VAR55) AND CROSS(KK,DD));
STICKLINE(共振点>0,0,30,2,0),COLOR008888;
STICKLINE(共振点>0,0,30,1.5,0),COLOR00AAAA;
STICKLINE(共振点>0,0,30,0.8,0),COLOR00DDDD;
STICKLINE(共振点>0,0,30,0.3,0),COLOR00FFFF;
VAR1:=1;
VAR2:=((((2*CLOSE)+HIGH)+LOW) / 4);
金叉进:20,COLORFF00FF,LINETHICK2;
高死叉出:90,COLORBLUE,LINETHICK2;
VAR4:=LLV(LOW,5);
VAR5:=HHV(HIGH,4);
C1:=(EMA((((VAR2-VAR4)/(VAR5-VAR4))*100),4)*VAR1),COLORFF00FF,LINETHICK2;
C2:=(EMA(((0.667*REF(C1,1))+(0.333*C1)),2)*VAR1),COLORFFFFFF,LINETHICK2;
条件:=CROSS(C1,C2) AND C1<40;
条件0:=CROSS(C2,C1) AND C1>90;
TJ1:=CROSS(C1,C2);
TJ2:=CROSS(C2,C1);
TJ3:=CROSS(C1,C2) AND REF(C1,1)<20;
TJ4:=CROSS(C2,C1) AND REF(C1,1)>80;
DRAWTEXT(FILTER((REF(条件,1) AND (REF(LOW,1)>LOW OR TJ2))
OR (REF(条件,2) AND (REF(LOW,2)>LLV(LOW,3) OR TJ2))
OR (REF(条件,3) AND (REF(LOW,3)>LLV(LOW,4) OR TJ2)),4),70,'止'),COLORRED;
{DRAWTEXT(FILTER((REF(条件,1) AND (REF(LOW,1)>LOW OR TJ2))
OR (REF(条件,2) AND (REF(LOW,2)>LLV(LOW,3) OR TJ2))
OR (REF(条件,3) AND (REF(LOW,3)>LLV(LOW,4) OR TJ2)),4),60,'跌'),COLORRED;}
DRAWTEXT(FILTER((REF(条件,1) AND (REF(LOW,1)>LOW OR TJ2)) OR
(REF(条件,2) AND (REF(LOW,2)>LLV(LOW,3) OR TJ2))
OR (REF(条件,3) AND (REF(LOW,3)>LLV(LOW,4) OR TJ2)),4),65,'买'),COLORRED;
DRAWTEXT(条件,20,'买'),COLORRED;
STICKLINE(条件,0,20,2,0),COLORRED;
DRAWTEXT(条件0,85,'卖'),COLORBLUE;
DRAWTEXT(CROSS(C1,75),70,'险区'),COLORGREEN;
DRAWTEXT(TJ3,65,'安'),COLORRED;
DRAWTEXT(TJ3,60,'买'),COLORRED;
DRAWTEXT(TJ4,85,'逃顶'),COLORBLUE;
STICKLINE(TJ4,100,80,2,0),COLORGREEN;
VAR200:=(CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20))*100;
VAR300:=SMA(SMA(VAR200,3,1),3,1)/28.57;
VAR400:=EMA(VAR300,5);
操盘:=3*VAR300-2*VAR400;
A1:=CROSS(操盘,VAR300) AND VAR300<2.1 AND C>O;
STICKLINE(A1,20,0,4,0),COLOR770077;
STICKLINE(A1,20,0,3,0),COLOR990099;
STICKLINE(A1,20,0,2,0),COLORBB00BB;
STICKLINE(A1,20,0,1,0),COLORDD00DD;
STICKLINE(A1,20,0,0.3,0),COLORFF00FF;
DRAWTEXT(A1,30,'财'),COLORFF00FF;
★遵守纪律★:100,COLORRED,NODRAW;
★交易之魂★:100,COLORRED,NODRAW;

通达信彩虹指标公式

 

相关文章