在线检测未来函数

通达信短线快马主图指标公式

来源:Internet,编辑:股旁网,2013-03-17

1、线:股票短期均线5、10、20、30呈多头排列;获利盘达到60%左右,庄家筹码比较集中; 2、量:短期量能曾经连续萎缩3天; 3、价:短期股价曾经连跌3天,或者低点、高点或中心不断下移; 4、涨:今日出现第一根中阳线放量拉升,可以视为短线快马,一般次日均能再涨; 5、除:适当排除短线已经连续拉出阳线或已经具有较大涨幅个股; 6、回:短线快马该涨不涨,2日内连续缩量回调,可作为回调买点。

MA5:MA(CLOSE,5),COLORWHITE,LINETHICK2;
MA30:MA(CLOSE,30),COLORYELLOW,LINETHICK2;
{获利盘--庄家筹码集中度}
获利:=WINNER(CLOSE),COLORRED;
CMJZ:=CLOSE/COST(60)>0.98;
{短线多头}
DT1:=(CLOSE>REF(CLOSE,4) OR MA(CLOSE,5)>MA(CLOSE,10)) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,20)>MA(CLOSE,30);
DT2:=MA(CLOSE,5)>=REF(MA(CLOSE,5),1) AND MA(CLOSE,10)>REF(MA(CLOSE,10),1) AND MA(CLOSE,20)>REF(MA(CLOSE,20),1) AND MA(CLOSE,30)>REF(MA(CLOSE,30),1);
{量形波浪}
LXSL:=(VOL<REF(VOL,1) AND REF(VOL,1)<REF(VOL,2)) OR VOL<REF(VOL,1)/1.8;
SLSJ:=BARSLAST(LXSL);
{k线波浪}
GJZX:=(O+C+H+L)/4;
LXXD:=(C<REF(C,1) AND REF(C,1)<REF(C,2)) OR (GJZX<REF(GJZX,1) AND REF(GJZX,1)<REF(GJZX,2)) OR (H<REF(H,1) AND REF(H,1)<REF(H,2)) OR (L<REF(L,1) AND REF(L,1)<REF(L,2) AND GJZX<REF(GJZX,1));
XDSJ:=BARSLAST(LXXD);
QRSP:=REF(CLOSE,1)<REF(CLOSE,2) OR REF(CLOSE,1)/REF(CLOSE,2)<=1.035;
LXSY:=(H/REF(CLOSE,1)>=1.05 AND REF(CLOSE,1)>REF(CLOSE,2)*1.02 AND REF(CLOSE,2)>=REF(CLOSE,3)*1.02) OR H/REF(CLOSE,3)>=1.15,COLORRED;
FLSZ:=VOL>REF(VOL,1)*1.5 AND VOL>MA(VOL,5) AND CLOSE/REF(CLOSE,1)>=1.02;
短:=(FLSZ AND SLSJ<=3 AND XDSJ<=3)*0.5,COLORFF6600,STICK,LINETHICK1;
DRAWTEXT(短>0 ,L*0.97 , '短'),COLORYELLOW,LINETHICK1;
马:=(CMJZ AND DT1 AND DT2 AND QRSP AND SLSJ<=6 AND XDSJ<=6 AND FLSZ AND LXSY=0)*1.5,COLORYELLOW,STICK,LINETHICK2;
drawicon((获利>0.6 and 马>0),l-0.02,1);
DRAWTEXT(马>0 ,L*0.99, '马'),COLORRED,LINETHICK1;
ma0:=ma(c,5);
ma1:=ma(c,10);
穿:=(CROSS(C,MA0) OR (O<MA0 AND C>MA0)) AND V>REF(V,1) AND MA0>REF(MA0,1) AND MA1>REF(MA1,1);
DRAWTEXT(穿>0 ,H*1.03, '穿'),COLORYELLOW,LINETHICK1;
{快马回头}
N4:=BARSLAST(短 OR 马);
HT1:=N4<=2 AND L>REF(L,N4) AND C/REF(C,N4)<1.015 AND V<REF(V,1);
HT2:=REF(HT1,1) AND (C<=REF(C,1) OR C<=REF(C,N4)) AND C>REF(O,N4) AND V<REF(V,1);
回:=HT2*0.8,COLORWHITE,STICK,LINETHICK2;
STICKLINE(回,L*0.98,L*0.92,0,1),colorwhite,linethick2;
DRAWTEXT(回>0 ,L*0.95 , '回'),COLORFF00FF,LINETHICK1;
STICKLINE(短 OR 马,h,l,0,1),colorYELLOW,linethick2;
STICKLINE(短 OR 马,o,c,4,1),colorYELLOW,linethick2;
QSXS:=(MA(C,30)>REF(MA(C,30),1))*REF(MA(C,30),1)-0.1, CIRCLEDOT,COLORYELLOW;
DRAWTEXT(QSXS>0 ,MA30-0.02 , '○'),coloryellow,LINETHICK1;

通达信短线快马主图指标公式

 

相关文章