在线检测未来函数

通达信涨停黄金分割主图指标公式

来源:Internet,编辑:股旁网,2013-03-17

T:=150;
TT:=3;
均价线:=AMOUNT/V/100;
C2:=REF(C,1);
涨停:=IF(REF(C,1)*1.1-C<0.2 ,1,0);
STICKLINE(涨停,OPEN,CLOSE,4,0),COLORRED;
STICKLINE(涨停,OPEN,CLOSE,3,0),COLORYELLOW;
STICKLINE(涨停,H,L,0,0),COLORYELLOW;
B1:='┄┄┄┄┄';
DRAWTEXT(均价线 AND 涨停,均价线,B1),COLORGREEN;
B3:='┄┄┄┄┄';
DRAWTEXT((O+C)/2 AND 涨停,(O+C)/2 ,B3),COLORMAGENTA;
B2:='┄┄┄┄┄';
DRAWTEXT(涨停,L,B2),COLORGRAY;
MA13:=MA(C,13),COLORGRAY;
MA21:=MA(C,21),COLORWHITE;
支撑线:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
LC:=REF(CLOSE,1);
操作线:=SMA(MAX(CLOSE-LC,0),2,1)/SMA(ABS(CLOSE-LC),2,1)*100;
趋势线:=SMA(MAX(CLOSE-LC,0),14,1)/SMA(ABS(CLOSE-LC),14,1)*100;
震仓线:=45;
震仓线2:=50;
逃命线:=80;
抄底线:=20;
绝底线:=5;
PP2:=操作线<震仓线2 AND REF(操作线,1)>震仓线2 ;
PP:=操作线<震仓线 AND REF(操作线,1)>震仓线 ;
PP3:=操作线<抄底线 AND REF(操作线,1)>抄底线;
HH:=COUNT(涨停,13)>=1;
STICKLINE(PP2 AND HH,OPEN,CLOSE,0.8,0),COLORBLUE;
STICKLINE(PP AND HH,OPEN,CLOSE,0.8,0),COLORBLUE;
STICKLINE(PP3 AND HH,OPEN,CLOSE,0.8,0),COLORBLUE;
A:=SMA(L,4,3) ;
STICKLINE(A AND REF(PP,1) AND HH ,A*0.9999,A*0.9979,5,0);
DRAWICON(A AND REF(PP,1) AND HH,L*0.98,7);
STICKLINE(A AND REF(PP3,1) AND HH ,A*0.9999,A*0.9979,5,0);
DRAWICON(A AND REF(PP3,1) AND HH,L*0.98,7);
高1:=REF(HHV(H,T),TT);
低1:=REF(LLV(L,T),TT);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.5;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
顶:REFDATE(高1,DATE),COLORFFFF00;
一:REFDATE(H1,DATE),POINTDOT,COLORYELLOW;
二:REFDATE(H2,DATE),POINTDOT,COLORMAGENTA;
三:REFDATE(H3,DATE),COLOR00FFFF;
四:REFDATE(H4,DATE),POINTDOT,COLORMAGENTA;
五:REFDATE(H5,DATE),POINTDOT,COLORYELLOW;
低:REFDATE(低1,DATE),COLOR00FF00;
TT3:=(CURRBARSCOUNT=5);
TT4:=(CURRBARSCOUNT=5+3);
DRAWNUMBER(TT3 AND 顶,顶,顶),COLOR999900;
DRAWTEXT(TT4 AND 顶,顶,'高:'),COLOR208FFF;
DRAWNUMBER(TT3 AND 一,一,一),COLOR999999;
DRAWTEXT(TT4 AND 一,一,'191:'),COLOR208FFF;
DRAWNUMBER(TT3 AND 二,二,二),COLOR999999;
DRAWTEXT(TT4 AND 二,二,'382:'),COLOR208FFF;
DRAWNUMBER(TT3 AND 三,三,三),COLOR999999;
DRAWTEXT(TT4 AND 三,三,'1/2:'),COLOR208FFF;
DRAWNUMBER(TT3 AND 四,四,四),COLOR999999;
DRAWTEXT(TT4 AND 四,四,'618:'),COLOR208FFF;
DRAWNUMBER(TT3 AND 五,五,五),COLOR999999;
DRAWTEXT(TT4 AND 五,五,'809:'),COLOR208FFF;
DRAWNUMBER(TT3 AND 低,低*1.01,低),COLOR999900;
DRAWTEXT(TT4 AND 低,低*1.009,'低:'),COLOR208FFF;

通达信涨停黄金分割主图指标公式

 

相关文章