在线检测未来函数

通达信一品爱家+经典震仓指标公式

来源:Internet,编辑:股旁网,2013-03-18

N:=5;
ZC:=EMA(WINNER(C)*70,3)+20,COLORRED,LINETHICK2;
SC:=EMA((WINNER(C*1.1)-WINNER(C*0.9))*70,3),COLORFF6600;
SD:=ZC-SC;
生命:SD,COLORFF00FF,LINETHICK2;
AA:=SMA(ABS(L-REF(L,1)),N,1)/SMA(MAX(L-REF(l,1),0),N,1);
孕育:EMA(IF(L<=LLV(l,N),AA,0)*5,3),COLORYELLOW,POINTDOT;
GD:=SD>0 AND SD>REF(SD,1) AND REF(SD,1)<REF(SD,2);
健康:CROSS(SD,-20),COLORWHITE,POINTDOT;
成长:CROSS(SD,0),COLOR00FF00,POINTDOT;
快乐:CROSS(SD,20),COLOR0000FF,POINTDOT;
CZSJ:=BARSLAST(成长);
步步高:GD,COLOR00FF00,POINTDOT;
varC:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
DRAWTEXT(CROSS(84,varC),70,'退休'),COLORYELLOW;
DRAWICON(CROSS(82,varC),60,2);
退:CROSS(82,varC) OR CROSS(84,varC),COLORFF9900,POINTDOT;
休:CROSS(20,SD),COLORFF9900,POINTDOT;
XXSJ:=BARSLAST(休);
IF(C,-SD,-SD),COLORF0F000,LINETHICK2;
{以下设置副图显示方式}
STICKLINE(孕育>0,0,孕育,4,0),COLORYELLOW;
STICKLINE(C,0,0,4,0),COLORWHITE;
STICKLINE(C,20,20,4,0),COLORFF9900;
STICKLINE(C,-20,-20,4,0),COLORFF9900;
STICKLINE(SD>0 AND SD<20 AND CZSJ<XXSJ,0,SD,1,0),COLOR00FF00;
STICKLINE(SD>0 AND SD<20 AND CZSJ>XXSJ,0,SD,1,0),COLORFF9900;
STICKLINE(SD>20,20,SD,1,0),COLOREE88EE;
STICKLINE(SD>70,60,60,8,0),COLORWHITE;
DRAWTEXT(CROSS(SD,-20),-10,'□'),COLORWHITE;
DRAWTEXT(CROSS(SD,0),0,'▲'),COLOR00FF00;
DRAWTEXT(CROSS(20,SD),50,'↓'),COLORFF9900;
DRAWTEXT(CROSS(SD,20),20,'●'),COLOR0000FF;
DRAWTEXT(CROSS(SD,20),20,'¤'),COLOR0000FF;
DRAWTEXT(GD,50,'↑'),COLOR00FF00;
MA5:=MA(C,5);
MA10:=MA(C,10);
MA20:=MA(C,20);
MA30:=MA(C,30);
DTPL:=MA5>MA10 AND MA10>MA20 AND MA20>MA30;
DTSJ:=BARSLAST(DTPL AND NOT(REF(DTPL,1)));
ZXDT:=MA10>MA20 AND MA20>MA30 AND MA10>REF(MA10,1) AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);
BMBD:=DTSJ<20 AND ZXDT AND COUNT(ZXDT,5)>=3;
TDDF:=(L/REF(C,1)-1)*100<=-5 AND (REF(HHV(H,5),1)/L-1)*100>=DDF;
跳水:TDDF*-20,COLOR00FF00,LINETHICK2;
DRZC:=COUNT(H/REF(C,1)>=1.08,7) AND L/REF(C,1)<=0.93 AND BMBD;
运动:IF(DRZC>0,-20,0),COLORFF00FF,LINETHICK2;
经典:((DRZC OR TDDF) AND BMBD AND L=LLV(L,5))*-20,COLORYELLOW,LINETHICK2;
STICKLINE(DRZC,0,0.5,4,0),COLORYELLOW;
DRAWTEXT(DRZC OR 经典=-20,-20,'经◆典'),COLORFF00FF;
优选:DRZC AND TDDF AND BMBD AND L=LLV(L,5),COLORYELLOW,POINTDOT,LINETHICK0;
DRAWICON(优选,-20,1);

通达信一品爱家+经典震仓指标公式

 

相关文章