在线检测未来函数

通达信MACD带量指标公式

来源:Internet,编辑:股旁网,2013-03-18

{MACD带量}
DIFF1:EMA(C,6) - EMA(C,12),COLORRED;
DEA1:EMA(DIFF1,5),COLORYELLOW;
MACD1:=DIFF1-DEA1;
PJJ:=DMA((H + L + C * 2) / 4,0.9);
JJ:=REF(EMA(PJJ,3),1);
QJJ:=VOL / ((H - L) * 2 - ABS(C - O));
XVL:=IF(C > O,QJJ * (H - L),IF(C < O,QJJ * (H - O + (C - L)),VOL / 2)) + IF(C > O,0 - QJJ * (H - C + (O - L)),IF(C < O,0 - QJJ * (H - L),0 - VOL / 2));
ZLL:=VOL / CAPITAL;
HSL1:=IF(ZLL > 10,10,ZLL);
HSL:=XVL / 20 / 1.15;
攻击流量:=HSL * 0.55 + REF(HSL,1) * 0.33 + REF(HSL,2) * 0.22;
GJJ:=EMA(攻击流量,8);
LLJX:=EMA(攻击流量,3);
流量:=LLJX,COLORC875B7;
STICKLINE(流量 > 0 AND MACD1>0 ,MACD1/3,0,1,0),COLORRED;
STICKLINE(流量 > 0 AND MACD1<0,0,MACD1/3,1,0),COLORGREEN;
VAR01:=EMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5);
VAR02:=(HHV(HIGH,25)-LLV(LOW,25))/EMA((CLOSE-LLV(LOW,25)),5);
VAR03:=CROSS(VAR02,VAR01);
VAR04:=REF(VAR02,2)<REF(VAR02,1) AND VAR02<REF(VAR02,1);
YXF:=COUNT(VAR03,7)>0 AND VAR04;
VAR06:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR07:=SMA(ABS(LOW-VAR06),13,1)/SMA(MAX(LOW-VAR06,0),10,1);
VAR08:=EMA(VAR07,10);
VAR09:=EMA(C,5);
VAR10:=LLV(LOW,33);
VAR11:=EMA(IF(LOW<=VAR10,VAR09,0),3)*40;
VAR12:=IF(VAR11>100,VAR11*0.312,VAR11);
STICKLINE(YXF AND COUNT(YXF,5)=1,0.2,0.5,4,0),COLORRED;
VAR4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
VAR5:=SMA(VAR4,13,8);
操盘:=CEILING(SMA(VAR5,13,8)),LINETHICK2,COLORBLUE;
操盘线:=MA(3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*SMA(SMA((C- LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1),5),LINETHICK2,COLORRED;
VARG:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR80:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
VAR81:=VARG<REF(VAR80,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);
DRAWTEXT(VAR81 AND COUNT(VAR81,30)=1,0.45,'大资金进'),COLORRED;
STICKLINE(VAR81 AND COUNT(VAR81,30)=1,0,0.5,4,0),COLORFF00FF;
VARH:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR82:=(HIGH+LOW+CLOSE)/3;
VAR83:=(VAR82-MA(VAR82,14))/(0.015*AVEDEV(VAR82,14));
VAR84:=(VAR82-MA(VAR82,70))/(0.015*AVEDEV(VAR82,70));
VAR85:=IF(VAR83>=150 AND VAR83<200 AND VAR84>=150 AND VAR84<200,10,0);
VAR86:=IF(VAR83<=-150 AND VAR83>-200 AND VAR84<=-150 AND VAR84>-200,-10,VAR85);
VAR87:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR88:=100-ABS(VAR87);
VAR89:=IF(VAR88<90,VAR88,100);
VAR90:=IF(VARH>0,VARH,0);
VAR91:=IF(VAR84>=200 AND VAR83>=150,15,IF(VAR84<=-200 AND VAR83<=-150,-15,VAR86))+60;
VAR92:=VAR90>48 AND VAR91>60 AND VAR89<100;
DRAWTEXT(VAR92 AND COUNT(VAR92,30)=1,0.45,'大笔出货'),LINETHICK1,COLORFFCC66;
STICKLINE(VAR92 AND COUNT(VAR92,30)=1,0,0.5,4,0),COLORFFCC66;

通达信MACD带量指标公式

 

相关文章